Previous 1 2 3 Next 41 Replies Latest reply: Jan 23, 2015 6:35 PM by bananas13
f0rgiven Level 1 (0 points)
I am posting here b/c the camera will not mount (forgive me if this is the wrong forum). So i have a canon powershot elph that use to mount in osx but now, it will not mount (on the desktop. No way to view the files on the memory card). How do i get this camera to mount? iPhoto see it and is able to download any photo/AVI from the camera. I also have reset the camera and run checkdisk /f on that other OS to see if that would help. Still, No love!

Message was edited by: f0rgiven

Message was edited by: f0rgiven

iMac 24", Mac OS X (10.6.3)
  • a brody Level 9 (65,390 points)
    iPhoto see it and is able to download any photo/AVI from the camera.

    It seems the only problem is that it won't mount on the desktop. The fact that iPhoto will see the camera is enough to just drag and drop the photos from iPhoto to a folder on the desktop, so those photos will appear there.

    Your other options is to make sure that all items under Finder menu -> Preferences -> General are checked to show on the desktop, and make sure the contents of Users -> yourname -> Desktop folder are all empty except one folder to hold all the files that are on that folder. That will allow you then when you close all Finder windows and View menu -> Arrange by -> kind to see all mounted items on the upper right corner of your Desktop. If it doesn't it is a bug in the firmware of the Canon. At least iPhoto is able to see it. So you don't have to switch operating systems to see it.
  • f0rgiven Level 1 (0 points)
    a brody wrote:

    It seems the only problem is that it won't mount on the desktop. The fact that iPhoto will see the camera is enough to just drag and drop the photos from iPhoto to a folder on the desktop, so those photos will appear there.

    Well, kinda The real problem is i can not seem to get any AVI video from the camera to iMovie '09 (i was able to do this before).
    Your other options is to make sure that all items under Finder menu -> Preferences -> General >are checked to show on the desktop,

    Did this and still did not see the camera mounted.
    Canon's do mount in osx, right?
  • Francine Schwieder Level 6 (19,045 points)
    I don't think any Canon has ever mounted in OS X. Get a card reader, then you can mount the card as a drive by putting it in the reader. Alternatively, you can see if you have better luck with Image Capture than with iPhoto to do what you want. Launch Image Capture, then connect your camera and select in from the Devices list in the Image Capture window. You should then be able to make using Image Capture the default action when you connect your camera. You should have access to all the files on the card, and be able to transfer them to wherever you want.

  • Alcivar Level 1 (0 points)
    Canon has of course mounted in OSX. I've been mounting my Canon ZR800 for over a year now. Today it doesn't mount and I keep getting the Disc Removal error. I dumped the iMovie plist and rebooted but it doesn't help. I'm sure my firewire cable is good.

    Interesting - If I have the camera on when I start iMovie, the program freezes and won't even force quit until I shut the camera off! If I start the camera after I open iMovie and try to import from camera iMovie tells me no camera connected. So the frustrating circle continues.

    OSX 10.5.8
    iMovie '08 (7.1.4)
  • Jay Warner1 Level 1 (20 points)
    I'm not alone! My Canon Digital Rebel XT has never 'mounted' with either OSX 10.4.11 or 10.6.1, .2, .3, or .4. It has been observable by iPhoto, old and latest releases, and by LightRoom 2.3, & 2.7. These softwares recognize it & load images from the camera at a great rate, but the camera never made it to the listed device level. iPhoto will find the camera well enough to upload pictures.

    Lightroom 3, however, requires that the item be a recognized device before it will upload images well. LR 3 finds the camera, automatically sets up to upload images, but can never find any on the camera. I have discussed this with Adobe (LightRoom people), and I'm asking Canon for help, too. Now I'm asking Mac people for understanding.

    Now what's going on here? The System Profiler does find it, on the "USB High-Speed Bus:" on my Power Mac as a Canon Digital Camera. But it is not on the Device list.

    How do I tell the machine to go out and look for devices again? how do I tell the machine to list the devices it finds? Or correct the errors it ran into?

    I am about to install & restart something called USB Overdrive, in the hope that this will do something positive. Don't know your opinion of that action, but here goes...

  • Jay Warner1 Level 1 (20 points)
    OK, I think I have the cause & cure.

    Canon says the software [firmware?] bundled with the Canon Rebel XT "is not fully compatible with the latest version of OSX." I can continue to automatically bring up iPhoto or use ImageCapture, in any case. Thanks, but I want LightRoom 3. Canon recommended that I set the controls in ImageCapture to specify opening LR3 when a camera is detected. I did, but it was doing this before, so I saw no difference. Also, I'm not sure it was doing it reliably, before or after this change.

    This software incompatibility might explain why the Canon Rebel XT was not loading into LightRoom 3, but would not explain why it was not recognized by the Finder to add to the Devices list. The Canon wouldn't get added to the Devices list in OSX 10.4.11, either.

    ImageCapture could easily see the images on the camera, and could copy them to a HD without difficulty. But it's not LR3, and nothing convinced the Finder to add the camera to the Devices.

    What I did find, eventually, is this:

    I set ImageCapture to open itself when it recognizes a camera.

    I jack in the camera, and ImageCapture opens.

    THEN I open LightRoom 3. It comes up with the present images in the library.

    I invoke on the Import command by button or keyboard command. It opens the import display, with the images from the camera.

    I set the LR3 import settings as I want them. I make a habit not to erase the camera, until all is said and done, and disconnected from the computer.

    I click the Import button, and it does!


    If I have it open ImageCapture first, that seems to persuade LR3 that images are on the camera.
    Sometimes iPhoto accomplishes the same end.

    I went through this sequence a number of times, starting from neither software open. I tried different sequences - LR3 then ImageCapture, camera first or last, etc. The above sequence worked reliably; the others' responses confused me.

    Those of you with similar Canon uploading problems, see if this helps any. If you don't have ImageCapture, try it with iPhoto instead. Just open it first.

    Does this work around work?
  • MoonCaine Level 1 (40 points)
    My Canon PowerShot G6 does not mount -- that is, it is not seen by either iPhoto or Image Capture (I already realize it's not supposed to show up as a disk drive).

    I think this might be the first time I used the camera since upgrading to Snow Leopard almost 2 months ago.

    Jay, you wrote, "I set ImageCapture to open itself when it recognizes a camera."

    How is that done? I opened Image Capture (the Apple program), but find no preferences or settings to change.
  • MoonCaine Level 1 (40 points)
    This problem still unsolved. I haven't yet found a way to make my Snow Leopard Mac recognize that I plugged in my Canon Powershot G6 camera.

    My older PowerShot G3 works fine when connected, though.
  • malcolmlewis Level 1 (0 points)
    I have a similar issue.

    If I connect my Panasonic GF1 to my MacBook Air via USB, the camera shows up as an external drive under Devices in the Finder. This makes is quick and easy to transfer photos from the camera to any folder I like.

    When I connect my Canon S90, it does not show up as a Device (or anything else) in Finder. I know I have the correct driver because iPhoto sees the USB-connected S90 as an external drive under Devices

    So iPhoto sees the USB-connected S90 as a Device. Finder does not. Makes no sense to me.
  • PixelRogue Level 1 (0 points)
    Add me to the list.

    Brand spanking new MacBook Air 13", all software updated. Canon Powershot A620 will not mount. Mounts find on the MacBook Pro (also 100% updated software).

  • PixelRogue Level 1 (0 points)
    Update: Zapping p-ram now has the camera showing up under the USB contents of the System Profiler. Still will not mount or be recognized by programs, however a step closer.
  • filmeire Level 1 (0 points)
    Thanks Francine; I never knew image capture could do this. I upload much quicker now instead of using iphoto.
  • liz13fwwm Level 1 (0 points)
    I have a brand new MacBook Pro and I'm running into the same problems of trying to upload images from my Canon Digit Rebel XT. The camera is not recognized in the Finder or iPhoto or Picasa.

    Image Capture was indeed the solution. I opened Image Capture in the Finder, it recognized the photos, and I'm now uploading photos from the Canon.

    Strange issue but works. Thanks all.
  • bcFrisco Level 1 (0 points)
    But Macs are the best!! It shouldn't care what camera, it's usb, let me read what's connected. How difficult is that??
Previous 1 2 3 Next