10 Replies Latest reply: Apr 10, 2010 5:32 PM by PAHU
grobbs Level 1 (0 points)
The Canon IR 3100C is on the work network of Windows PCs. I am the only one for now operating with a Mac. When adding printer, I can see it in the windows tab, under the workgroup. When I add it like this, with the driver downloaded from Canon site (PPD v2.85). The print job seems to execute, but nothing comes out the printer. This method also doesn't show the ink levels etc.

So I tried adding the printer with it's IP address. When I use IPP with the queue 'ipp', it looks like it works, but nothing comes out. If I use LPD, the print job is paused, and will not run. The connection via IP shows the ink levels of the printer. I have tried the above with the generic PS driver, and the Canon IR C3100 and Canon IR 3100C EUR drivers, none work.

I'm not sure if I have not got the write print queu names, wrong driver, or if perhaps the printer itself is incorrectly setup.

When looking at the printer configuration it says that IPP and LPD is activated.

I feel like I have tried just about everything. Appreciate any insight from those more experienced than myself.

MacBook Pro, Mac OS X (10.6.3)
  • PAHU Level 6 (16,119 points)
    The first thing I would check is that your iR3100C supports Postscript? I say that because the Generic PS or the Canon PPD should have worked. To check if it has Postscript support, you can open your Internet browser and type in the IP address of the copier. This will get to the internal web page of the iR and under Additional Functions > Custom Settings > Printer Settings you will see what printer languages are supported. Note that you may be prompted for an Admin account to open the Custom Settings page.

    With the Custom Settings page open, under the Printer Settings heading you will see UFR II and probably PCL but possibly not PS. Without PS, you won't be able to use the Generic PS driver or the Canon PPDs. But you could use Generic PCL Laser Printer if it has PCL support.

    If the PS option is present, then you may find that the printer has Dept ID Management enabled. Some admins enable this setting to stop excessive colour usage. This setting is also located under Additional Functions. Now with this setting enabled, the user would be required to enter an ID/Password to print. Unfortunately the PPD or Generic PS driver cannot support this function. So you would need to enable a setting under Dept ID Management called 'Allow Unknown IDs'. This means that a computer that is not capable of entering an ID can still print to the copier. Of course any print jobs without an ID would not be logged or restricted, so your admin may not agree to enabling this.

    Hope this gives you some help. Please reply if needed.

  • grobbs Level 1 (0 points)
    Pahu, Thanks for your quick response. In the Additional functions, Custom Settings, Printer Settings, I have a whole bunch of options about quality, half tones etc, but nothing to do with PS/UFR etc...

    I have been through all the menu items and find nothing to do with PS UFR PCL. In custom settings, there is 'Custom commen settings', which is about priority drawers etc, then 'Timer Settings', then 'printer settings' with a sub item of 'settings' and then a bunch of 'Network Settings', including 'TCP/IP', 'Netware', 'SMB', 'SNMP' etc.

    Anywhere else I could look? perhaps on the printer?
  • grobbs Level 1 (0 points)
    Pahu, I do see the Dept Id management, and it is not enabled
  • PAHU Level 6 (16,119 points)
    grobbs wrote:
    Anywhere else I could look? perhaps on the printer?

    Sorry but I was using our iRC3380 as a reference. I guess the iRC3100 being an older model does not have the same settings.

    So, I think you could use the copiers touch panel to access the menus. If you press Additional Functions then Report Settings then Printer, you should see PCL and PS. If you select PS you should then see Configuration Page. Select this and then press Yes when prompted. This will print a PS Config page which proves you have the PS option.

    If you don't see PS, or even PCL, under Report Settings > Printer, then your copier only has the UFR printer language. Unfortunately, this was the first version of UFR and there was no Mac driver made for it. So this would mean that you will not be able to print to it from your Mac.
  • grobbs Level 1 (0 points)
    I have strolled through the menu on the printer, and no mention of the PS or the ability to print a report on it. Only a usage report. I'm starting to think that it may just be outdated and indeed without the PS ability. Thanks for your time and help.
  • grobbs Level 1 (0 points)
    Pahu, do you know if the PS option is hardware related, or could the Canon technician implement a firmware update? Thanks
  • PAHU Level 6 (16,119 points)
    I believe the option is a mixture of hardware and firmware. First of all you needed a particular type of Boot ROM to give you the network printer function. And then the tech needs to install a new system to support the additional printer languages.

    This was the case with our previous iRC3200, which was like a big brother to the iRC3100. I remember this machine being delivered without the PS function, which didn't go down well with our Mac users. It took several calls and some strong words before we got a tech out to 'update' the machine.

    The problem you may have is getting this ROM. I would guess that this series started selling about 6 or 7 years ago, so the chances of the ROM being available could be slim. Still, give your Canon tech a call. You won't know until you ask.

    Good luck....
  • grobbs Level 1 (0 points)
    Thanks Pahu. I appreciate your help.
  • josh_k3 Level 1 (0 points)
    Pahu, do you know if your solution will also work on an iR 4570 printers?

    Since the Snow Leopard update, no Mac here is able to print anymore.

    Canon totally messed this up. Guess the next printers here will be Kyocera...
  • PAHU Level 6 (16,119 points)
    josh_k3 wrote:
    Pahu, do you know if your solution will also work on an iR 4570 printers?

    It all depends on the configuration of your iR4570...

    If it only has UFR2 support, then Canon does not seem interested in providing a solution for Snow Leopard.

    If it has also PCL5e/PCL6, then you will be able to use the 'Generic PCL Laser Printer' driver that is included with 10.6.

    And if it has support for Postscript, then you will be able to use the Canon PPDs, which work fine on 10.6.

    So, you need to check the printer configuration of your iR4570. Like the iRC3100, this can be done on the copier, pressing Additional Functions then Printer Settings. Scroll through the menus to see what printer languages you have. Hopefully you have PS which will make life a lot easier for you.