Previous 1 4 5 6 7 8 Next 110 Replies Latest reply: Jan 2, 2012 5:17 PM by teshome Go to original post
  • hele425 Level 1 Level 1 (0 points)
    I have the 3G version and as of a few days ago the time is just a little over six hours off. I have tried all of the following and nothing has changed: powering off, sync with iTunes on my Mac, reset through the settings menu. Is Apple still replacing these iPads? I don't want to set it manually as I travel a lot and I like that it recognizes (or used to) the different time zones.
  • hele425 Level 1 Level 1 (0 points)
    To set it automatically go to Settings, General, Date and Time and it should be there. I suspect that it is only available for the 3G version and that it is tied to phone service.
  • Robert Stoeber Level 1 Level 1 (0 points)
    Just to clarify something, the Wi-Fi-only iPad does not appear to sync its internal clock to any time servers, ever, even after a full power off. This is really strange for a mobile device that's designed to use the Internet for storage, backup, app purchases, communication, etc.

    Besides that, you can't get an app to fix that problem. There are apps that will connect to time servers and display the correct time, but according to the vendors "Unfortunately, 3rd party iOS applications cannot change the internal clock. So Emerald Time can display the right time but it can't make it available to other apps."

    Not sure why this isn't built in, but I hope we can get an update from Apple get the right time.
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    UKenGB wrote:
    I also would like to know this. Or more specifically, where is this 'Set Automatically' option. I certainly have not been able to find it. I wish people wouldn't make suggestions to do something that doesn't exist. Or am I wrong and I just cannot find it?

    It also still has not been answered if there is any automatic setting of the time at all. Thing is, on the iPhone there IS the option to 'Set Automatically'. So when it is possible to do so, it appears Apple provides the option to do it or not. So the fact that the iPad does not have the option (unless I'm wrong about that) indicates to me that there is NO automatic time sync.

    Does anyone have the real answers?


    In iOS 4.2.1, Settings > General > Date & Time > Set Automatically

    One possible answer is whether this option will be visible for wifi-only models. Based on how it's supposed to work, I don't think that it will be.

    The real question is whether this does anything in the absence of cellular data, i.e., when operating Wifi only or airplane mode? What it usually does to me is to make the clock even more inaccurate when I turn that mode on. For example, on this last test cycle it turned a 77 second deficit (against an NPT clock) to a 222 second one. Subsequent fiddling with settings there in Settings haven't managed to change the deficit; the iPad continues to show 3-4 minutes fast.
  • slyguy_28 Level 2 Level 2 (165 points)
    +I bought my iPad on December 20th. I didn't check the time, but was pretty sure that it was accurate. I never paid any attention to it. I just checked it using the Emerald time App and saw that it was 79 seconds slow. I was pretty surprised, but not overly so considering that the clock doesn't have a 3G carrier to sync itself with. I reset the time manually using the time displayed running the same App on my iPhone which was only 1 second fast. I guess I have pretty good reflexes because now my iPad is .32 seconds slow and my iPhone is still 1.12 seconds fast.+

    +In all, my iPad has kept pretty good time. If it loses a second here or there, I'm still very happy with it...+
    Sly
  • ClintandMary Level 1 Level 1 (0 points)
    Yes, it's suprizing that Apple didn't include this for WiFi-only models... Not to mention disappointing. But I'm glad I'm not missing anything. I was starting to feel stupid for missing it.
  • StoneSoup Level 1 Level 1 (45 points)
    For what it's worth, I think Robert's on the right track. My 3G iPad started running four or five minutes faster than my iMac/Macbook Pro/iPhone 3G (all of which automatically sync'd with Apple's timeservers). This has been going on for several weeks now -- at least, that's when I started noticing that my iCal alarms were popping up on my iPad several minutes before all of my other devices chirped.

    I use my iPad primarily at home on WiFi, so I just normally leave 3G turned off. Speculating that that had something to do with it, I just turned 3G back on. The time synchronized to exactly the same time as my iMac/MBP/iPhone.

    Hmm...

    I've turned off 3G once more. It'll be interesting to see how long it takes for the iPad to drift away again.
  • Monk Edsel Level 1 Level 1 (5 points)
    I bought my wifi iPad on launch day, and it's been gaining time ever since. It was 7 minutes ahead until I found this thread and manually set the clock. I'm not sure which is more disconcerting; the iPad's lack of accurate timekeeping, or the necessity of manually setting its time.
  • davek0974 Level 1 Level 1 (45 points)
    What bothers me is that I paid £590 for an electronic device that can't even keep time!!!

    My fridge keeps better time.

    My iPad runs fast and does not self correct when connected to my mac.

    It's very annoying.
  • Dan Hofferth Level 1 Level 1 (5 points)
    My iPad (wifi+3g) had been keeping perfect time until just recently, when I noticed that it was fast by about 5 minutes. It was still set to "auto" time, it's always connected to wifi, rebooting didn't help, and my iPhone (on the same network) was exactly correct.

    Then it hit me... the one thing I had changed recently that might be related...

    I went into Settings... Cellular Data... and turned Cellular Data back to "On". A week or-so ago, I had turned it off thinking, "I never use the cell data feature on this thing... why not turn that off? Maybe it'll save a bit of battery power?"

    I flipped it back to on and, in about 5 seconds, the clock corrected itself to within 1-second of NNTP.

    Again, I'm not paying for cell data for this device... I never have. I'm guessing it's designed to get correct time from the cell towers passively.

    Worked for me... hope this is helpful to some of you.

    Dan
  • Matthew Palm Level 1 Level 1 (40 points)
    Dan!!! You are, indeed, the man

    My WiFi+3G iPad has slowly been gaining time over that last few weeks. I was all ready to take it in to the store to get it swapped out when I decided to check the Discussions forum. And BAM!, your answer was there.

    I, too, do not use 3G at all. I don't have an account, haven't entered any name or billing info, nothing. I just switched Cellular Data on as you suggested, and in 5 seconds, I got back on time - my iMac, my iPhone, and now my iPad all have the same time.

    Thanks
  • Ferneaux Level 1 Level 1 (0 points)
    Dan is DEFINITELY the man!

    His suggestion of simply turning back on the Cellular Data setting worked for me too!

    My iPad was running 6+ minutes fast.... now it's only 1.8 seconds faster than the timeanddate.com servers!

    Thanks, Dan! That time bug was making me C.R.A.Z.Y!!
  • bragiw Level 1 Level 1 (0 points)
    I have a 64GB wifi 3G and noticed a couple of days ago that the clock was about 4 minutes too fast. using set time automatically. Tried all that has been suggested here; turning wifi, mobile/cellular, and bluetooth on and off, shutting down and rebooting, syncing again and again but nothing worked. Took it to an apple retailer/repair and they had never heard of this but suggested I do a restore. This I did and although it takes a few hours it fixed the time warp for me. The process offers restoring with the entire contents and profile as previously used and so all I lost was a couple hours from using the iPad but regained the correct time.
  • bragiw Level 1 Level 1 (0 points)
    I have a 64GB wifi 3G and noticed a couple of days ago that the clock was about 4 minutes too fast. using set time automatically. Tried all that has been suggested here; turning wifi, mobile/cellular, and bluetooth on and off, shutting down and rebooting, syncing again and again but nothing worked. Took it to an apple retailer/repair and they had never heard of this but suggested I do a restore. This I did and although it takes a few hours it fixed the time warp for me. The process offers restoring with the entire contents and profile as previously used and so all I lost was a couple hours from using the iPad but regained the correct time.
  • ihaveanipad24 Level 1 Level 1 (0 points)

    Have you tried going to settings and changing the time zone?

Previous 1 4 5 6 7 8 Next