2 Replies Latest reply: Apr 8, 2010 10:18 AM by Robert Newall
ejg999 Level 1 Level 1
This weekend I upgrade to Snow Loepard and then version 10.6.3. I now experience high cpu usage (and slowness)with Safari. An Apple rep told me there have been reports of this issue, but no resolution.

As a result I need to use a different web browser. I have tried Chrome (Java apps don't work at all) and FireFox (crashes every time). What other suggestions do people have that I can use as a web browser?


MacBook Pro 2.2hz 4GB, Mac OS X (10.6.3)
  • macjack Level 9 Level 9
    Have you "reset Safari" from the Safari Menu?

    Also try Safe Mode (It will take more time to startup in Safe Mode because it runs a directory check.)

    If your apps function correctly that way, go to System Preferences >> Accounts >> Login Items, and remove them. Boot normally and test. If not go to Users/(yourname)/Library/Contextual Menu Items and move whatever is there to the desktop. Then do the same with /Library/Contextual Menu Items. Lastly, try moving ~(yourHome)/Library/Fonts to your desktop and restarting.
    EDIT: In the case of Safari look in Users/yourhome/Library/Internet Plug-in items and
    /Library/Internet Plug-in items.

    Log out/in or restart, if that sorts it start putting items back one at a time until you find the culprit.


    Message was edited by: macjack
  • Robert Newall Level 3 Level 3
    Not technical. Try Camino and Opera. The latter is a combined browser/email client. The interface is different but can be easily got used to. I find browsers develop hitches that clear with a later version or without. Since I want to have the use 'now', I always have about four around.
    You should though follow the other advice and try to find what is wrong with your Safari.