Previous 1 2 Next 19 Replies Latest reply: Apr 28, 2010 3:53 AM by caa100
caa100 Level 1 Level 1 (10 points)
Symptom: signal not weak, but iPad periodically becomes "not connected"
Workaround: go to settings, find the network, and connect to it.
Note: password is not being forgotten in this case.

I think my iPad is having problems when it's DHCP lease expires. It does not appear to be renewing its lease gracefully. Instead it winds up disconnected.

The DHCP lease expiration is a theory, but it seems to fit. I noticed that disconnections happen about once per day, which corresponds to the 24 hour client lease time as set on my router.

Checking the router's lease table, I also saw that several devices were renewing at about the same time, which perhaps also contributes to the problem. Potentially, there could be a brief conflict when this happens When there is an IP conflict, most other devices will just request a new lease. But I figured I could prevent this by manually renewing the iPads lease so that it would have a new renew cycle.

This morning, I happened to be using it when it was due to renew it's lease. I was browsing the web, and sure enough there was a momentary "connecting" popup, but I did not get dropped..

I am going to try a static IP next.
  • tvdavis Level 1 Level 1 (0 points)
    I have observed that, despite sitting right next to my router & having full signal strength, the moment I try to use the "Back" button in the Safari browser, the connection completely drops. It re-instates itself in a few seconds.

    This is just the latest of the many Wi-Fi issues I've noticed in three days of ownership.

    I've done the Reset, turned up the screen's brightness, changed router settings, used different Wi-Fi hotspots, used a Verizon Mi-Fi. Still having random drops.

    I'll be calling in a ticket to Apple tomorrow, and I have no intention of making multiple trips to the (not close by) Apple store. I also have no intention of paying a restocking fee on a faulty device. This is unacceptable.
  • coppertrail Level 1 Level 1 (45 points)
    I've observed a 100% signal strength with the router when the ipad is asleep. When I wake it, the signal drops to 50 - 60% within 30 sec and drops even lower when I load a page.

    I too have given my ipad a static ip to workaround the dhcp lease issue.
  • Graham Outterside Level 4 Level 4 (2,910 points)
    coppertrail wrote:
    I've observed a 100% signal strength with the router when the ipad is asleep.


    Out of interest, how did you see that ? if its asleep the display is off isn't it ?
  • coppertrail Level 1 Level 1 (45 points)
    Hi Graham,

    I'm actually seeing this on my router's wireless status page, not on the device itself. Log into your router and you. May have a similar page. My router is a DIR-655.
  • caa100 Level 1 Level 1 (10 points)
    Theory disproved.

    Static IP, and once again while browsing (with full bars) I was interrupted by the annoying "Connecting..." popup.

    DHCP lease renewal and/or IP address conflict definitely ruled out.

    Perhaps I need to return this iPad....
  • caa100 Level 1 Level 1 (10 points)
    Despite my previous post, I think that the *static IP has solved my problems*. I have been running that way close to a week, and have not been dropped.

    Every once in a while, I will be in the browser and the screen will dim while the "connecting..." popup displays. But it always manages to reconnect.

    When I was using DHCP, I would often wind up in a "not connected" state.

    I do think the iPad's DHCP client is wiggy.
  • DrVenture Level 2 Level 2 (180 points)
    caa100,

    What is the make and model of your wireless router and what firmware are you running?
  • caa100 Level 1 Level 1 (10 points)
    DrVenture wrote:
    caa100,

    What is the make and model of your wireless router and what firmware are you running?

    Linksys WRT-54Gv3,FW 4.30.5. Configured for G-Only, WPA2/AES, DHCP enabled with 24 hour client lease time. It is using a channel that was selected for minimal conflict with neighbors after taking a site survey with NetStumbler (which I periodically repeat.)

    The router and its configuration are not the issue. More devices than I can count have successfully connected to it as DHCP clients. Between our own devices and those belonging to guests: desktop PC's, laptop PC's, wireless printers, iPhones, iPod touches, video game consoles, and even a TV. (Yes, it is configured to allow enough DHCP clients, and yes, static IP's are not overlapping with the range for the DHCP pool. )

    Among these devices, only the iPad has ever had a problem.

    I am satisfied with my workaround at home (using static IP).

    But this is not something I can do when traveling, where I do not control the router or network.
  • Doug Mokaren Level 1 Level 1 (30 points)
    This seems to be a known problem with DHCP leases. Apparently the iPad will not drop the lease, keeping the previous IP and not renewing. The router gets the signal that the iPad goes offline, so it reassigns the IP to another user. When the iPad goes back online, two users have the same IP and loss or connectivity occurs. Here's some writeups from problems happening at Princeton U.

    http://db.tidbits.com/article/11195 and http://news.softpedia.com/news/Lay-Off-the-iPad-Princeton-University-Tells-Stude nts-139830.shtml
  • UG64 Level 2 Level 2 (150 points)
    I have tried various networking configurations at Apple Care's request. As per Apple's suggestion to Restore your iPad to the factory settings *will fix* the issue, until you load the iPad with content. I'm currently trying to determine just what is kicking the iPad off the network, blocking or corrupting the iPad.

    When loaded, my iPad will stream, browse, transfer files just fine, but when the iPad goes to sleep it will have a problem connecting after it wakes up and using the workaround to turn wi-fi off then back on again. I had to restore my iPad as a new iPad and not from a backup, because the backup restored the fault. I've restored this iPad three times so far and two more times a new iPad at Apple Care's request. This morning Apple disabled over dozen apps on my iPad, NetFlix, ABC.com, Yahoo Entertainment and more which still didn't fix the problem.

    As of this writing I've got my iPad restored back to factory settings and it is currently working just fine, when I start putting apps back on the thing just might be a different story.
  • jeffreylyons2007 Level 1 Level 1 (0 points)
    You might be onto something. Don't some apps like Aim and Facebook constantly push data through? Maybe it's an app that's causing issues.
  • PianoBrad Level 1 Level 1 (0 points)
    They had me restore back to factory settings but that didn't work. (The senior support tech apologized for the underling who made me do it.)

    What did fix the problem for me was switching from 64-bit WEP to 128-bit WEP encryption.
  • mr-internet Level 1 Level 1 (15 points)
    I had the same problem this just worked for me, but you are sooo close
    http://discussions.apple.com/thread.jspa?threadID=2401779&tstart=0
  • smoooth Level 1 Level 1 (0 points)
    I'm also having strange behavior with the wifi connection. Sometimes won't connect even though wifi has strong signal and ip address. I think it's a bug in the wifi settings app. It doesnt know how ton save the settings or may be a dhcp. I've switched to static ip to see if I experience the same. The problem in general appears sporadic, only shows up about once every day or so.
Previous 1 2 Next