Skip navigation

MBP often won't wake after sleep.

69319 Views 244 Replies Latest reply: Jun 5, 2013 8:12 PM by PMoore91 RSS
  • PMoore91 Calculating status...
    Currently Being Moderated
    Apr 27, 2010 1:12 AM (in response to Dale Weisshaar)
    I've got the same issue. I did try the SMC Reset, and the next time I closed my MacBook, it ran into the same problem. Believe me, it's not the SMC. I did find it interesting that Parallels was mentioned, because a good deal of the time I've had the problem, VMWare Fusion was open. I can't say for sure that this is 100%, and I know for certain that there is a percentage of times that I have managed to successfully close and re-open the MacBook with Fusion open, but it might be interesting to test.

    I'll let you all know what the results are in a few days.
    MacBook Pro, Mac OS X (10.6.3), It's still got the removable battery, but it was the latest of that type.
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Apr 27, 2010 11:43 AM (in response to Ryzl1987)

    I forgot to mention doing a PRAM reset also.

     

    DALE

     

     

    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.3), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • PMoore91 Level 1 Level 1 (65 points)
    Currently Being Moderated
    Apr 28, 2010 10:33 AM (in response to Dale Weisshaar)
    Okay, just did a PRAM Reset, crossing my fingers for luck.

    Also, I can say for sure that it's not an issue with Virtual Machine software.
    MacBook Pro, Mac OS X (10.6.3), It's still got the removable battery, but it was the latest of that type.
  • georgem cz Calculating status...
    Currently Being Moderated
    Apr 28, 2010 11:23 AM (in response to Ryzl1987)
    Same problem here.
    It seems from my observation here, that it is somehow related to the swap file or something - my MBP won't wake up usually after heavy memory usage (like running parallels or something like that)
    MacBook Pro, Mac OS X (10.6.3)
  • Yera Meyahu Calculating status...
    Currently Being Moderated
    Apr 28, 2010 11:25 AM (in response to georgem cz)
    Agreed. A memory/sleep problem from 10.6.3?
    MacBookPro5,3, Mac OS X (10.5.7)
  • qlcrst Calculating status...
    Currently Being Moderated
    Apr 29, 2010 3:14 AM (in response to Ryzl1987)
    I'm having the same problem on my MBP since updating to 10.6.3. It only seems to occur while or shortly after I'm using my Virtual Box and goes along with some erratic system behavior, like heavy lag and program freezes that didn't occur before. I could also quite easily tab between my Virtual Box and my OS X programs, this seems to overtax the computer now.
  • PMoore91 Level 1 Level 1 (65 points)
    Currently Being Moderated
    Apr 29, 2010 8:39 AM (in response to Dale Weisshaar)
    PRAM Reset didn't help, the issue just presented itself again. There are no consistent applications that are open, and I haven't had this issue for long. It just started this year.
    MacBook Pro, Mac OS X (10.6.3), It's still got the removable battery, but it was the latest of that type.
  • DylanRhea Level 1 Level 1 (105 points)
    Currently Being Moderated
    Apr 29, 2010 10:53 AM (in response to PMoore91)
    ****. I thought I had this beat. I did all the resets and maintenance processes, and the problem disappeared for about a week. I use Parallels 5 very heavily every day, and it was sleeping and waking just fine. I usually suspend the VM for the night before shutting down. Problem reappeared today and I had to hard boot everything. Again, just appeared in 10.6.3. Not sure there is a real pattern to this.
    15" MacBook Pro, 2.8GHz 4GB RAM, Mac OS X (10.6.3), 2TB External Storage via Airdisk
  • PMoore91 Level 1 Level 1 (65 points)
    Currently Being Moderated
    Apr 30, 2010 12:06 AM (in response to DylanRhea)
    I haven't noticed a pattern either. Sometimes it happens after the MBP has been closed for hours, and sometimes when it's closed for mere seconds. Sometimes, my virtual machine is open, and sometimes it's not. There is no one consistency except the MBP itself and Snow Leopard. I didn't used to have this problem, and I haven't abused it, so I doubt it's the Mac, but it's not just Snow Leopard, because a friend of mine, who runs Leopard, is having the same issue. This is really starting to mess with my ability to do my job. I need this problem resolved yesterday.
    MacBook Pro, Mac OS X (10.6.3), It's still got the removable battery, but it was the latest of that type.
  • appity Calculating status...
    Currently Being Moderated
    Apr 30, 2010 12:34 AM (in response to Ryzl1987)
    I have been having this problem since Leopard. I'm now on 10.6.3 and getting it again. I can't pinpoint exactly yet, I thought the problem was disconnecting from my external display but I actually think it has more to do with disconnecting from the power. It happend a few mins ago, I'm going to try an replicate the problem this time with my files saved and closed!!
    MBP 2.4GHz Intel Core Dua 2, Mac OS X (10.6.3)
  • DarrenNavitas Calculating status...
    Currently Being Moderated
    Apr 30, 2010 2:58 AM (in response to Ryzl1987)
    Hi All,

    I'm getting exactly the same issue on occasion! Most of the time it sleeps and wakes fine - however randomly I will get the 'dark screen of death' (!!) when trying to wake from sleep. The diagnostic message show the same that everyone else has reported :

    30/04/2010 08:40:54 configd[15] Wake: Drivers Failure - AC 99 - HDEF GIGE SATA RP01 IXVE
    com.apple.message.domain: com.apple.powermanagement.wake
    com.apple.message.signature: Drivers Failure
    com.apple.message.result: Failure

    I do run Parallels 5 however this issue arises when I sleep the machine with Parallels still running and when I have shut Parallels down completely -so I don't think that's an issue.

    Come on Apple - I too have lost work, and it's frustrating when you begin to trust that something is reliable and then get caught out several times!

    Cheers
    Darren
    17" MBP Unibody, Mac OS X (10.6.3)
  • georgem cz Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 30, 2010 3:44 AM (in response to Ryzl1987)
    Tried to reapply the 10.6.3 from the combo, but no success. Still the same.

    For me it looks that if the memory usage reaches some limit then the sleep problem will appear. Typical problem scenario I have is - start parallels, use VM for a while, suspend it, wait a while, start another VM, work, suspend, wait for HDD to calm down, close the lid, wait a few secs (or more, it doesn't matter) and you have a nice black screen of death.
    MacBook Pro, Mac OS X (10.6.3)
  • Matt Revelle Calculating status...
    Currently Being Moderated
    Apr 30, 2010 4:16 AM (in response to Ryzl1987)
    I've tested two of the proposed workarounds: ensuring the same power configuration (battery vs. plug) when sleeping and waking; and turning off secure virtual memory. I've had the black screen of death with both.

    I recall having a problem like this years ago on a different laptop, but these recent problems didn't start until after 10.6.3. If this BSOD is the same problem that 10.5 users are having, I'd guess a driver update that became available in 10.6.3 was also a part of a 10.5 update.

    Until this is fixed, save obsessively often!
    Macbook Pro (Late 2008), Mac OS X (10.6.3), 4GB RAM
  • JoeyR Level 6 Level 6 (8,275 points)
    Currently Being Moderated
    Apr 30, 2010 5:42 AM (in response to Ryzl1987)
    I have been having the same problem... It seemed to have started after I had upgraded from 4 to 8GB. The memory itself seemed fine as there were never any problems related to actual use. Since the only difference between sleeping with 4GB vs. 8GB would be the "hibernation-like" safe sleep mode that writes the contents of the RAM to your drive before actually sleeping, it seemed worth while to investigate. I disabled safe sleep and the problem has not come back. You can disable safe sleep in Terminal:

    sudo pmset -a hibernatemode 0 (and reboot)

    Just change the last "0" to a 3 to re-enable it. There is an actual utility to do the same thing if you don't want to play around in Terminal:

    http://www.jinx.de/SmartSleep.html

    I haven't actually used the app... so I can't say if it is or isn't compatible with the 2010 Macs.

    As I use an SSD, it's probably best to save the wear by writing an 8GB file everytime I sleep the machine anyway. I'm never in the habit of leaving things open when I put my machine to sleep anyway.

    Granted... this would still seem to indicate some underlaying problem.
    Core Duo BlackBook - SR MBP - 13.3" MB Pro - 8GB Gen 2 and 3 Nanos, Mac OS X (10.6)
  • Yera Meyahu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 30, 2010 6:34 AM (in response to JoeyR)
    I had been using SmartSleep when this all first started, and it was one of the first things I removed (all sleep settings reset, of course). However, I think I was using it in 'Smart' mode, which still uses HIbernate in certain circumstances.
    MacBookPro5,3, Mac OS X (10.6.3)
1 2 3 4 5 ... 17 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.