Previous 1 2 Next 19 Replies Latest reply: Aug 12, 2010 1:36 PM by curly41
dosers Level 2 Level 2 (390 points)
I have a small annoyance with my 2009 (Nehalem) Mac Pro I am wondering if someone can help with, or suggest something, please:
The Mac Pro does not auto-sleep; ever. I have played around with the sleep time settings, and enabled or disabled the 'sleep drives' option, but to no avail. Mac Pro will stay on, no matter if I am logged on OR even on the 'log on users' screen.
That said, I can sleep the Mac Pro manually at any time, and without any problems; it stays asleep without a hitch, and wake-up is flawless.

There is nothing in the console log that would tell me why the auto sleep doesn't function. I deleted the sleep plist and re-set, but again, no change.

Any ideas? Not sure what could signal the system to not do auto-sleep?
It's running 10.6.3.

Cheers,
Dan

Mac Pro Nehalem 2.93, 16GB, GTX 285, MacBook Pro 2.8, 4GB, Mac OS X (10.6.3)
  • abugbitme Level 1 Level 1 (0 points)
    I have exactly the same problem with my 2009MP. I've tried everything I can do. I'm down to just the keyboard and mouse, so I does not seem to be USB related. Hopefully someone can help us both.
  • dosers Level 2 Level 2 (390 points)
    Intersting; I half-though I was along out there with this issue
    Again, it's odd in that the console log has no indiciation what is causing the lack of sleep - and again, I have no problem with sleep (and staying and awaking the MP) as long as I put it to sleep manually.

    I would think if something continues polling, the manual sleep wouldn't work either (or stay asleep) - so this is an odd one....
    My keyboard and mouse are both Apple (BT Magic Mouse and Alu Keyboard)...

    Thx,
    Dan
  • abugbitme Level 1 Level 1 (0 points)
    Dan,

    You might want to try repairing the hard disk permissions, from what I have read it works for some folks. I tried it with no luck.
  • dosers Level 2 Level 2 (390 points)
    Thanks - yeah, same here; repaired permissions (and even checked disk), all fine, no change in auto-sleep behavior though....
  • abugbitme Level 1 Level 1 (0 points)
    I found a work around in another thread. I did a quick test (1 minute) and it worked. *DragonOne PleaseSleep* is little app that does the job. Not a perfect solution, but it will save some electrical costs! BTW, after starting PleaseSleep, it runs in the menu bar. You will need to set it to launch at startup in it's preferences settings.

    Message was edited by: abugbitme
  • iPod 60Gb Black Level 1 Level 1 (5 points)
    Exactly the same problems as those described above: forced sleep works (by using the power button or closing the lid) but automatic sleep doesn't (using 'Energy Saving' preferences).

    Tried every single piece of advice here and on other posts: reset PRAM/ SMC, verified disc, repaired permissions, deleted the power saving preference files, cleared caches & history, restarted in every conceivable mode... The only things that worked were safe boot and creating a new user account which means it must be a software issue.

    Disabled/ removed/ paused/ reinstalled every piece of software I could but to no avail. The most frustrating thing? Having to wait for 5 mins every time I tried something to check whether the damned thing was going to go to sleep.

    In the end, and in desperation, I took the advice of Dino X and downloaded PleaseSleep. Success! A genius piece of software. It forces sleep when the Energy Saver preferences cut in but, even if I don't set exceptions, it won't force sleep if there's a DVD playing (for example).

    Only had the Mac for a few months and I'll never go back to that other, unmentionable operating system; the Mac's just too good but I'm vexed that I'm having to use third party software to get it to work as it should (and was) - feels like a bit of a Win*s solution to me.
  • iPod 60Gb Black Level 1 Level 1 (5 points)
    OK, ignore some of my previous email. After writing I searched a little further. I opened up the console and it turns out that when I uninstalled the software for my Vodafone 3G dongle a few weeks ago it left traces (despite using CleanApp).

    Every 10 seconds it was checking for access and thus stopping the 'Book from sleeping. As I couldn't find the exact file responsible I deleted almost everything with a Vodafone reference and it worked. Not quite sure which file is responsible (and can't be bothered to hunt further) but it's still searching at boot but no longer continuing to search.

    Sleep works again and no need for 3rd party software. Cool.
  • aaafox Level 1 Level 1 (0 points)
    I have the same problem and I was unable to resolve the issue,so I took the computer to the apple sore for repair.It seems to be a os software issue.The
    tech's are working on the problem and I will let you know what they do to fix it.
  • hursleymac Level 1 Level 1 (0 points)
    I bought one of these 2 months ago and in that time I have had:

    1. Faulty Graphics Card
    2. The well documented humming PSU noise
    3. The Bluetooth issues...and
    4. The failure to auto sleep

    Perhaps Steve Jobs should change his catch-phrase to "It Just Doesn't Work".

    For the money, these machines are cr@p quality...I've had a MBP for 12 months with no trouble but this machine is a very bad Apple experience

    Paul
  • Michael Hoover Level 2 Level 2 (255 points)
    Has anyone given thought about their network settings, depending on how its set up it has been known to prevent sleep, for example in MobileMe preferences panel, if Back to My Mac is turned on my computer will not sleep, other possibilities such as file sharing, screen sharing etc... might prevent your system from sleeping.
  • aaafox Level 1 Level 1 (0 points)
    Goto
    Library/Preferences/SystemConfiguration
    Delete/move to trashcan
    com.apple.PowerManagement.plist
    Reboot
    Set new sleep settings and wait for sleep mod to activate.
    It worked for me.
  • aaafox Level 1 Level 1 (0 points)
    Please disregard my last post this fix did not work after reboot.
  • A_MaStA Level 1 Level 1 (0 points)
    Manual sleep works perfectly. Auto-sleep, not at all. I don't know what the heck is up because I can't find anything in the console logs. I also just recently did a fresh install of the 10.6 and only did the Apple updates, yet it still won't auto-sleep. So I'm guessing it's an OS issue of some sort.
  • mooblie Level 4 Level 4 (1,935 points)
    I find some (some, not all) webpages prevent auto-sleep, if they're open when auto-sleep is attempted.

    In particular: BBC News, eBay...

    Closing just those tabs in Firefox allows auto-sleep for me.
Previous 1 2 Next