Previous 1 2 3 4 Next 204 Replies Latest reply: Sep 3, 2015 4:13 AM by tyw613 Go to original post
  • callaway Level 1 (20 points)
    I tried this, but it didn't work for me. Not that I'm complaining too much, but I'm still trying to match the download speeds that my Windows laptop gets. Wireless N, my laptop gets 42 Mbps download and 32 Mbps upload. My iPad maxes out at 16 Mbps download and about 18 Mbps upload. Can't figure out how to do any better. Fortunaltey, I haven't had any issues with the iPad's download rate, but I'd love to see it how fast this thing can really work. Maybe the next software upgrade?
  • Luxman1 Level 1 (0 points)
    I have problems with iPad download speed. Here is my configuration :

    SMC SMCWGBR14-N Barricade N ProMax Draft 11n Wireless Gigabit Broadband Router
    ISP - Armstrong - provides 10 Mbps download and 3 mbps upload speed.
    Desktop attached to the router has 10 mbps internet download speed.
    HP Laptop running on G network card - 10 mpbs download speed.
    iPad has only 1 mbps download. The upload is 3 mbps which matches to the laptop upload speed.

    Just strange that iPad is having only 1 mbps ... youtube videos are very slow to load.

    Any help would be appreciated.
  • keithfrommarietta Level 1 (20 points)

    I was having the exact same problem that others have noted. My new iPad 2 would only get between .10 and .47 Mbs Down on my home network, while my Windows PC would get between 16 and 20 Mbs down and even my iPhone on wi-fi would get 6 - 8. It was essentially unusable for downloading, streaming or browsing.


    My router had no tab or setting that said "QoS". I first tested by changing it from multi-mode (g/n) to n only and immediately was getting speeds of 16 Mbs down on my iPad. The problem is that I have other devices that are g only, so I have to run in multi-mode. I then found a checkbox that was labled MMS (Multi-Media Services), which as it turns out is the same as QoS. By unchecking that, I was able to get 16 Mbs down on my iPad.


    As everyone points out (& I have found), that is great when you're connecting on your own router and can make that change, but no good if you're traveling - as I do. Today, I was in the Apple store. They wanted to swap out my iPad for a new one, but I resisted since I had no faith that for all of that trouble that anything would be fixed. After pressing them to go through the troubleshooting steps, low and behold, it said to reset the network settings. This is found under: Settings; General; Reset; "Reset Network Settings". We did this, and whereas I was getting .27 Mbs down on their network beforehand (and a Mac connected on the same network was getting 39 Mbs), after resetting and reconnecting, I got a full 16 Mbs down!


    Note that I don't believe you'll ever get comparable speeds on an iPad or iPhone as you will a computer due to iOS differences in network throughput (so don't expect to see 40 Mbs), but speeds of 12 - 18 down should handle everything you need including streaming HD movies. Hope this helps!

  • Serge Imasdounian Level 1 (0 points)

    I have a brand new Ipad 2 and im having the same problem with the download speed, while surfing speed is normal !


    I did the RESET NETWORK thing and had no change et all !

    I also checked my router fot the QoS and g/n byttons and i have neither !


    Any propositions anyone !?

  • keithfrommarietta Level 1 (20 points)

    Serge, are you looking for actual buttons on your router (for QoS, MMS, or G/N)? They won't be physical buttons. You need to log into your router to manage it's settings. If you don't know how to do this, usually you can go into your wireless settings & look for the IP address of your default gateway (typically something like or, etc). Then open your browser & type that IP into the address and hit enter. You'll either be presented with the admin page for your router or a login for its user name & password. If the latter, refer to the documentation that came with it. If you didn't change the login information, the default is sometimes simply "admin" and "password".


    Once you've logged into your router, there will be a number of setting available to change. If it's a recent router, you should have to the option to switch from mixed mode (G/N) to just N. You should also see either the QoS or MMS setting that you can disable.


    All this having been said, this will only fix your problem while at home. If resetting your iPad's network settings didn't help, I suggest going into an Apple store for service. They will suggest two things, first, to completely restore your iPad. This, of course, you could try at home but it doesn't guarantee to fix the problem and it is a bit of a pain. If you try this, note that you want to do a "clean" install of your iPad when you reconnect it (i.e. don't restore it from a backup in iTunes) or you will just be reloading the corrupted settings from before. The second thing they will suggest is just to swap out your iPad for a new one, which may resolve the problem. Thankfully, I didn't have to go that route, as the reset of the network settings has completely resolved my throughput problems. I've since tested my iPad on several networks and haven't experienced any slowness on them.


    Hope this helps!

  • Shirley 123 Level 1 (0 points)

    anyone know what to do to help with this with a Time Capsule? Luckily I have unlimited 3G but my WiFi is so slow that I often disable WiFi and switch to 3G while in my home. I have an iPad 2 WiFi 3G while my friend's WiFi iPad 2 seems fine on the same network. Any thoughts?

  • jockogator Level 1 (5 points)

    Installed new Lynsys/Cisco E1000 N router to go with my new Motorola Surfboard DB6120 Docsys 3.0 cable modem. 

    One month old iPad2 was crawling before, and even worse after this hardware upgrade!


    Luckly, found this board, and found the fix.


    I have B, G and N wireless devices on my network, so had to have the newwork setting as Mixed.


    OP is correct, in that the QoS is what needs to be fixed, at least fo the Lynksys/Cisco N router


    On the Linksys E1000, select Applications & Gaming -->QoS (see image below)

    Change WMM support to Disabled, save and reboot both the router and the IPad. 

    I had to deleted the device from the iPad and re-configure.


    Went from less than 1Mbps to 20!!!!LinksysE1000-setup.JPG

    Worked for me!  Hope it does for you too.


  • mhamilton69 Level 1 (0 points)

    Worked for me too on a Netgear. 

    The question is what is the iPad's problem with QoS? 

    It does not make me feel good to turn off QoS when I have other streaming devices in the house.

    Why does the iPhone not have anyproble with this (probably it just ignores QoS).


    C'mon Apple, what does big brother have to say about QoS support?

  • MyMac8MyPC Level 4 (1,460 points)

    mhamilton69 wrote:


    The question is what is the iPad's problem with QoS? 


  • dliston Level 1 (0 points)

    Was only getting 1 meg on my linksys wrt310a.  Turned off WMM under QoS and it jumped to 16 meg.  Thanks for the help!

  • Applefaninfinity Level 1 (0 points)

    Thanks for posting this solution. Worked splendidly for me. The DL speed went up 20X !

  • JonFromNJ Level 1 (0 points)

    Great posts above.  I haven't tried the QoS fix because I didn't see this thread until now, but I did have crazy slow Wi-Fi on my iPad2, now fixed, so thought I would share my experience incase helpful.


    I was having horribly slow Wi-Fi speeds on my iPad2, despite a fast cable modem connection and a "N" generation Linksys wireless router (maybe 2-3 yrs old).  Was achieving speeds of only 1.3Mbs -- slow enough that you couldn't watch YouTube videos.  From hunting around on the web, I came across the suggestion to manually set the Wi-Fi router to the "G" standard (ie downgrade it from the faster "N" standard).  Remarkably, I did it and it worked like a charm.  I now get Wi-Fi speeds of about 12 or 13 Mbs, or 10x what I was getting before.  Bizarre but true.  It is an easy fix.  And also I think the "G" standard is capable of 50Mbs so even though it is a slower and older standard, it is still way faster than anything you are likely to achieve as a home user.


    Maybe changing the QoS setting also does the trick, and perhaps that is a better solution.  But changing setting from N to G has done the trick for me.  Good luck.

  • victorfromatlanta Level 1 (0 points)

    CM2010, you Rock!  I just got an iPad2 & my download speed was averaging 0.80Mbps (Glacial).  I disabled QoS in my Linksys Router & viola, the download speed is now averaging 13Mbps.


    I was all set to spend hours troubleshooting.  Luckily your post was the first result for my internet post.  Thanks again.

  • JBinKC Level 1 (0 points)

    Thanks for the helpful, detailed tips.  I've been trying to diagnose or repair the lousy, erratic wifi performance on my iPAD1 and my iPAD2 for some time.  I tired the network reset option, and it hasn't changed my results.  I must be very close (3 to 5') to my Airport Extreme or Expresss (I have both) to get any performance at all.  My iPhones and Macbooks work fine on wifi all over my condo.  The iPADs are just very erratic, and often unusable if I'm not within a few feet of the router.

  • Wumpy Level 1 (0 points)

    I have been trying to solve my slow connection speeds for months.  I was just about ready to pursue a warranty replacement claim.  I just found this post and it worked.  My router won't allow me to turn off QoS and stay in N mode, so I have to keep in b+g mode.  However with QoS mode off my iPad transfer rate went from .4 Mbps to 11Mbps.  As far as this being a minor software glitch that Apple will fix quickly, I don't think so.  I just upgraded to iOS5 and the problem wasn't resolved.


    Thank you for this post, it saved me lots of hassle.

Previous 1 2 3 4 Next