Skip navigation

Fixed my slow iPad Wi-Fi issue, here is what I found...

546463 Views 175 Replies Latest reply: Apr 16, 2014 5:04 PM by Vjamora RSS
  • jtashland Calculating status...

    Been searching for weeks on various boards trying to figure out why my Ipad2 is so slow. I was about to have apple take this back for a replacement. After buying 2 top of the line routers one as a base and another as a bridge/repeater and the Ipad2 was still as slow as ever. Even had a neighbor who is network certified couldnt even find a reson why it was so slow. I was in the process of contacting apple again for the 3rd time to send a replacement when I stumbled across this forum. I went to the wireless set up tab on my netgear 9500 and disabled the WMM ( not the QOS ) as that is something totally different, and my Ipad2 now seems to be working alot faster. I will give it a week and see if this finally fixed this slow connectivity issue. Why apple has not addresed this is way beyond me... If they dont support QOS/WMM, then they should state that... Watching video and no issue so far... keep my fingers crossed.

  • HarryToTheShore Calculating status...

    Thank you CM2010.  Just disabled WMM through the QOS tab on my Linksys WRT160N. Internet speeds are great on my 4S especially when streaming video from ESPN.  Thanks again!

  • dduncan391 Calculating status...

    Amazing!  I've been messing with this forever and your suggestion fixed the problem.  My iPad connection to my Netgear WNR834B v2 was giving me a download speed of about 0.45Mb, and is now giving me 12+Mb.  Thanks.

  • RGS55 Calculating status...

    This is amazing and worked like a champ! Thank you so much for this suggestion of disabling QoS/WMM in the Gaming/Application settings for the Linksys router. I did not even have to reboot my router or ipad - it just started working great. My ipad2 was not only slow, it would drop off after being in sleep mode and even in the middle of doing stuff!! THANK YOU!!!

  • Gardi23 Calculating status...

    Hi all I'm having same probs as everyone but I've got a sky router any 1 no how to change the settings on this thanks

  • l9o Calculating status...

    Thank you ! This is a life saver !!

  • TheDr1970 Level 1 Level 1 (0 points)

    Finding this post was a huge help! I am an IT engineer and, honestly, I just didn't devote the time to research the issue until now. I barely use my iPad2 because the wifi speeds at home are pitiful! 0.80/Mbps dl and 5.00/Mbps upload. That upload speed is what got me thinking... why would it be relatively good? Installing apps on my iPad2 was taking sometimes 1 hr or more! Ridiculous!

     

    I changed my Linksys router to G-only and turned off QoS... BAM! DL speeds jumped to 25/Mbps! Huge difference. I do this stuff for a living and I never would have guessed an issue with the router. All laptops, smartphones, etc work great. I assumed it was something with my iPad2 like it was defective or an OS/firmware issue. I had pretty much given it to my wife as a dedicated Words w/ Friends toy. Now that it's fixed I am taking it back.

     

    Thank you so much for posting this fix. As an added benefit I asked my kids to try their iTouch and they said it had never been so quick. And Apple, you suck for making all your products incompatible with something as insignificant as QoS. IMHO the front page of the docs should say "Warning! Turn off QoS or your download speed will be horrible." But no, instead you either let people suffer or they go blow wasted money on an Apple router which doesn't have QoS.

  • Agent P Calculating status...

    Thanks to keithfrommarietta for the detailed instructions on how to do this! I am the domestic IT expert at our house and that isn't saying much. I have only had my ipad2 for a few months and was furious to be having problems with something as basic as streaming youtube videos. After two calls with apple support my problem was not solved by upgrading to the latest ios or resetting my network settings.

     

    Disabling WMM on my router instantly solved the problem! I have a Netgear N600 Wireless Dual Band Router. I found the option to disable it under the ADVANCED tab, then Setup, then QoS setup.

  • keithfrommarietta Level 1 Level 1 (0 points)

    Glad to be of service! I too am shocked that Apple hasn't better addressed this yet, or at least offer detailed instructions on how to work around it. I know it's not a problem everywhere which might be why they haven't come up with a more complete solution, as I've been at friend's houses and checked their settings and found the QoS or WMM enabled, yet still get 15 Mbs+ on the download. The thing is, when your iPad crawls, this is a very effective fix for it. Cheers!

  • Joseps Calculating status...

    Having same issue with my iPad 2. Anyone knows where is the WMM/QoS setings in a LINKSYS Wireless-G Cable Gateway WCG200CC? Many thanks.

  • evb57 Calculating status...

    not surprisingly, Windstream washes their hands of the issue since it is the I-pad, not the internet connection.  I have a Sagemcom 1704 Windstream Modem/Router, G series operating in Mixed mode.  The Qos was NOT enabled; i went in and disabled the MMS (Advertising)based on earlier support community advice but that hasn't helped either.  Laptop response is fine, this is the I-pad--and i see it mostly in the email download (Safari surfing is fine).  Any further recommendations?

  • evb57 Level 1 Level 1 (0 points)

    Well written for us newbies. unfortunately didn't work for me.  Qos is disabled; i disabled the MMS, then i reset the network as you suggested.  My download hassle is mostly emails--minutes for some even without an attachment.  Looks like i have to go visit the i-pad store.  I do only have a G modem/router (Sagemcom 1704 Windstream).  is that just too out of date?  only a year old.

  • shravanevana Calculating status...

    Thank you for your help with this Sir, it worked like a charm!

  • Tux Kapono Level 1 Level 1 (80 points)

    I disable WMM and tripled my speed, but could no longer connect to my wi-fi router. Then I found this on Apple's website...

     

    http://support.apple.com/kb/TS3727

     

    WMM must be enabled for devices to connect. Disabling WMM on your wireless router can prevent the following Apple products from connecting to an 802.11n Wi-Fi network:

    • iPad
    • iPhone
    • iPod touch
    • Apple TV

     

    Does this suck as much as it sounds like it does?

  • evb57 Level 1 Level 1 (0 points)

    i didn't have much luck either--went to Apple store, they suggested i reboot entirely and go back to factory settings.  That worked.  Silly, but i that is often the solution for PCs, so perhaps the big A isn't so immune.

1 2 3 4 5 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.