Previous 1 3 4 5 6 7 Next 204 Replies Latest reply: Sep 3, 2015 4:13 AM by tyw613 Go to original post
  • jockogator Level 1 (5 points)



    The issue is iPad using a WiFi router.  Not while connecting via the phone.

    Been going on since the original iPad, and iPad2


    Just Google speed test.  Any of the top listings will work. I've used just fine.

    Test on a netbook, laptop, desktop, wired & wireless to get a baseline of your ISP and router first.

    Then download one of the free speed test apps for the iPad, and test again.  Those of us who had the problem becasue of the noticable difference, were then looking for answers, and found them here.


    Slow speed problem identified, answer found, router setting changed, slow speed problem fixed!


    Go to the router settings, change as advised, test again, see and experience the difference.  At least, that's what most of us got after making the changes to the router.  Furgettabout it after that!


    Good luck!

  • keithfrommarietta Level 1 (20 points)

    I was one of the early posters on this. Very disappointing that Apple hasn't yet addressed this. I have an iPad 2 (and iPhone, Windows 7 PC and Macbook Pro). My iPad is WiFi only. The slow WiFi connection only happened on the iPad - no other devices.


    To check your speed, I suggest on a computer and the Mobile Speed Test  app for iPhone and iPad. I've had excellent results with them - very accurate.


    As I've posted before, the best results in improving the speed come from adjusting your router settings. They can be accessed thru the admin page in your browser - on many routers it is found by typing in the URL of your browser and hitting return. If that isn't it, you need to run a command prompt and type "IPCONFIG /all" (note the space before the slash) and then find the IP of your default gateway, then type that into your browswer to get to the admin page. Your router may be password protected. If you haven't changed it, many of them (netgear especially) have them set at the default of "admin" for user ID and "password" for password. Yeah, creative huh? :-)


    Find the setting for either QoS (Quality of Service) or MMS (Multi-Media Services). UNCHECK THE BOX FOR EITHER OF THESE OPTIONS. They are essentially the same thing and, in theory, are there to throttle bandwidth for certain services to give greater priority to things that are bandwidth-heavy, like streaming video. I've never seen any affect on any other device's speed whether they are checked or not. Unchecking them will fix the slow speeds on the iPad for most people (as it did for me, and many others as attested here). Oddly, I've never had slow connections on my iPad when connecting in hotspots, where I obviously don't have control over router settings. This seems to just be a problem in the home for most of us.


    Good luck & happy surfing!

  • bizpat Level 1 (0 points)

    I have a ipad, 3rd generation. iPhone 4S. My internet connection is 100mb on computer. Phone is fine, but iPad is horrid. My modem/router is a Motorola SURFboard SBG6580. I do not see anything in the router settings that resemble any of the suggestions.  If anyone is familiar with this router, I sure would appreciate some guidance. I couldn't find anything on Motorola site.



  • bizpat Level 1 (0 points)

    I jsut found something that doubled my speed!


    I went to Settings, General, Network and turned off the WiFi, turn it back on and it really improved it!

  • pjrufus Level 1 (5 points)

    Just wanted to say thanks. I feel like kind of an idiot. I've had ipads for 2 years, I'm on an ipad 2 now, and I just thought it was a bit slow on my home wifi, and I couldn't watch youtube videos. Wasn't really a problem until I bought an apple tv. Spent hours researching, updating router firmware, changing settings, then I found this thread. Found out my desktop and laptop were downloading at 20-25 and ipad at .75. Turned off WMM and everything is great. Thanks for the help. I wish I found this thread yesterday.

  • TheDr1970 Level 1 (0 points)

    @pjrufus: You just described my situation exactly. My ipad2 seemed slow but I never bothered messing with the troubleshooting. Everything else was 20-25 dl and the ipad was about 0.5-0.75 when I finally tested the speeds. I turned off WMM (QoS) and it jumped to 20-25. I was shocked that something so small was the answer.

  • kentmcpherson Level 1 (0 points)

    I have an ipad 3 and a Linksys EA4500 router that has QoS enabled. But Speed Test utility says I am 16mb download speeds.  Do I still need to disable QoS?

  • cjnjfamily Level 1 (0 points)

    Owned my Ipad 2 for less than a week, having trouble with intermitent slow speeds and dropped wi-fi connection.  Have 3 Ipod touches and 2 P.C.'s running windows 7 that all work fine. 


    Installed the same speed test app on my ipod and ipad, ipod=fine; ipad=sits there and says looking for server (using speed  I installed the same ebay app on both; ipod=fine, ipad2=lost connection with server. 


    So then I hit Settings>Reset>Erase all content and settings (WARNING, THIS DELETE's EVERYTHING) .  I then set my ipad2 up as a new device.  Used the same itunes info that I have on the ipod (which I did before), and started over.  I installed the app and tried it about 30 times.  Worked fine.   Installled the Ebay App for Ebay and tried to sign into Ebay, bogged it down.  Tried the speed app, looking for server.


    I then hit Settings>Reset>Erase all content and settings (AGAIN, Deletes everything) and reset up the ipad2 as a new one using my existing itunes info.  I enabled location services (which I don't like to do), and find my ipad (which I don't like to do), after I got to the main screen I then went into Settings>ICloud and turned off all things and when it asked if I wanted to delete things I said yes so that I could make sure it did not import anything from any other device.


    I then installed the app and it did the speed test for 10 minutes without a problem.


    Now for my home network info: Cable modem/router Mortorola Surfboard sbg901

    logged into modem (before I did the resetting of the Ipad2)>WMM>Wmm support to off


    That didn't do anything for me


    So i turned the wireless off on the modem/router and installed a Linksys E1000 which as far as I can tell is suppose to be an N band router.  Got it all hooked up and surfed on PC's and  IPod's; Ipad 2 Speedtest. net looking for server.  Tried Safari nothing, went into Parental controls in the router using PC (I think it is>admin is user and password is your wireless key I think) and switched off the QOS and then the Ipad2 wouldn't even connect to it.


    PLEASE feel free to contact me about this problem.  I guess I will slowly start moving back into my Ipad2. But so far I have isolated it to a problem that was either imported from another device or from my existing Itunes information.  OR it could be a problem with the Ebay for Ipad App. 

  • cjnjfamily Level 1 (0 points)

    Ok, so I only have the app installed, everything else is as if it were a new Ipad2 with the exception of using an existing itunes info that I had used on other devices.


    Speedtest=working fine

    Safari=working fine

    app store=working fine


    Next I installed the Ebay for Ipad app=bogged down really slow, but eventually worked.

    Tried fine 10x


    The only thing I did different with the Ebay for Ipad app this time was to not tell it to sign me out (normally I would hit the green button upper left>settings>keep me logged in> I would turn that to off)

  • bob1116 Level 1 (0 points)

    Last person still using Earthlink DSL here. This morning I was getting 5 megs down. Tonight I was getting less than a meg down to both my computer and ipad. Turned the modem off and on, ( left the Airport Express on) and now I'm back to 5 megs down.

  • Yacpro13 Level 1 (0 points)

    Turned of QOS and WMM support and my new iPad is flying on wifi again.

    Hopefully this gets fixed in ios6. Thanks so much for the tip!

  • Juramoon Level 1 (0 points)

    Yes I just turned off QOS and got my best ever speed. have gone from download of 57kbs to 2876 kbs

  • perjar Level 1 (0 points)

    I've got the same problem with my ipad 2 but the trick with disabling QoS in the router as discussed in this thread doesn't do the trick for me. I have a Netgear WNR2000v3 router. I am sitting on a DSL connection so my speed is not dazzling, but still, running speedtest on a wifi connected Windows laptop gives 5 mbit while speedtest on the ipad 2 reports 0.8 mbit.  My router has some settings for b/g/n standards and I have tried them all without result.

    Anyone have the same issue with Netgear?

  • bob1116 Level 1 (0 points)

    I never got to dazzling either. 4 mgs (up from 1.5) was a vast improvement, but Netflix still stalled and was never in full HD. I Just dumped Earthlink DSL (lines owned by ATT) and switched to ATT Uverse. 10 mgs, same price. Att just installed fibre in my neighborhood but they won't release that bandwith to Earthlink. Netflix now full HD. No buffering. Same price too.

  • Wpjwong Level 1 (0 points)

    I have same slow wifi issue with my iPAD2 (3Mbps) while iPhone 4, 4S and new iPAD are running fine with over 20Mbps over the same wifi network. I am using DLink DIR-655 and turning off WMM feature does not help. I tried to reset all settings and content of iPAD2, now it can run at 27Mbps. After restoring all the apps and settings from iTune, it runs with less than 4Mbps again. So I really think it is apps or it's setting affecting the performance. I may need to install apps again one by one to check which one is causing the problem. Any suggestion is welcome.

Previous 1 3 4 5 6 7 Next