Previous 1 5 6 7 8 9 Next 171 Replies Latest reply: Apr 6, 2014 8:10 PM by Nickpicnic Go to original post
  • macbkrob Level 1 Level 1 (0 points)
    I started consistently losing my connection when i upgraded to 10.6.4 ... every few minutes, even though my wireless connection looked like it was connected, my connection would either hang or slow to a crawl. i was constantly stopping and starting Airport to reset my wireless connection. i've tried lots of different things like manually setting my ip address as suggested by others but that didn't help either. when i connect directly using an ethernet cable, the problem goes away, so it seems like it's only a wireless connectivity problem for me.

    here's what worked for me: i open up a terminal window, and simply start pinging my router. so i run the command "ping 10.0.1.1" (where 10.0.1.1 is my router ip) and i just leave the terminal window open while i'm on the computer. when the computer goes to sleep, the pinging stops, and then it starts back up again when the computer wakes out of sleep mode. so far so good. my wireless connection has not slowed or gotten hung in over 5 days. (my wireless connection used to slow or just hang every 3-5 minutes.)

    so you guys can try that out and see if it works for you.
  • drichi2009 Level 1 Level 1 (10 points)
    I did the same thing---gave up after trying all the tricks and tweaks I could find. I accept the fact that my Mac---that just works except when it doesn't---is not wireless compatible. I do not expect Apple to do anything about the problem except to continue to deny it until it starts costing them. And it won't.
  • drichi2009 Level 1 Level 1 (10 points)
    "Anyone found a permanent solution?"

    Yes, but it does not involve Apple products.
  • wking Level 1 Level 1 (0 points)
    Well, if you have a solution, do tell...
  • bustout Level 1 Level 1 (25 points)
    Add mine to the list... it just started doing it, A LOT. Very frustrating as I work from home on it. I have the system and everything updated, yet it seems to be getting worse. I wish I would have put in a cat-5e when I did my new work area but the wireless worked perfectly then.
  • SwanZee Level 1 Level 1 (0 points)
    Hi all,
    just over 2 weeks ago I purchased a Refurb 27 inch Core i5 Imac, the machine looks and behaves as good as new, BUT I cannot connect to the internet wirelessly. I get airport constantly seeking for networks even though the router is only 8 ft away. Sometimes I can see my network and adjacent ones used by neighbours but cannot connect to mine. I get refusal to accept WPA password, and/or Timed Out message. I had upgraded the OS from 10.6.4 to 6.5 and thought that this may have been an issue, so I downgraded back to to 6.4 (Erase and Install) losing my transferred apps etc from my MacBook Pro and the problem remains. Yet my Pro, IPhone, G4 Imac, PCs all connect! I have attached an Ethernet cable to the new Imac and the Internet is working great. I tried the PRAM reset, my neighbours' networks are all using different channels, so I'm stumped. Next thing is to contact apple.
  • RyanWoods Level 1 Level 1 (0 points)
    Bought my first Mac on Black Friday, a 21.5" i3 iMac. This issue is the first thing I've noticed. If I leave my connection idle for me than a few minutes it just drops. Don't have this issue with any of the other 10 or so devices running wirelessly in my house including four PCs. It's kind of ironic that I bought a Mac because I was tired of these type of problems on Windows based computers. Maybe Apple will come out with a fix if Consumer Reports runs an article about it...
  • backspacer123 Level 1 Level 1 (0 points)
    Hi folks,

    Just looking for a little help here, or at least see if anyone else has come across this problem with their mac.

    Anyways the problem is that the internet connection tends to be a bit erratic at the best of times, it cuts out randomly and usually requires a restart to get the internet connection up and running again. Now sometimes it can be fine for days at a time, other times it may only last a few minutes and just stop working again, needless to say it get frustrating having to do a constant reboot whenever there's a connection problem.

    I have checked the IP Address, DNS and Router settings and everything appears to be in order. Have attempted to assign addresses manually with no success and have returned it to the automatic setting.

    The OS is Snow Leopard 10.6.3. Any feedback would be much appreciated with this, it has me fairly stumped.

    Backspacer.
  • K.Harmon Level 1 Level 1 (0 points)
    I'm having the same issue with my iMac...
    I have airport and a router for wireless connection to my iMac, I've been using it for years and have NEVER had connection problems until just recently over the last few months, and it seems to be intermittent, it'll work for a few weeks then it wont work for more than a few minutes at a time, I also noticed it corresponds to apple updates because since the update to 10.6.5, I'm losing internet again!...but just prior to this update it was fine....the update before that....no internet except with restarts:(
    It keeps saying one or all of the following, "ISP failed" "Internet failed" "Server failed" when I use network diagnosic to reconnect, so now I'm only able to stay connected for a short period (minutes)
  • clarkeycats Level 1 Level 1 (0 points)
    PhilHB wrote:
    Hello,
    I may have a solution(at least my iMac has been ok for 30Hrs+).
    I also posted on another forum & this was an answer I got.

    +would suggest you to delete your network from the preferred networks list on your Mac. In Network Preferences, select AirPort, and start out by turning off the AirPort card. Then click Advanced, select the first tab in the overlaid window. Remove your network using the - sign, click Ok, then Apply. With AirPort still off, go to Keychain Access, delete the password for your network. Restart the computer, turn AirPort back on, rejoin your network and authenticate. Put the computer to sleep from or using Hot Corners, wait 5-10 minutes, maybe 30 or overnight, and wake it back up. Does it work?+


    thanks Phil, i tried this last night after my connection completely died on me, it seemed to work for the rest of the evening and was faster than ever. Will check on it later to see if everything is still working well.
  • Darko Ibrahimpasic1 Level 2 Level 2 (325 points)
    Hey guys I have a 09 24' imac, and having same issues as everyone else. However I do not think this is iMac or ISP related. My mac worked fine until I downloaded the newest "Airport Utility Update" and new "Firmware for TimeCapsule" After that, I began having this problem. I do not have a solution but just wanna give you heads up
  • lionheart_001 Level 1 Level 1 (5 points)
    I have this problem as well.

    But....!

    It only happens in WindowsXP mode. Apple (Mac) mode is fine. Its now worse and when I go to check emails, re-clearing the internet connection no longer works. It just keeps trying to connect, with good signal strength. The rest of the household is PC's and they are all fine. Cable modem (wireless) is fine, reboot it and its great. I have tried adjusting the Freq. setting and power setting (transmit setting) on the Cable modem (Motorola 900 series, about a year new), and that does nothing.

    Why would mine work beautifully in Apple mode, and not at all in Windows mode????? Thats what I cant figure out. I would think that is a software issue and not a hardware issue.


    I am using the iMac 24", 2009 model. (Love the computer, but the internet issue drives me nuts).
  • Darko Ibrahimpasic1 Level 2 Level 2 (325 points)
    Ok guys try this. It fixed it for me. Go to your airport/router settings and change the channel from automatic to 11 or 9. That did it for me. No problems at all. Let me know how it goes.
  • lionheart_001 Level 1 Level 1 (5 points)
    I tried that. I was at 11, then 10, then 9. Still cannot connect.
  • hey joe Level 1 Level 1 (0 points)
    *I finally fixed this by switching from 802.11n to 802.11g.*

    Every wireless access point has an option to use b/g/n and most are configured by default to automatically select based on the initial wireless connection request. Forcing it to use 802.11g only really did the trick.

    Sucky being stuck at 54Mbps max throughput but for general internet use this is usually way quicker than your internet connection anyway.

    As I understand it 802.11n is a draft specification so it shouldn't really be a surprise there are interoperability issues with many wireless access point that support this standard.
Previous 1 5 6 7 8 9 Next