5 Replies Latest reply: Apr 29, 2010 10:09 PM by dnase2000
Robert P2 Level 1 (50 points)
Hi all, this is driving me nuts, I can play youtube videos on my old G4 powerbook without any problems at all over my wireless Airport connection (802.11g)
but my Apple TV will sometimes get a couple of seconds into a youtube video then freeze?
sometimes it's just buffering (very slowly!) and sometimes appears to be not downloading at all?

why would the Apple tv stream differently to my old laptop?

btw my laptop will play any 360, 480 and 720 youtube video without steaming problems

bit puzzled with this one?

Mac Pro 2.8 octo, G4 powerbook 17", Mac OS X (10.5.8)
  • Rob the Elder Level 1 (40 points)
    I suspect its the connect speed resulting from the signal strength. Check to see if you move the ATV closer to the wireless hub you get better performance.

    Many people are migrating to wireless N to get better and more reliable performance. The ATV loves N
  • Roidy Level 1 (35 points)
    Yep, I've noticed the same thing over the past week or so. YouTube works fine on my PC but on ATV some videos just stop at some random point during playback and never finish buffering or the buffering is really slow, which is really annoying because I love using YouTube on my ATV. I was wondering if it had something to do with the overhaul that the YouTube video pages have just gone through. I'm on a wired connection to my ATV so it's not a network speed problem.

    The YouTube video page overhaul raises another point. Videos are no longer rated using the 1 to 5 star method, now it's either thumbs up or thumbs down, but the ATV still uses the 5 star rating system. I wonder if we'll get an update for this.
  • Waymen Level 5 (5,635 points)
    The source of the video you get when accessing YouTube from a computer is usually different than what you get on the Apple TV. Most of the content you get on the computer is in Adobe's Flash format while the Apple TV has to use H.264 video streams. That in itself shouldn't cause a problem (in fact, some would argue that H.264 is "better" than Flash) but it does mean that the streams may be coming from different sources and thus the streaming performance may be different (i.e. the servers may be different and the caching and routing on the internet may be different). This could be part of the problem you are seeing.

    However, I'd agree with what others have said, your problems are most likely being caused by wireless network issues in your home.
  • Robert P2 Level 1 (50 points)
    I Have had my Apple TV connected via gigabit ethernet for the last 2 days and the problem is still there so it definitely has nothing to do with my wireless speed?

    still at a loss to understand this one
  • dnase2000 Level 1 (15 points)
    I have noticed the same "speed" problem on my ATV as you have. In fact, the internet connection often seems much worse on my ATV compared to my computers and lately it has been resetting the wireless connection almost every day and loosing the password which is annoying. I haven't been able to figure the problem out either.