1 2 Previous Next 19 Replies Latest reply: Feb 1, 2014 11:10 AM by yonyo
htmanning Level 1 Level 1 (0 points)
I've read about several situations where the iPad cannot connect to a WiFi router. Some people cannot connect to hotel WiFi service because of an HTML5 implementation in Safari that doesn't allow the iPad to forward to the acceptance of terms page. Another situation where 2 networks have the same SSID with different passwords or something.

I have a situation where the iPad cannot connect to a basic Linksys Router with a simple WPA password. The iPad sees the network, prompts me for the password, has a strong signal, but will not "connect." Every other computer, laptop, even my Palm Pre will connect. Any ideas?

iPad, iPhone OS 3.1.3
  • 1. Re: iPad cannot connect to Linksys Router
    zy1122 Level 1 Level 1 (5 points)
    I have 3 linksys routers and the iPad has been able to connect to them all. I settled on the Linksys WRT54GL because the others are old and starting to exhibit dropout problems.

    My suggestion would be to temporarily shorten your password to one or two digits and see if that helps. Before playing around with the Linksys I would suggest that beforehand you save your config file in case you need to restore the router.

    I am on G band only, channel 6. My wireless security is set to WPA Personal, TKIP+AES, and I have a 26 digit WPA shared key. BTW, the 26 digit key is a real pain in the butt, but perhaps provides additional security.

    Like nearly everyone else, I am occasionally experiencing short internet disconnects followed by an automatic reconnect. I'm hoping the next iPad upgrade will remedy this.
  • 2. Re: iPad cannot connect to Linksys Router
    htmanning Level 1 Level 1 (0 points)
    I don't think it's the brand of router because I have a Linksys router that I can connect to. I think something is going on that I can't figure out. The router is not blocking me via mac address. The setup is a simple WPA password that's 8 characters long. I've setup a ton of these routers and it's just a no brainer. I'm wondering if perhaps these routers have an old firmware that Apple doesn't like or something. They are G routers.
  • 3. Re: iPad cannot connect to Linksys Router
    Waltooor Level 1 Level 1 (0 points)
    I figured it out for me on the linksys.
    change your maximum number of dhcp users to 150 and change the channel to 11.
    save your settings.
    unplug your router and plug it back it so it re-issues ip addresses
    power your stuff down and up and see if that works.
  • 4. Re: iPad cannot connect to Linksys Router
    Yoda066 Level 1 Level 1 (0 points)
    Hi,
    I have an SMC access point with similar issue.
    No problem connecting iPod touch 3g and iPhone 4g, but iPad just keep saying that cannot connect to the network....

    Following your comment I changed the channel form 6 to 11 and resolved the problem.

    Maybe this can help other people too.
  • 5. Re: iPad cannot connect to Linksys Router
    piersonsteven Level 1 Level 1 (0 points)
    I'm having the sam problem with my Linksys router How do you change the channel from 6 to 11. I'm in Network settings and have been able to change anything. Any help is greatly appreciated.

    Thanks
  • 6. Re: iPad cannot connect to Linksys Router
    JimHdk Level 7 Level 7 (23,635 points)
    The router channel can only be changed by opening an administrative session with the router. This can usually be done with a web browser at the URL http://192.168.1.1. Consult the documentation that came with your router for details.

    Make sure that the firmware in your router is up to date. Check the router manufacturer's support web pages for firmware updates.
  • 7. Re: iPad cannot connect to Linksys Router
    Chicago E Level 1 Level 1 (0 points)
    I read through the previous posts and some others on the web, but none of which seemed to work with connecting my iPad to the Linksys Router (WRT54G)....that is until I stumbled across the original connection path when I first bought the iPad.

    1) Log in to Linksys Router
    2) Go to Wireless Security Tab
    3) Select Security Mode: WEP
    4) WEP encryption: 64 Bits 10 hex digits
    5) Enter a passphrase & generate a key
    6) Enter the information from Key 1 as the password for the iPad
    7) Enjoy surfing...I hope this helps for you as well.

    Best,
    Eric
  • 8. Re: iPad cannot connect to Linksys Router
    giant ipad2 Level 1 Level 1 (0 points)

    I just spent 2 hours trying to get my iPad 2 to connect to my Linksys router.  (I could not get past the network password.) 

     

    Things I found out:  1) When you click on a network, the password you need to enter is NOT the router password.  You need to enter the pass key.  2) When you enter the pass key, it is case sensitive.  There is no caps lock on the iPad keyboard.  So you have to be very careful when entering the pass key.  3) The Linksys support web site was very helpful.  The instructions walked me thru the process, step by step..

     

    Good luck, J

  • 9. Re: iPad cannot connect to Linksys Router
    Ashka Level 4 Level 4 (3,760 points)

    Hi giant ipad 2

    You can set Caps Lock on your iPad under settings > General > Keyboard.

    When set a double tap on the shift  key sets the caps lock. The Shift Key turns blue with a white arrow. Single capital letter shift key is a white key with blue arrow.

    Best.

  • 10. Re: iPad cannot connect to Linksys Router
    malpert Level 1 Level 1 (0 points)

    is there anyother solution than going to WEP it is NOT as secure as wpa?

    marv

  • 11. Re: iPad cannot connect to Linksys Router
    Underwriterguy Level 1 Level 1 (0 points)

    I've worked for 2 days on a problem with my new iPad and a linksys wrt300N router. Kept getting "unable to join" or "password incorrect" messages. iPad worked fine in the Apple store and at coffee shops. My iPhone worked fine at home. Finally it occurred to me to "reset" the router. Not plug and unplug, but use the red reset button on back. Got directions on a wiki and did the job. IT WORKED! All Apple units working fine.

    Hope this helps.

  • 12. Re: iPad cannot connect to Linksys Router
    Junella A Level 1 Level 1 (0 points)

    i have a WRT45G wireless and having difficulty connecting / setting my ipad to it ... help

  • 13. Re: iPad cannot connect to Linksys Router
    NewToApple2011 Level 1 Level 1 (0 points)

    I was having connection issues with my Linksys WRT54G also.  Changed to channel 11 as suggested but still would not connect.  Then I updated the firmware from 1.02.0 to 1.02.8 and I connected fine.  I hope that helps.

  • 14. Re: iPad cannot connect to Linksys Router
    joshuafromworth Level 1 Level 1 (0 points)

    I simply Changed my router security from WPA2 to WPA Personal. No need to change it to WEP. I'm usuing and Linksys E1200 by the way. This fixed my connection issues or simply change the router to G instead of N. That may have fixed it as well.

1 2 Previous Next