Skip navigation
This discussion is archived

Mobile Device Helper has stopped working

3744 Views 2 Replies Latest reply: Apr 17, 2010 6:10 PM by Zachary Prewitt RSS
tjjonah Calculating status...
Currently Being Moderated
Apr 15, 2010 10:34 AM
I have just purchased an iPhone 3Gs, I have the lastest version of iTunes (9.1) and am operating on 32-bit Windows Vista using an Acer laptop.

First, the iPhone was not recognised - so re-installed iTunes, downloaded Service Pack 2 for vista, reinstalled iTunes. Did't work. Finally found a forum that lead me to delete a problem file for Acer laptops (can't remember its name now) but then my iPhone was now recognised!

Secondly, tried to sync my windows contacts (all my old contacta list from old phone) then had syncing problems..through more forums that error message stopped but now I have a new one that I can't get past...

'Mobile Device Helped has stopped working' comes up repeatedly and will not let me to anything with iTunes as it freezes until I end task in Task manager.

I have looked into other forums that talk of deleting the Apple Mobile Device, but it doesn't seem to me to be the rigt decision as the majority of people have just had to reinstall iTunes as it wont recognise the phone without the file.

It seems that the new iTunes doesn't like Windows Vista.

Please can anyone help me get past this point before I lose the will to live!! (it's been over 5hours now!!!!)

Thanks
Acer, Windows Vista
  • haggem Calculating status...
    Currently Being Moderated
    Apr 17, 2010 4:32 AM (in response to tjjonah)
    I have the same problem. Ever since the update I can not sync my Iphone with Itunes. The error message says: 'Mobile Device Helped has stopped working' I have so far uninstalled everything from apple and than reinstalled itunes but it still has the same problem. I also tried restarting the service but that also does not solve my problem.

    Anyone have another idea? Thanx in Advance.

    Message was edited by: haggem
    Windows Vista
  • Zachary Prewitt Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 17, 2010 6:10 PM (in response to tjjonah)
    Sort of the same issue.

    Windows Vista 64bit Home Premium.

    I just launched iTunes for the first time after installing 9.1. When I connected my iPhone, iTunes told me that I needed to install a newer version of Apple Mobile Device, which entailed removing/reinstalling iTunes and AMD. I remember there being an order to which applications should be removed, so I did that, but got stuck at AMD. I wasn't able to remove it. There was no error message, it just automatically rolled back the uninstall process and quit. I did some research and saw someone recommend using the Windows Install Cleanup Utility. I used that to remove AMD, and it worked. Next on the list was Apple Application Support (?), which also could not be uninstalled by normal means. So I used WIC on that as well. iTunes, Bonjour, Quicktime, and Apple Software update I was able to remove via the Control Panel. I rebooted, reinstalled iTunes, and when it began the install process for AMD I got this message:

    "Could not open key:
    Unknown\Components\DA42BC89BF25F5BD0AF18C3B9B1A1EE8\3F55235DF871F046A8F862841205 6EF. Verify that you have sufficient access to that key, or contact your support personnel."

    Got the same message for Apple Application Support. As a result, neither was installed.

    Prior to doing any of this, I had disabled AMD in Services, which didn't help. I have since re-enabled it, and it is still running in Services, although it does not show up in the list on programs to uninstall.

    After all this, I read in another forum that simply doing a Repair on AMD would solve the problem, but since I am unable to reinstall it, I cannot test it out.

    Message was edited by: Zachary Prewitt
    Windows Vista

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.