8 Replies Latest reply: Nov 2, 2010 2:06 PM by acyas
capaho Level 4 Level 4 (3,650 points)
I've run into some websites recently that use either java or javascript that I can no longer log into with Safari in Snow Leopard. They work in Firefox and on my G5 iMac running Leopard, but not on my Intel Macs running Snow Leopard. Has one of the recent Safari updates broken something in Snow Leopard in relation to java and javascript, particularly in relation to secure websites?

iMac 2.4 GHz Core 2 Duo, MBP 2.53 GHz, Mac OS X (10.6.1), The more I think, the more I think I shouldn't think more.
  • 1. Re: Safari Java/Javascript Broken in Snow Leopard?
    Carolyn Samit Level 10 Level 10 (89,765 points)
    HI,




    From the Safari Menu Bar click Safari/Preferences then select the Security tab.

    Where you see Web content; make sure the top 3 buttons are ticked.

    If the buttons are checked... perhaps this isn't a Java issue. Which sites are you having problems with???













    Carolyn
  • 2. Re: Safari Java/Javascript Broken in Snow Leopard?
    capaho Level 4 Level 4 (3,650 points)
    Where you see Web content; make sure the top 3 buttons are ticked.


    Well, at least you pointed me in the right direction and I found the problem. The necessary options were enabled in addition to block pop-ups, which I disabled from the file menu a long time ago. I can only guess it was re-enabled after the last Safari update, because that's when the problems started. That setting shouldn't be enabled in the security tab when it's disabled in the file menu, so I'll write this one off as a Safari bug.
  • 3. Re: Safari Java/Javascript Broken in Snow Leopard?
    Ben in Cambodia Level 1 Level 1 (0 points)
    I am having a problem with javascript too.

    I cannot book a flight on airtran.com nor can i get a quote from budgettruck.com

    The crazy thing is that before i upgraded to snow leopard I booked a flight and rented a truck...

    I had an appointment at the mac store last week and they could not fix my problem. They had the same problem as me. I tried creating another user account - but that did not work. They told me re-install snow leopard, which I have done, but did not fix my problem. The mac store got those two sites to work via another drive, but not with mine.

    HELP... any ideas? there are other websites, but these two are stuck in my head.
  • 4. Re: Safari Java/Javascript Broken in Snow Leopard?
    Flydesign Level 1 Level 1 (0 points)
    I also have has problems with Java script. The following site:http://learning.blogs.nytimes.com/category/news-quiz/ does not load properly when Java script is checked under the security prefs tab. However if you email the contents of the page, the script works within Mail program. I have ran across other sites that it does not work. I wish Apple would get back into the business of computers instead of all their attention to iphone technology. If you deselect the check box “Enable Javascript” the above link works. However it disables viewing youtube. I have tried checking and unchecking, resettind tossing out safari prefs, empty cache, reboot, just about everything I can think of and finally it landed me here. If you have any advise it would be appreciated,
    Ben 10.6.4/macpro/dual quadcore Intel Xeon
  • 5. Re: Safari Java/Javascript Broken in Snow Leopard?
    Flydesign Level 1 Level 1 (0 points)
    this answer is not answered. See my post. flydesign
  • 6. Re: Safari Java/Javascript Broken in Snow Leopard?
    MoxieBlue Level 1 Level 1 (0 points)
    Try changing your DNS:
    System Preferences> Network> Advanced> DNS
    Under DNS Servers click the + and add these two separately:
    8.8.8.8
    8.8.4.4
  • 7. Re: Safari Java/Javascript Broken in Snow Leopard?
    randym431 Level 1 Level 1 (20 points)
    this is an older thread but wanted to add my 2cents.
    i had an issue on office depot site when you clicked for live help tab, nothing happened.
    if i opened in "new window" got the java script not enabled error (it was enabled however).
    ps.. using mac snow leopard btw.
    so as above i turned off popup blocking under prefs in safari security and the live chat window then worked, came up and all.
    also there is a popup option in safari under the "safari" tab at top.
    they work together. if one is checked, the other will be checked also.

    Message was edited by: randym431
  • 8. Re: Safari Java/Javascript Broken in Snow Leopard?
    acyas Level 1 Level 1 (0 points)
    I have found since i have loaded new operating system snow leopard and have now found that certain sites wont let me see certain info. http://www.freetypinggame.net/play4.asp when on this screen the title of the test does not show nore does the time and when i take the test the results wont show me anything. I have used this site several times and now that i installed new snow leopard it does not work. Is this java or what else can i try to fix or load to make this work. Anyone know the answer.... I have asked the site itself and they have no answers for me....