Previous 1 2 Next 19 Replies Latest reply: Apr 20, 2010 9:39 PM by howwow
howwow Level 4 (3,500 points)
Hello.

These two days I've encountered this *window pop-up message* when I visited a few frequent sites, *including Apple.com*:

*Slow Script*

*Safari is no longer responding because of a script on the webpage "Apple" (http://www.apple.com/). Do you want to stop running the script, or let it continue?*

*(Buttons- Stop & Continue)*

If I hit "Stop", the site stops loading and the main page appears OK

If I hit "Continue" the site re-loads and the window message pops up again.

Thanks and cheers

iMac Intel 20" (2007), Mac OS X (10.6.3), 13" MBP (mid 2009) OSX 10.6.2 | iPhone 3GS (32Gb) 3.1.2
  • Carolyn Samit Level 10 (103,365 points)
    HI,

    From the Safari Menu Bar click Safari/Preferences then select the Advanced tab.

    At the bottom of that pane click on *Show Develop menu in menu bar*

    Now back to the Safari Menu Bar click Develop and click: *Disable Runaway JavaScript Timer*

    See if that makes a difference.








    Carolyn
  • ~Bee Level 7 (31,425 points)
    Wow, Carolyn.

    I'm impressed!
    It took me a couple of hours to find that last week.
  • howwow Level 4 (3,500 points)
    Thanks Carolyn!

    Let me try this, but I believe it should work!

    Cheers everyone
  • ~Bee Level 7 (31,425 points)
  • howwow Level 4 (3,500 points)
    Hi

    *No, actually it's not working.* If I have the 'Disable Runaway JavaScript Timer' check, when loading Apple.com site, the page will try to load (still empty page) but *keep having spinning beach ball,* and the whole Safari will be stuck with spinning beach ball.

    I *have to Force Quit* in order to use Safari again

    Cheers
  • ~Bee Level 7 (31,425 points)
    Howhow . ..
    What version of Safari are you running there?
    In other words, are you updated to the current version?

    Here's a very interesting article on this:
    http://www.weston-fl.com/blog/?p=461
  • howwow Level 4 (3,500 points)
    Hi

    I am running Safari ver. 4.0.5 (6531.22.7), the latest version. I have every other thing updated recently as well.

    The Slow Script thing only happen very recently, and I also experience the same thing on my office Mac Pro, which runs the *latest Leopard OS* and all other stuffs updated.

    Cheers
  • howwow Level 4 (3,500 points)
    Hi

    I just read the article and I must say the whole thing is pretty ironic.

    It says the possible problem of the Slow Script message is too much amount of data is loading on the webpage, and possible because of Flash content.

    Ha ha ha, I am only having this Slow Script problem on Apple.com and only a few other, very few webpages that I frequent.

    I thought Apple "hates" Flash... so how could it be possible that the main page has Flash?

    Maybe it is about time I email Steve Jobs personally and see what he has to say about this

    Cheers
  • ~Bee Level 7 (31,425 points)
    I just had a thought . . .
    You said this just started about April 14th.
    Did you make ANY changes/upgrades/deletions on say the 13th???

    ALSO:
    Do you have Click2Flash installed?
    If so, is it the latest version?

    Message was edited by: ~Bee
  • andyBall_uk Level 7 (20,490 points)
    re the article - the feature is called “Disable Runaway JavaScript Timer”
    Flash can call javascript functions, but I'm not sure that the timer relates directly to Flash... anyone know?
  • howwow Level 4 (3,500 points)
    Hi Bee,

    Besides the last round of OS, Security Updates and other Apple only updates through Software Updates, I don't remember making any changes to my iMac or Safari.

    It is just "surf as normal/routine" then this message started to pop up, as well as in the office, which I did not do regular updates often than home.

    No Click2Flash installed. What is that anyway?

    Cheers
  • ~Bee Level 7 (31,425 points)
    Howhow --

    I had seen a post by andy mentioning it in another thread,
    but it does not apply to you.

    Honestly, I have no more ideas, based on what you've told us so far.

    Maybe there is something happening with your ISP . . .
  • howwow Level 4 (3,500 points)
    Hi

    Just an update. My own MBP in the office, which is using wireless network from an AirPort from a cable modem (not through office network port) has no problem surfing Apple.com

    No 'Slow Script' message.

    I also noticed I did not turn on my MBP Safari's Advance option showing the Developer menu. When I turn it on, nothing was checked.

    "The plot thickens..." Hmmm
  • howwow Level 4 (3,500 points)
    Hi all, guess what??

    I was just "randomly, any-oh-how" trying to see if I can get rid of this 'Slow Script' message problem. So I decided to try *Reset Safari* - I checked everything, except leaving Top Sites alone 'cause I don't want to go through the hassle of setting it up again.

    ...and... wah lah. *The problem seems to have vanished!* Apple loads even faster than before!!!

    Cheers for now.
Previous 1 2 Next