1 2 Previous Next 17 Replies Latest reply: Dec 31, 2013 2:40 AM by nexhil
Al Q Level 1 Level 1 (105 points)
Trying to get my wife's iPad to connect to the internet in a hotel that has wired high speed internet but no wifi.

My MacBook Pro connects just fine. So I turned on Internet Sharing for both Bluetooth and wifi (with WEP password for wifi).

The iPad connects to the Mac by wifi but says it has no internet connection.

With Bluetooth, it pairs OK. The Mac sets it up as serial port sharing (no other choice offered, but within that there is a choice of modem or RS232 protocol). But when I try to connect it connects momentarily then disconnects right away.

Any suggestions on how to let the iPad get at the internet in this situation?

MacBook Pro 13", 4G RAM, 250GB HD, Mac OS X (10.6.3), Parallels 4.0, Final Cut Express HD 3.5, iPhone 3G.
  • 1. Re: Internet Sharing from Macbook Pro to iPad???
    Old Toad Level 10 Level 10 (115,680 points)
    in a hotel that has wired high speed internet but no wifi. The iPad connects to the Mac by wifi

    If the hotel does not have WiFi in the rooms then the iPad is connecting to the Mac via Bluetooth, not WiFi. Bluetooth only supports keyboards and headphones at this time. No internet. Craig suggested an alternative in his post here: http://discussions.apple.com/message.jspa?messageID=11347739#11347739

    OT
  • 2. Re: Internet Sharing from Macbook Pro to iPad???
    DownAndOut Level 1 Level 1 (0 points)
    What you're doing should work. I just tried the same experiment here using my MBP and iPad. I plugged into ethernet and disconnected my wireless from my normal home network. Then in Sharing Preferences I shared ethernet to Airport with no encryption and checked internet sharing. On the iPad's WiFi settings, it sees the MacBook Pro and selecting it connected right away. It still sees my real network but it says it's using the MBP. No problems browsing or using other internet enabled apps.

    Sorry I can't be of more help, but at least you know it should work...
  • 3. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)
    The problem could be in the hotel's internet setup. I have done this before in other hotels with my iphone and it worked fine. Not with the iPad, which is brand new, but it should work exactly the same. (Too bad that Apple supports only WEP for internet sharing over wifi, but with the relatively low power and the steel in the walls of a typical hotel, it is not all that big a security hole.)

    Both the iPad and my iphone connect to the network set up by the MBP, either using WEP or with security turned off. And the MBP itself seems to have full internet access.

    The MBP is on a 192.168 subnet, which is reasonable for the hotel. The iPad is on 10.0.2.1 which is presumably the subnet created by the MBP for sharing. The iPad has picked up the hotel's search domain that is also seen by the MBP, so clearly the internet sharing is working at least in part. I assume that the MBP is doing NAT, so the hotel should be seeing an IP address that it expects. It all ought to work.
  • 4. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)
    No, the MBP is CREATING a wifi network, acting as the router, in order to share its ethernet connection. I've done it before and it worked fine. But today it does not work for either iphone or ipad. See the rest of the thread.
  • 5. Re: Internet Sharing from Macbook Pro to iPad???
    tlbese Level 1 Level 1 (0 points)
    Similar to Al Q... I have a very weak wifi signal in my office so I also try to set up internet sharing with my MBP several times a week and some days it works perfectly and some days it doesn't. The iPad always connects to the MBP but some days just can't get out to the internet. Sporadic problems like this drive me crazy, none of the parameters change, but sometimes it works and sometimes it doesn't.
  • 6. Re: Internet Sharing from Macbook Pro to iPad???
    SteveCWatkins Level 1 Level 1 (60 points)
    I'm guessing this has something to do with the Hotel's network authentication setup. It may be seeing multiple MAC addresses on a single connection and not accept that. On a secured system like a hotel's would be, your attempt may not be possible.
  • 7. Re: Internet Sharing from Macbook Pro to iPad???
    DrVenture Level 2 Level 2 (180 points)
    Al Q,

    So in this case you are double natting. Do you think maybe it is a DNS problem? I would check there first.
  • 8. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)
    That is quite possible. I have had similar results in two different hotels whose login systems were from different providers, but the mere existence of a login/blocking system is an obstacle.

    My main reason for thinking this is not the problem, or at least not the whole problem, is that I found several discussion threads from others whose internet sharing had worked with Leopard and stopped working with Snow Leopard. Some were using it in hotels like me, but others were at home with a non-wireless router.
  • 9. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)
    Yes, certainly double natting. But it used to work for me, and several others, before we upgraded to Snow Leopard.

    Do you have any specific suggestions for diagnostics to try the next time I encounter this problem, or settings to change?
  • 10. Re: Internet Sharing from Macbook Pro to iPad???
    Slouis Level 1 Level 1 (0 points)

    Hi

     

    I did the following and it worked well

     

    1) Go to system preference and then Sharing

     

    2) Do Internet sharing and under edit options get it an apprproiate ID(if you prefer another one than the default name)

     

    3) Open Ipad and select the network

     

    Here you go..it worked well..Better dont do an advanced setting as you might screw up the settings..make it simle and it will work..All The Best !!

  • 11. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)

    I am still not succeeding.

     

    I just upgraded to a new Macbook Pro with Mountain Lion. Testing at home, where there are no issues around hotel ISP limitations and I feel pretty safe originating an open wifi network for a few minutes.

     

    Set up Internet Sharing from Ethernet to Wifi. Used the Create Network option for wifi in the menu bar to set up an open unprotected wifi network whose name is the name of my Mac. I can choose any wifi channel from 1 to 11; it makes no difference.

     

    I can see that network from my wife's iPad, and can connect to it no problem. But as in all similar tests since Snow Leopard came out, Safari in the iPad can't open any web sites; it says it is not connected to the internet. I can also connect to the MBP wifi from my iPhone, but if I select it, the 3G symbol still shows at the top of the screen because the phone cannot find an internet connection over that wifi.

     

    Clearly some other people are managing to do what I cannot. Quite possibly some piece of third party software on my Mac is interfering. Little Snitch, for example, though it is currently turned off.

  • 12. Re: Internet Sharing from Macbook Pro to iPad???
    nexhil Level 1 Level 1 (10 points)

    Hi!

     

    I don't know if you still need this, but tonight I came across the same problem.
    I was connected with my iPad 4 and iPhone 5 with my Mac but no internet.
    I changed the DNS to 8.8.8.8 on my iPhone and iPad and it works now (Even home sharing, I'm sharing on my attic)

  • 13. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)

    Brilliant idea. My iPhone was able to connect to the internet using the Mac's shared network (ethernet to wifi).

     

    So in Network Sharing mode, the Mac is routing internet traffic properly but is not properly handling DNS requests.

     

    My LAN router is at 192.168.2.1 and my Mac is at 192.168.2.13 on that subnet. When the Mac shares that ethernet, it creates a subnet 19j2.168.3 for the wireless link, with itself as the router at 192.168.3.1. Using DHCP it gives its own address as the DNS server on that subnet (as seen by my iPhone when I connect). But when it receives DNS requests at its router address, it clearly is not forwarding them to the DNS server addresses that it uses itself (which in this case are 192.168.2.1 and 8.8.8.8).

     

    I will create a bug report for this behaviour, and maybe we will finally see a fix. The bug has been around since Snow Leopard with many complaints in the forums but maybe no formal bug reports.

     

    So thanks a lot nexhil. Wish I had thought of trying that years ago.

  • 14. Re: Internet Sharing from Macbook Pro to iPad???
    Al Q Level 1 Level 1 (105 points)

    Update: I spoke a bit too soon.

     

    This fix worked for my iPhone running IOS 6.1.1. However it did not work for my other Macbook running Lion, or for my wife's first generation iPad running an older IOS (the latest that supports it). They continue to connect to the wireless link with no problems, but cannot open any web sites or connect to mail servers.

1 2 Previous Next