Previous 1 2 Next 26 Replies Latest reply: Jun 27, 2013 6:42 PM by William Paplham
JoshuaG10 Level 1 (0 points)
I have a 2x Dual-Core Xeon XServe, running OS X Server 10.6.3, and a DroboPro. I was able to succesfully connect the Drobo, but data transfers turned up FireWire errors. They show up on Console, but don't pop up as drive errors. The errors trace to the method
(the error mesage is "fast packet start length < orblength)")

Unfortunately, after having spoken with both Apple Enterprise Support and Drobo support, no one has given me a solution. Apple indicated that the problem is known, however; unfortunately, they have no front-facing information. Drobo didn't know about the problem. Apple stated that the problem may have to do with memory (my XServe has 32GB). I was not able to reproduce the error on a MacBook Pro, but it had much less RAM.

Anyone else having this problem? The best IO I can do right now is iSCSI, which is not as fast (in theory it should be, but that's ignoring overhead). iSCSI is only marginally faster than USB.

XServe, Mac OS X (10.6.3)
  • JoshuaG10 Level 1 (0 points)
  • DaddyPaycheck Level 6 (16,030 points)
    Does Drobo have a firmware update available?
  • ponta1956 Level 1 (5 points)
    I'm in same trouble. My machine is MacBook Pro (mid 2006) running OS X 10.6.3 with Drobo S.
    Mar 23 21:03:56 MacBookPro kernel[0]: IOFireWireSBP2ORB<0x05fcc400>::prepareFastStartPacket - fast start packet not full, yet pte doesn't fit
    Mar 23 21:03:56: --- last message repeated 4 times ---
    Mar 23 21:03:56 MacBookPro kernel[0]: disk1s2: I/O error.
  • JoshuaG10 Level 1 (0 points)
    No, there's no firmware update that addresses this. They've been having trouble reproducing the error.
  • JoshuaG10 Level 1 (0 points)
    I'm sorry to head that you are having the same problem, but I appreciate the confirmation.

    If you wouldn't mind, can you post in the droboforum thread about this same issue? Maybe we can get the two to talk.

    Also, of course, you don't have a second ethernet port; are you using iSCSI?

    What kind of performance are you getting?
  • JoshuaG10 Level 1 (0 points)
    Oh, and I was told that more RAM seems to be linked to the problem. I have 32GB; how much do you have?
  • Doug F. Level 2 (185 points)
    I have an October 2006 MBP C2D with 3G RAM. It has both FW800 and FW400. I also have a DroboPro with 8x 2T drives (WD20EADS).

    I am seeing the same error (repeated over and over) in kernel.log and data corruption when using FW800.

    After spending quite some time on the phone with Data Robotics, we determined that it is this computer that is having a problem. Using the DroboPro via USB or via FW800 on another computer (a slightly newer nVidia version of this same laptop) doesn't encounter the problem.

    I would hate to think I need to get new hardware, as I can't imagine giving up my dual-firewire ports, so I hope it's not a hardware problem. They don't make Mac laptops with enough ports anymore.

    Anyone learn anything else, please?


  • chiefgeek Level 1 (0 points)
    Same problem here. MacPro dual quad-core with 14gb ram. DroboPro running DroboDashboard 1.7.29352 and firmware 1.1.5.

    Three 1TB drives and one 750GB in the Drobo.

    My problem seemed to arise when I attempted to connect the iSCSI connection to my second ethernet port.
  • Tim Benson1 Level 1 (0 points)
    Hi there,

    Just to let you know that I have just purchased and configured a DroboS and I have exactly the same problem with my Mac Pro running Mac OS X 10.6.3 client. Connectivity via USB is fine, but FireWire 800 causes a Finder error -36 upon reading a file, and yields exactly the same kernel logging of FireWire errors:

    B<0x11082900>::prepareFastStartPacket - fast start packet not full, yet pte doesn't fit
    kernel[0]: IOFireWireSBP2ORB<0x11082900>::prepareFastStartPacket - fast start packet not full, yet pte doesn't fit
    --- last message repeated 27 times ---

    My DroboS has current firmware (2.0.1) and I am using the current Drobo Dashboard (1.6.8). I have completely reset the DroboS several times, reformatted the volumes, and tried different cables and ports. There are no other devices on the FireWire bus, and other devices do not experience any issues.

    I have had no luck with Data Robotics Support yet - they just tell me to check cables and ports again

    Will post again if I make any progress, but otherwise I will return my unit because USB is far too slow (~20 Megabytes per second). eSATA is not even an option on most Macs either.


  • xgenius Level 1 (0 points)
    Have you tried using just the native RAM that came with the XServer or even stepping it down to 4 GBs of RAM to test it out? I have found through the years that making the system a bit more base can help a ton in figuring out where the trouble lies.
    What all that you have written so far my suspicions for what could be wrong would be 1 or more RAM cards, a memory slot on the Logic board, a bad framework for the FW, a corrupted OS kernel.
    There are several great ways of testing each so try it out. I know it's hard to get the time to appropriately troubleshoot a server, but an hour here and an hour there can do wonders.

    Let me know if you have any questions in particular or want more detail.
  • K. Scott Myers Level 1 (45 points)
    Hi Tim, did you find a solution to this - I'm having the exact same issue with my Mac Pro. Any help would be appreciated.

  • Doug F. Level 2 (185 points)
    I have the newly released latest firmware (1.1.11) and 10.6.4 and this issue is still not resolved. The only solution seems to be to use USB or Firewire.

    Anyone else have any luck?
  • BGH Level 1 (0 points)
    Yep same here: We use Drobo fro CrashPlan destination. Errors coincide with CrashPlan writing to the DroboPro. Server 10.6.4 and drobo FW 1.1.11 connecting over FW 800 . Have swapped cables and ports. Issue persists.
  • westinmylifeaway Level 1 (0 points)
    Do you have an available slot in your Xserve? If so you could try a third party FireWire host adapter. NitroAV sells a variety of cards, they offer 3 port cards for approximately $60. The reason I suggest this is your observation that the Drobo performs better on a different hardware configuration.
Previous 1 2 Next