3 Replies Latest reply: Apr 21, 2010 6:50 AM by Jolly Giant
vegirlizzyq Level 1 Level 1 (0 points)
I hope someone can help me. It was working just fine earlier. I went to plug it in, thinking I left it on, and it won't charge, at all. I've tried different outlets, different plugs, USB, restarting it.. it's just black! Nothing comes up at all. What happened??!!!

iPod Touch 8g
  • Jolly Giant Level 7 Level 7 (25,440 points)
    try to connect in recovery mode: http://support.apple.com/kb/HT1808.

    JGG

  • vegirlizzyq Level 1 Level 1 (0 points)
    Jolly, that didn't work

    Nothing comes up on the screen at all, like it not recognizing the charger at all.
  • Jolly Giant Level 7 Level 7 (25,440 points)
    couple more things to try:


    Try reseting it. Make sure the hold switch is off, then hold the middle button and the "Menu" button down for about 7-8 seconds. Now try plugging it into your computer. If the problem persists make sure there is nothing in the iPod charger socket. Sometimes if you carry your iPod in your pocket a lot, lint will build up in there


    and


    The first thing you should try is another USB slot on your computer. If that does not work, then try restarting your computer. If you continue to have problems, try a completely different computer. After trying all of the above, and your unit still not working, your unit could have a bad system board. Look at the bottom of your unit and make sure there is no corrosion(liquid damage). Also check to see if you see any bent pins, this can also cause your USB port on your ipod not to work. Check with apple to see if the unit is still under warranty with Apple with this site: https://selfsolve.apple.com/GetWarranty.do

    The serial number can be found on the back of the unit toward the bottom


    JGG