5 Replies Latest reply: Feb 21, 2012 10:45 AM by Nittles
andrchr Level 1 Level 1 (0 points)
I have an early 2009 mac mini (10.5.7) that I want to connect via airport to my existing wifi (b/g) network. The router is a Belkin Part # F5D7230-4 wireless g router. The network is setup with wpa security. My mac mini can recognize the network but when it tries to connect the wheel spins and then I get a "connection timeout" error.

I know the network is fine. I have other macs and pcs that connect to it no problem. I also know that the mac mini's hardware is fine. I took it into the Apple store and it connected without a problem to their networks.

I'm at a loss to figure out the answer. While there is a wall between the mini and the router, it is otherwise less than two feet from the router. I've tried playing with the router's channel settings, broadcasting on just g instead of mixed g/b, etc., and no luck.

Any thoughts on what's wrong?

The Apple genius told me it is probably because I'm not using an apple router. I don't buy that, given the whole point of the wireless standards is supposed to be compatibility.

I'd appreciate any advice people might have.

Message was edited by: andrchr

mac mini early 2009, Mac OS X (10.5.7), belkin Part # F5D7230-4 wireless g router
  • andrchr Level 1 Level 1 (0 points)
    I'm not sure why this worked, but I turned off all security on the router and the mac mini connected. Then I turned the security back on and it no longer gave me the connection timeout error. I consider it resolved, but I'd be interested if someone understands why that solution worked.
  • crouchie Level 1 Level 1 (0 points)
    I had exactly the same problem with my older Mac mini - kept dropping the wireless network and became progressively harder to get it to pick up the network again. It could see the network, but couldn't connect successfully - kept timing out. I removed the security passcode and now no problems. All other devices in the house no problem (including two pcs, 1 iPad, 2 iPhones and another newer Mac mini)....bizarre. And no, I didn't have caps lock on!
  • MrARH Level 1 Level 1 (0 points)
    Mine has just started doing this....

    Have a wireless network that 2 IBM laptops, an iMX, ipad, ipod touch and apple TV happily share.
    The wireless network is provided a NetGear DG834G wireless ADSL router

    So did my 1.66Ghz Core Duo MacMini.... Until last week.

    Now trying to connect to the wireless router, I get timeout issues - nothing I do will fix it. Reboot - mini, router; Renaming the network etc. I thought it was interference so changed the channel.

    The mini also connects fine to a Airport Express I have installed.
    I cannot work it out. The router has not changed - and all my other devices work fine. The MacMini sees lots of local wireless networks, and will connect to my Airport express. And I have wired internet access

    When connecting it continually askes for my WEP key - which I happily provide.
    But it does not remember it - and times out.

    All software is up-to-date including the recent MacOS update (could it be this?)
    Netowkr diagnostics suggest wrong key, or network type.

    But am pretty sure all is ok. And have tried 26 char WEP keys with $ or non $ infront of them

    And I have tried the 5 or 6 different ways you can set this up - icon, network preferences, etc...
    Any expert thoughts would be helpful at this point.

    There is this worrying entry in the console logs - about when all the problems started

    --------


    rocess: airportd [388]
    Path: /usr/libexec/airportd
    Identifier: airportd
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: launchd [1]

    Date/Time: 2010-12-13 20:59:03.061 +1100
    OS Version: Mac OS X 10.6.5 (10H574)
    Report Version: 6

    Anonymous UUID: C4AC0617-1F23-41DC-87D4-5BF136797AF5

    Exception Type: EXCBADACCESS (SIGBUS)
    Exception Codes: KERNPROTECTIONFAILURE at 0x0000000000000000
    Crashed Thread: 2 Dispatch queue: airportd cmd q

    Thread 0: Dispatch queue: com.apple.main-thread
    0 libSystem.B.dylib 0x916720fa machmsgtrap + 10
    1 libSystem.B.dylib 0x91672867 mach_msg + 68
    2 libSystem.B.dylib 0x916de138 machmsgserver + 696
    3 airportd 0x00006ee7 0x1000 + 24295
    4 airportd 0x00002235 0x1000 + 4661

    Thread 1: Dispatch queue: com.apple.libdispatch-manager
    0 libSystem.B.dylib 0x91698982 kevent + 10
    1 libSystem.B.dylib 0x9169909c dispatch_mgrinvoke + 215
    2 libSystem.B.dylib 0x91698559 dispatch_queueinvoke + 163
    3 libSystem.B.dylib 0x916982fe dispatch_workerthread2 + 240
    4 libSystem.B.dylib 0x91697d81 pthreadwqthread + 390
    5 libSystem.B.dylib 0x91697bc6 start_wqthread + 30

    Thread 2 Crashed: Dispatch queue: airportd cmd q
    0 airportd 0x00018c1c 0x1000 + 97308
    1 airportd 0x00020f8f 0x1000 + 130959
    2 airportd 0x00013bee 0x1000 + 76782
    3 airportd 0x00003192 0x1000 + 8594
    4 airportd 0x00005a09 0x1000 + 18953
    5 airportd 0x00006ac2 0x1000 + 23234
    6 libSystem.B.dylib 0x916a6024 dispatch_call_block_andrelease + 16
    7 libSystem.B.dylib 0x91698a8c dispatch_queuedrain + 249
    8 libSystem.B.dylib 0x916984e8 dispatch_queueinvoke + 50
    9 libSystem.B.dylib 0x916982fe dispatch_workerthread2 + 240
    10 libSystem.B.dylib 0x91697d81 pthreadwqthread + 390
    11 libSystem.B.dylib 0x91697bc6 start_wqthread + 30

    Thread 2 crashed with X86 Thread State (32-bit):
    eax: 0x00000000 ebx: 0x00000000 ecx: 0x0003693f edx: 0x00000000
    edi: 0x00000000 esi: 0xa01814c0 ebp: 0xb01029c8 esp: 0xb0102990
    ss: 0x0000001f efl: 0x00010213 eip: 0x00018c1c cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x0000001f gs: 0x00000037
    cr2: 0x00000000

    System Profile:
    Model: Macmini1,1, BootROM MM11.0055.B08, 2 processors, Intel Core Duo, 1.66 GHz, 2 GB, SMC 1.3f4
    Graphics: Intel GMA 950, GMA 950, Built-In, spdisplaysintegratedvram
    Memory Module: global_name
    AirPort: spairportwireless_card_type_airportextreme (0x168C, 0x86), Atheros 5424: 2.1.14.5
    Bluetooth: Version 2.3.8f7, 2 service, 12 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Network Service: Built-in Ethernet, Ethernet, en0
    Serial ATA Device: ST98823AS, 74.53 GB
    Parallel ATA Device: MATSHITADVD-R UJ-846
    USB Device: Keyboard Hub, 0x05ac (Apple Inc.), 0x1006, 0xfd600000
    USB Device: Microsoft® 2.4GHz Transceiver v5.0, 0x045e (Microsoft Corporation), 0x074f, 0xfd630000
    USB Device: Apple Keyboard, 0x05ac (Apple Inc.), 0x0220, 0xfd620000
    USB Device: USB2.0 Hub, 0x05e3 (Genesys Logic, Inc.), 0x0606, 0xfd500000
    USB Device: UM-1, 0x0582 (Roland Corporation), 0x009d, 0xfd510000
    USB Device: My Book 1110, 0x1058 (Western Digital Technologies, Inc.), 0x1110, 0xfd300000
    USB Device: LaCie HD Drive, 0x059f (LaCie), 0x0621, 0xfd100000
    USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8205, 0x7d100000
    USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8240, 0x7d200000


    -------------

    And from the recent Airport Utility Update this error

    Process: AirPort Base Station Agent [930]
    Path: /System/Library/CoreServices/AirPort Base Station Agent.app/Contents/MacOS/AirPort Base Station Agent
    Identifier: AirPort Base Station Agent
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: launchd [160]

    Date/Time: 2010-12-17 22:28:49.479 +1100
    OS Version: Mac OS X 10.6.5 (10H574)
    Report Version: 6

    Exception Type: EXCBADACCESS (SIGSEGV)
    Exception Codes: KERNINVALIDADDRESS at 0x00000000916720fa
    Crashed Thread: Unknown

    Backtrace not available

    Unknown thread crashed with X86 Thread State (32-bit):
    eax: 0x00000000 ebx: 0x00000003 ecx: 0xbfffe15c edx: 0x916720fa
    edi: 0x00000000 esi: 0x00000000 ebp: 0xbfffe198 esp: 0xbfffe15c
    ss: 0x0000001f efl: 0x00010206 eip: 0x916720fa cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
    cr2: 0x916720fa

    Binary images description not available

    -------
    And this from my system log

    17/12/10 10:28:46 PM com.apple.launchctl.Aqua[967] com.apple.AirPortBaseStationAgent: Already loaded
    17/12/10 10:28:49 PM com.apple.ReportCrash.Root[988] 2010-12-17 22:28:49.483 ReportCrash[988:2603] Failed to create CSSymbolicatorRef for AirPort Base Station Agent
    17/12/10 10:28:49 PM com.apple.launchd.peruser.501[160] (com.apple.AirPortBaseStationAgent[930]) Job appears to have crashed: Segmentation fault
    17/12/10 10:28:49 PM com.apple.ReportCrash.Root[988] 2010-12-17 22:28:49.511 ReportCrash[988:2603] Saved crash report for AirPort Base Station Agent[930] version ??? (???) to /Library/Logs/DiagnosticReports/AirPort Base Station Agent2010-12-17-222849localhost.crash

    ----------
    And this from about trying to make Connections - Hawaii is my wireless network name

    17/12/10 10:35:46 PM airportd[1073] Apple80211Associate() failed -3905 (Timeout)
    17/12/10 10:35:46 PM Apple80211 framework[970] airportd MIG failed (Associate Event) = -3905 (Timeout) (port = 44395)
    17/12/10 10:35:46 PM SystemUIServer[970] Error joining Hawaii: Connection timeout (-3905 timeout connecting)
  • RA$OR Level 1 Level 1 (0 points)

    Hi MrARH

     

    Did you find a fix for your problem. I would be interested to know if you found a solution as I am experiencing the same problem and it's 'doing my head in'.

  • Nittles Level 1 Level 1 (0 points)

    I had this problem and noticed that I had a couple of passwords saved in Keychain Access for the same wireless network. I deleted all but the current password and I am able to connect fine.