6 Replies Latest reply: May 31, 2010 10:19 PM by scottyr
cascadesjohn Level 1 (0 points)
Just used Migration Assistant to move everything from old MBP to new MPB, latest Snow Leopard. I own Aperture 3 after downloading and paying for the upgrade software. Aperture 3 worked fine on the old MBP, now wants my serial # on the new MBP. The serial # for Aperture 3 upgrade is not accepted. It asks for "original" serial #. I've owned versions 1, 1.5 and 2. I don't have any of those serial numbers anymore. Advice, please.

MacBook Pro, Mac OS X (10.6.3)
  • Tony Gay Level 4 (1,630 points)
    Advice
    in the future email serial numbers to yourself and keep them archived allowing you to refer back to them at any time.

    As for you missing serial numbers...

    In purchasing the upgrade do you have to provide the serial number?
    Do you still have all the tax receipts for you previous versions?
    Did you purchase all of your software from the one reseller?

    Did you purchase the previous upgrades on line? If so Apple in their email provides you with the serial number for your new version.

    Tony
  • David Slater Level 6 (18,770 points)
    NEVER NEVER NEVER migrate pro apps
    they install stuff all over the place (places Migration assistant doesn't look)


    as for your missing number what happened too them?
  • cascadesjohn Level 1 (0 points)
    Good advice on the emailing of nos. to myself. I've begun using 1Password to achieve the same result.
  • cascadesjohn Level 1 (0 points)
    Thanks for the info on not migrating pro apps. I wish Apple would have the courtesy to either 1) tell us innocents that fact or, 2) make Migration Assistant a more savvy product. I'll know better next time.
  • scottyr Level 1 (10 points)
    I have a similar problem and can't get out of it.
    I used Migration Assistant to move Aperture 3 from my old iMac to a my new iMac. I launch Aperture 3 and it asks for the serial number. I enter the serial number from the box and the app freezes. It did this repeatedly. I even tried to delete the plist file but no luck.

    I tried to uninstall and reinstall and I get the same problem. It asks for the serial number, I enter the number from the box and the app freezes. I always have to force quit to get out.
    If anyone can help, I'd sure love to hear it. Thank you...
  • scottyr Level 1 (10 points)
    I was later able to self diagnose and fix. For those with the same issue, I deleted the ProAppsSystemID file in library/application support/ProApps and this got me past the freeze.