2 Replies Latest reply: Apr 23, 2010 11:24 AM by eamsoundartist
eamsoundartist Level 1 (0 points)
I'm a mac user with a fetish for old IBM Model M clicky keyboards. After some sniffing around and buying a few cheap adapters that didn't work, I found this product on www.clickykeyboards.com :

http://www.clickykeyboards.com/index.cfm/fa/items.main/parentcat/11298/subcatid/ 0/id/124184

In short, it doesn't seem to work right with key modifiers in 10.6 whereas it did in 10.5


The longer story with details...

In leopard, it worked like a charm. Most important to me of course was flexibility of layout in the modifier keys. Starting from the bottom left, standard mac layout is:

control ... option(alt) ... command(apple)

My keyboard (late 80's classic Model M) has:

ctrl ... [grey plastic] ... alt

...and the normal functionality you get when you plug in a standard 104-key windows keyboard to a mac by USB is:

ctrl = control
alt = option
windows = command

So I map as follows using the modifier keys remap function in the keyboard pane of sysprefs:

ctrl = control
alt = command (so it's in the same place that it would be on a mac keyboard
caps lock = option

And it worked beauty. The LED's for num/caps/scroll didn't do anything, which was fine, who needs them. And when I booted to WinXP via BootCamp, it also worked properly. F12 worked for both eject and dashboard, awesome.

Just got the new snow-kitty and the remap stopped working! All the keys on the board work as designed, but no matter how I map the modifier keys in SysPrefs, alt is locked to option, ctrl to ctrl, caps lock to caps lock, the LED's work again (weird), and I have no apple key! It's like the remap values I choose are getting overridden in hardware or something.

Anyone have any ideas? Could be the USB/PS2 converter needs a 10.6 driver, but I can't figure out who the manufacturer is...

Before anyone suggests it, using a newer keyboard is not under any circumstances a viable option

Mac Mini, Mac OS X (10.6.3)
  • Tom Gewecke Level 9 (77,115 points)
    Anyone have any ideas? Could be the USB/PS2 converter needs a 10.6 driver, but I can't figure out who the manufacturer is...

    Ask the place where you bought it. I suspect that only the people who made the thing can help you (unless someone else has made a converter that does work in 10.6).
  • eamsoundartist Level 1 (0 points)
    Already asked them earlier today, awaiting reply. They've been very helpful in the past so fingers crossed.

    I see this getting fixed by either a driver update from the manufacturer, which I'm not super-confident about since the converter has kind of a brand-X chinese vibe and no documentation whatsoever, or a different (perhaps newer) converter. Will post any follow-up I get from clickykeyboards.com here.

    *brews coffee*