Skip navigation

Error: "failed to load book because the requested resource is missing"

38304 Views 20 Replies Latest reply: Oct 19, 2013 4:59 AM by DaLama RSS
1 2 Previous Next
Brian Madden Calculating status...
Currently Being Moderated
Apr 23, 2010 8:43 PM
I book a book via the iPad. The book appeared in my library no problem with the "new" tag and stuff, but when I tap it to read I get an error "failed to load book because the requested resource is missing." Any ideas? I'm on the road, so I haven't synced or backed up or anything..

I've also verified that I have a good connection, etc. I'm able to hit the "store" button and browse the store no prob, as well as web, etc.

Any thoughts?
iPad, Other OS
  • Enrique Quintero Calculating status...
    Hi Brian,

    I would try re-downloading it. First delete it, then download it again. iTunes will prompt you, you have already purchased this item, do you want to download it again?

    I hope this helps.

    Cheers.
    iPad 16G Wi-Fi, Other OS, iPhone OS 3.2
  • Rider77 Calculating status...
    Enrique's solution worked great on my brand-new iPad. The redownload took less than a minute, so on this version the delete event was " soft " meaning the iPad kept the iBook content on its hard drive .

    DrJ
    iPad Wifi 69 gig, iPhone OS 1.x
  • Vern Dempster Calculating status...
    Worked for me as well. Must be something to do with having the sample on my ipad already. Deleted and purchased again, it said I had a free download and 10 secs later it was there to read.
    Cheers
    Vern Dempster
    ipad 32, iPhone OS 3.1.3
  • cdolander Calculating status...
    I have tried all of the suggestions and none work: I have deleted the App and reinstalled it; I have deleted books I purchased and reinstalled them. I have repeatedly attempted to open books I have purchased, only to get: "Failed to load because the requested resource is missing". The title and author appear at the top of a blank page, with that message popping up immediately. Ironically, this only happens with books I purchased. Free books load just fine. I guess the moral of the story is: (a) don't buy books from the IBookstore, only download free ones; (b) go to Amazon and use the Kindle App; and (c) hope that someone at Apple puts some attention to this problem. As an Apple fanboy, I'd prefer to purchase books from IBookstore, but not with headaches like this.
    iPad, iPhone OS 3.1.3, Desktop Mac Mini
  • ericwagoner Calculating status...
    This is happening to me now, too. I've deleted and re-downloaded, and am still locked out of nine books I have bought.

    I get the same error on both the iPhone and the iPad, so I'm also guessing it's a bookmark sync gone bad. As it stands now, I cannot read any of the books I have bought on any of my devices.
    iMac, MacBook Pro, MacBook, iPhone 4, iPad, iOS 4
  • jkint Calculating status...
    I have done all of this also, the only difference is i'm using the ios 4.2 beta on my iPad, I purchased a good development book, but can't read it on my development iPad... sort of killing the intent... I have noticed that when It asks me to sync the book marks it asks for my login constantly till I say cancel...
    So yeah I'm guessing it's a book mark syncing issue.
    iMac 24" 3.06 GHZ, Mac OS X (10.6.4)
  • ericwagoner Level 1 Level 1 (0 points)
    Oh, good call. I'm also using 4.2 beta on the iPad. I've read books since upgrading the os, so it worked for a while. I don't have the beta on my iPhone -- maybe there's a sync mismatch between the two os versions? I'll try putting the beta on the phone and see if it's still broken.
    iMac, MacBook Pro, MacBook, iPhone 4, iPad, Mac OS X (10.6.4)
  • muthuka Level 1 Level 1 (20 points)
    I have the same iOS 4.2 beta 3 and iBooks is not working. I get both sign in popup and sync message. I re-downloaded my books and still they are not working.

    ****! I feel like I am in seattle campus !
    Macbook Pro 15.4", iOS 4, iOS 4.2 Beta 3
  • REBELinBLUE Level 1 Level 1 (5 points)
    The release notes specifically says that iBooks does not work in beta 3
    24" LED Cinema Display and 2.53GHz Macbook Pro, Mac OS X (10.6.4)
  • ericwagoner Level 1 Level 1 (0 points)
    Huh. There it is, listed under "FairPlay". Must have missed that bit. Thanks!
    iMac, MacBook Pro, MacBook, iPhone 4, iPad, Mac OS X (10.6.4)
  • REBELinBLUE Level 1 Level 1 (5 points)
    I myself missed it. Upgraded hours after buying 3 iBooks. Hopefully beta 4 won't be long >_<
    24" LED Cinema Display and 2.53GHz Macbook Pro, Mac OS X (10.6.1)
  • Zeek_ Calculating status...
    I believe I may have the answer to these many concerns. 

    When a book is over 20 or so megs, iBook will sometimes make an attempt to download on the iPad (when it should not). This causes problems. Perhaps the one you are experiencing. Therefore you have to wait until you are on a wifi connection before purchasing dictionary-like books. But if you've already made the mistake of downloading, theres no guarantee wifi will correct this. 

    What worked for me (like others have already mentioned) is that if you have an iphone or touch you can download it from there, sync with your computer and sync your iPad later. The book(s) will transfer just fine as long as you have this enabled on your devices.

    Initially this didn't work for me because in my frustration with a prior issue I took the liberty to create another iTunes account. Therefore iPad purchases were not visible on my phone. So be sure to have the same accounts activated on your devices and iTunes. 

    Yet even further diagnostics may need to be explored as I'm still prompted to provide my password every time i open iBooks (as if the download is still pending). Kinda afraid to revert to factory settings over a small issue. In the coming update Apple should fix these problems altogether. Hope this helps!
    Ipad, iPhone OS 3.1.3
  • T_man Calculating status...
    I don't mind dealing with the usual issues associated with beta releases but apple needs to revamp the iPad Beta process. Forcing me to upgrade a beta version to newer beta version that breaks key functionality (eg ability to read purchased books) without offering a way to downgrade is awful. I would have rather stayed on beta 2 and continued to help identify conflicts and other unreported issues than to upgrade and lose this key functionality.
    iPad, iOS 4
  • padder Calculating status...
    I have the beta 4.2 IPAD and tried to completely delte the book, off harddrive etc. and syc with ipod the book then back to ipad and still same error message
    "failed to load because requested resource etc. BS BS)

    Is there any way apple will support us????
    Windows Vista
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.