8 Replies Latest reply: Jul 13, 2010 12:06 PM by tomfrost
Revive Revival Level 1 (0 points)
Hello,
yesterday I was installing new applications from iTunes Store on my iPod Touch when it turned off suddenly. Since then, when I switch it on, the Apple logo appears on the screen for a few seconds and then it shuts down again. The same thing happens when I connect it to my computer, the logo appears and my iPod turns down a few seconds later. The iPod doesn't reload its battery once connected to the computer and iTunes doesn't even launch. Can anyone help me ?

PS: sorry if my English isn't perfect, I live in Belgium.

Sony Vaio VGN-AW31M, Windows 7
  • Ingo2711 Level 7 (22,485 points)
    Welcome to the discussions,
    try to charge it using the adapter for at least 15min. and connect again to your computer afterwards.
    If it is not recognized, connect in recovery mode: http://support.apple.com/kb/HT1808
  • LucEdwards Level 1 (0 points)
    I have the same problem. The Ipod is charged and and will not connect to Itunes because the computer doesnt recognize it.
  • Ingo2711 Level 7 (22,485 points)
    Did you check if Apple Mobile Device Service is installed? http://support.apple.com/kb/HT1747
    Did you check your USB drivers? http://support.apple.com/kb/TS1538
    Did you try to connect in recovery mode? http://support.apple.com/kb/HT1808
  • hcrwriter Level 1 (0 points)
    my son is having the same problem. It shut off while he was trying to delete apps. He plugged it in using a usb wall charger for the night. still wouldn't come on. I have had it plugged in for a couple of hours now on my computer, and it will still only show the really low battery charge or the white apple. the bottom left corner by the charge cord feels warm. i tried holding both buttons to see if it would show in itunes, no luck. I tried your instructions at http://support.apple.com/kb/HT1808. but I can't get the connect to tunes picture, only the low battery with the lightning bolt. What now? Its an 8gb. Gifted to him last Oct. No warranty. my 8gb i pod touch shows up fine on same computer with same cord.
  • monepone Level 1 (0 points)
    If any of you upgraded to iOS4 prior to this happening, that is likely what your problems is. iOS 4 has a bug that is draining the battery at an alarming rate and likely damaging our batteries in the process. There is a discussion about it here http://discussions.apple.com/thread.jspa?threadID=2474499&tstart=0

    Please send feedback to Apple and ask them to fix this problem.
  • hcrwriter Level 1 (0 points)
    The i pod is fixed. I got a tech that knows his stuff. It wasn't updated to version 4 by the way. It is now though. To reboot it I had to do a slight variation from what they say on the instruction page online. plug it in. After about two minutes hold both buttons until it shuts off then comes back on. Don't unplug it like it says online. Let go of the top button but keep the home button pressed. It will bring up the connect to itunes thing then. I had to do this a few times because I had to update my itunes and then it had to download the new software for the ipod. My son had to reinstall everything because he hadn't done a backup before, but it works.
  • palz2015 Level 1 (0 points)
    I know! I ran my battery app and it went from 90% to 80% in 10 minutes!
  • tomfrost Level 1 (0 points)
    Yesterday, I upgraded the to latest version of iTunes and I have had nothing but problems with my ipod touch ever since. I have "recovered" five or six times and it works for 15 minutes to an hour and then, for no reason, it shuts down and I get the message that I'm in a recovery mode. The end result of all my recoveries is that it works, then shuts down. Any solutions? Thanks.