4 Replies Latest reply: Apr 27, 2010 1:47 AM by Ingo2711
TJ65 Level 1 (0 points)
OK, here we go. I have an old Belkin wireless router (F5D6131-4) "B" type, that only uses WEP security. I have done the latest firmware update they offer. My Ipod touch 3d gen, will see the network, when I enter the 128 bit, 26 number/letter encryption, it says invalid password. It works on all 3 of our family laptops. I changed the encryption to 64 bit, with a 10 number/letter passcode, worked on the laptops, not the Ipod. I went to wifi settings on the Ipod, and put in my network manually, so I could be sure the encryption was set to WEP, still no dice. Then I disabled my WEP encryption on my router...works fine, grabs the net and I am surfing. This tells me that the encryption is the problem. So, the Ipod is suppose to handle WEP, what else am I missing ? Do I need to update my router ? I know WEP is outdated and can be cracked, but I dont want to run wide open all the time. Oh, by the way, i have reset the Ipod and the router a few times, still nothing. HELP ????

Ipod touch 3d gen, iPhone OS 3.1.2