Previous 1 2 Next 15 Replies Latest reply: Jul 26, 2010 2:34 AM by Martim Weinstein
Martim Weinstein Level 1 Level 1
27" iMac, 10.6.3, all software and firmware updates installed.

Without getting into too much detail let's say I tested everything from the router to the switch to the cables, mixing and matching everything until reaching the conclusion that it's the iMac. This is a network I built and configured myself, so I know it quite well. Last test was connecting my 15" MBP to the same cat6 cable the iMac cannot detect, which my MBP detects and works with without a hitch.

I've reset the SMC, rebuilt permissions, re-installed OS X, reset pram. I've restarted pressing "v" for a hardware test both with the OS X install DVD in the drive and out but nothing happens. Not sure if anything is suppose to happen...

Wifi works fine but is unacceptable to transfer various gigabyte size files for which I need the Gigabit network

If the ethernet port were dead would it still show up in the system profiler? (it does)

I'm really struggling here.... any more ideas?

MacBook Pro Core2Duo 2.8 GHz, Mac OS X (10.6.3), 4 GB RAM, 500 GB HD
  • Dah•veed Level 7 Level 7
    expertise.macappstore
    Mac App Store
    To get the Hardware Test, at least on my Macs, you (re)start the Mac, quickly insert the Install DVD and press & hold the D key. I am not aware of the V key alone doing anything at startup. V + Command starts in Verbose mode.

    Is Ethernet configured properly in System Preferences/Network/Ethernet/Advanced/Ethernet?


    Dah•veed

  • Martim Weinstein Level 1 Level 1
    My mistake. I pressed D, not V. I did it again just in case and can confirm nothing happens. What is suppose to happen? It opens an application?

    1 thing I didn't mention is that Ethernet has been working fine for the few months that I've had the iMac. All of a sudden I didn't have internet and as I investigated why, I found the error message on the network prefs.

    I've tried a few different settings in the advanced -> Ethernet to no avail, but it's always been on automatic even when it was working.
  • xtech Level 1 Level 1
    Could be a faulty ethernet jack ... although I would reboot first in safe mode/boot to confirm using
    half-split search technique we use as certified techs. Follow these steps to confirm the jack is ok
    and not a software related issue first.

    Instructions: http://support.apple.com/kb/ht1455

    This will save some time before next troubleshooting step(s).

    "Real sites are for the web and blogs are for frogs!"
  • Martim Weinstein Level 1 Level 1
    Rebooted in safe mode, removed and replugged the cable, removed the ethernet interface in the network sys prefs and then added it again. It continues to say: No connection: cable unplugged.

    Looking forward to the next steps...
  • xtech Level 1 Level 1
    Next step is to check your cable .. it could be a cross-over cable .. grab another one if you have one before we can point to a faulty or damaged Eth-jack.

    27 incher hey ... humm I see you did quite a few steps already which might have been a bit of an overkill to the system. How many items do you see in your network settings? ,,, ethernet, airport, b tooth, f wire, VPN, etc.
  • Martim Weinstein Level 1 Level 1
    Cables have been exchanged and retested on a different machine. No cables work on the iMac, all cables work on my MBP. No wall ethernet plug works on the iMac, all work on the MBP. I've tried and tested everything all the way back into the switch, mixing and matching to eliminate faults... trust me. It's either software or hardware on the iMac. All else is well.

    Right now all I have in the network panel is airport and ethernet. I've tried with only ethernet (doesn't work even after restarting). Airport alone or airport+ethernet works fine, as it goes to get it's connection on the airport side. Keep those ideas coming!
  • ChuckMoser Level 1 Level 1
    My mom had this same problem yesterday and it turned out one of the wires was bent in the ethernet port on the back of the iMac. Dumb, I know, but it's worth a shot.
  • Martim Weinstein Level 1 Level 1
    Thanks, but all wires are straight. I think I'll be taking it in to the shop, was trying to avoid that since it's an office computer.
  • panda_po Level 1 Level 1
    Hi,

    Have your problem been resolved? My kid has an iMac, same generation as yours, same 10.6.3, and same problem as yours. I checked the iMac's port and wires are straight. I suspect the fault is at iMac. I have no problem with my MBP, using the same ethernet cable, plugged to the same switch.
  • JFlynn12 Level 1 Level 1
    My 27" iMac started to experience similar issues. On reboot, the ethernet port dies and doesn't come back up.

    If I unplug and plug the ethernet cable in a couple of times, the port lights up and comes back on line.

    The simple explanation is a cable or port issue. But neither is the case. I have unplugged the cable on the iMac and Time Capsule sides -- same result. I have tried three different cables and different ports on the time capsule. Same result.

    Very strange problem. I was shocked that unplugging and plugging the cable back in could fix it.

    May be time to call Apple.
  • R Jones Level 1 Level 1
    Same problem here. Woke the iMac up yesterday afternoon and no internet. Get the "cable unplugged". Did all the troubleshooting/checking and can't get it working. However my Windows pc works fine on the same network/cable. Either jack is dead or software issue. Apple will be calling Monday. If it gets rssolved, I will post the solution that worked for me. If it doesn't get resolved I guess it'll go to the shop.
  • JFlynn12 Level 1 Level 1
    Took mine in today. I am documenting the issue on this thread:

    http://discussions.apple.com/thread.jspa?messageID=11782305
  • JFlynn12 Level 1 Level 1
  • Martim Weinstein Level 1 Level 1
    The logic board was replaced under warranty. Problem solved in a week Got offered a loaner unit while mine was fixing. All is well now.
Previous 1 2 Next