Previous 1 2 3 Next 40 Replies Latest reply: May 28, 2010 6:53 AM by internex
Gretchen Daniel1 Level 1 Level 1 (15 points)
I'm having a problem with the Arial font in Pages. My text was coming out squeezed together, so after trying to deal with the problem using Font Book to no avail, I deleted Arial and reinstalled a version from another Mac. That version seemed to fix the squished text problem, but now I am unable to select a block of text which is in Arial and either make it bold or italic. It's just unresponsive. I thought to try it in Text Edit, and the Arial font works fine there. Any ideas?

MacBook Air, iMac, Mac OS X (10.6.3)
  • Walt K Level 4 Level 4 (2,905 points)
    Did you reinstall the bold and italic versions also? Pages won't create fake bold and italics.

    Walt
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Thanks Walt - does this mean that the Bold button in the toolbar next to the Font won't work, even though it lists four options (Regular, Italic, Bold, Bold Italic)?

    I can get Italics to work if I access it through the Fonts menu instead of via the button. But bold doesn't seem to work either way, although it is checked in the Fonts menu (but the appearance of the font doesn't change).

    In Font Book I show that I have all 4 Arial fonts installed under the Arial group. In addition, I have Arial Black, Arial Hebrew, Arial Narrow, Arial Rounded MT Bold, and Arial Unicode MS, all with their own subgroups (bold, italic, etc.)

    I'm not sure I understand what "fake bold and italics" means...
  • Walt K Level 4 Level 4 (2,905 points)
    Open Font Book and highlight the problem fonts. Click on the gear wheel button up top and then Validate Fonts. See if that helps.

    A fake, or faux, font is what you get when an app creates bold or italic from the regular font when there is no bold or italic version installed. AppleWorks, for instance, does this, but not Pages.

    Walt
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    I did validate the fonts, both individually and as a group ("Arial"). Font Book did not indicate there was any problem with the fonts. I got green check marks on all of them. Arial's still behaving the same way in Pages. In fact, I selected some text and used the "italic" button on the toolbar. The text switched to italic, but then I was unable to get it to switch back to regular, either by using the style button or the Font menu. Very strange.
  • Level 8 Level 8 (41,780 points)
    Your problem isn't linked to the fact that Pages doesn't calculate "faux" styles. Arial exists in the four basic ones:
    regular, bold, italic, bolditalic.

    I'm thinking to two tracks.

    May you try to run Pages from an other user account to learn if the oddity is linked toi your original account or if it's a global one.

    If it is linked to your account, the first possible culprit is the Pages preferences file:
    <startupVolume>:Users:<yourAccount>:Library:Preferences:com.apple.iWork.Pages.pl ist
    Quit Pages,
    move the preferences file to the desktop
    restart Pages.
    If the problem is always here, the preferences file isn't the culprit. You may move it back to its original location (replacing the newly created one).

    In this case or if the problem is a global one, run a maintenance tool like Onyx to :
    repair permissions
    clean caches (mainly the fonts ones)

    Let us know the results.

    Yvan KOENIG (VALLAURIS, France) mercredi 28 avril 2010 09:06:12
  • robert_marc Level 1 Level 1 (0 points)
    Just upgraded my MacBook Pro to 10.6.3 and discovered that all my iWork '09 apps (Pages, Keynote, Numbers) have corrupted Arial fonts with squished display at large sizes. All Arial fonts worked fine minutes before the upgrade.

    Arial displays at a fixed word width no matter the font size - too small = weird spacing, too big = overlapping. Fontbook validation says there is a problem (yellow, not red) but offers no fix other than deactivation. Arial works great in Textedit, PShop and other apps I've tested.

    Clearly an iWork problem? Not sure, because PPT and Word now both lack Arial (normal font) when I'm sure I had it before. Sigh. This means nasty surprises come deadline time.

    I can deal with it, but it means replacing thousands of slides in hundreds of Keynote presentations. Not a pretty sight.

    A hint on how to fix corrupted font would be nice.
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Hi Robert - this was the same problem I was having - at large sizes the font looked squished; at small sizes it was spaced oddly. I fixed that problem by replacing my Arial font with one from another Mac I had, which fixed the squished font issue but now the select and bold options are unreliable and inconsistent from one word processing session to the next. Font Book doesn't indicate there's anything wrong with my Arial fonts, but clearly they're not behaving predictably. Unfortunately I have a template which I used to create hundreds of Pages docs and now I will have to change them all one at a time, unless I find a fix.
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    I should mention that I have not had time to try Yvan's solution but will try to do it tomorrow and report back on the results.

    thanks.
  • Walt K Level 4 Level 4 (2,905 points)
    Gretchen and Robert,

    There have been font problems after a Snow Leopard update that wasn't done using the Combo Updater. If your problems continue, try the combo updater available here:

    http://support.apple.com/kb/DL1017

    then repair permissions.

    Walt
  • Peggy Level 8 Level 8 (38,525 points)
    Welcome to Apple Discussions

    Did you apply the Mac OS 10.6.3 combo updater as Walt suggested. Even though you've already updated you can run the combo updater. Please run it & then post back. Don't forget to use Disk Utility to repair permissions afterward.

  • robert_marc Level 1 Level 1 (0 points)
    Thanks Gretchen

    I did the same and at least restored all my Keynotes and other files to usability (I think). But I have not verified that editing sessions are stable. Coming soon tho.

    Walt: Agree. Forewarned is forearmed. I always repair permissions pre/post, but that didn't prevent this. I had also upgraded a Mac Pro weeks age without any defects ... as far as I know. I'll follow this with interest however. I appreciate the collective wisdom.
  • Level 8 Level 8 (41,780 points)
    The first occurence was the update to 10.6.2 thru Software Update. It failed to install corrected fonts.
    I'm not sure that using Software Update to update incomplete 10.6.2 to 10.6.3 install the correct fonts.
    What is sure is that combo updater 10.6.3 does the complete task.

    Yvan KOENIG (VALLAURIS, France) jeudi 29 avril 2010 13:42:40
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    I ran the updated and repaired permissions last night. Tried to edit existing docs with the Arial font, and am still experiencing the inability/inconsistency of both the "bold" and "italic" buttons and Font Menu items. At least the font looks OK now, but I am unable to select text and make it bold or italic with any consistency. Actually, selecting text and clicking the "italic" button does change it to italics, but then I am unable to change it back. I have to close the document and not save changes in order to have it revert to regular Arial. Very frustrating.
  • fruhulda Level 6 Level 6 (15,120 points)
    Did you also delete the com.apple.iwork.pages.plist that Yvan mentioned in his post?
Previous 1 2 3 Next