5 Replies Latest reply: Jun 11, 2010 11:41 PM by staceyjax74
reidbrochill Level 1 Level 1 (0 points)
im at wit's end here. Essentially I got a 16GB nano today, and plugged it into my computer. I loaded it up with music and then tried to eject it. I receieved the "files in use" error message.

Undaunted, I figured I would restart my ipod and eject it then. Fail. Same error.

Slightly daunted, I pressed the "safely eject hardware" button. Fail. Same error.

More than a little perturbed I restarted my computer and tried again. Fail.

You see the pattern here. Help meeeeee! I have tried putting the ipod into disc mode, ive restored it to factory defaults, ive disable explorer.exe and tried, nothing is going my way. PLEASE HELP ME

Windows XP
  • reidbrochill Level 1 Level 1 (0 points)
    I take some of that back, i was unable to actually restore it. i got a message that said "cannot restore - files in use" or something to that effect
  • planb77 Level 7 Level 7 (32,300 points)
    Hello there,
    And welcome to Apple Discussions!

    Are you running any sort of antivirus software on your system? If so, make sure it is set not to scan your iPod from within the AV software's settings. How you do that depends on what kind of AV software you have installed and running. Or you can try and temporarily disable it and then try ejecting your iPod to see if that helps. If it does, you know where the problem lies.

  • reidbrochill Level 1 Level 1 (0 points)
    I just tried that. I have norton and I disabled everything and it still would not eject...

  • planb77 Level 7 Level 7 (32,300 points)
    Hmm. Do you have the *Enable Disk Use* option enabled from under your iPod's Summary tab in iTunes? If so, try disabling it to see if that does any good.

    Or if applicable, locate your iPod from within "My Computer" (or Computer), right->click on it and choose "Eject."

    Others have had luck by simply playing a song in their iTunes library for a little while and then reattempting to eject their iPod via iTunes.

  • staceyjax74 Level 1 Level 1 (0 points)
    Hi! I just got a new iPod Nano 5th Gen to replace my previous Nano (not sure what that one was but about 4 yrs old). Anyway, I was getting the same error message and after restarting PC, etc, I finally searched and found this disc. topic. I am happy to report that the last suggestion below about finding the device in My Computer and right clicking to eject worked! Thank you so much! I did see that the "enable disk use" in the summary tab is selected but grayed out so I was unable to deselect.

    My next question is, is there any way to fix this so that I don't have to go to My Computer to eject? If not, at least now I know that I can safely eject that way.