9 Replies Latest reply: May 19, 2011 12:13 PM by EB2600
fish2live Level 1 Level 1 (0 points)
It's a brand spanking new mac mini. I attached a 5 year old lcd monitor (always used before as VGA) using the mini-dvi to dvi adapter. I am using the monitor's dvi connector. The monitor resolution is 1280x1024.

The monitor does not work when using the mini-dvi to dvi adapter. If I remove the mini-dvi adapter and use a mini displayport to dvi adapter, it works just fine. I can keep both adapters plugged in and plug the cable into one or the other. It always works instantly when attached to the minidisplay port and doesn't work if I switch to the mini-dvi port.

I've tried the display with mini-dvi adapter on my macbook too. On the laptop, it acts like there are two screens attached, but there is no action on the external display.

As a further test, I attached the mac mini to the TV via a mini-dvi to hdmi adapter. The mini-dvi port on the mini works fine, as does the port on the laptop. The monitor works fine via minidisplay, but not mini-dvi.

Naturally, I concluded that the mini-dvi adapter was faulty. A second adapter came today, and nothing has changed. Could I have received two Apple mini-dvi adapters in a row with problems? Is there something about the monitor that doesn't like the mini-dvi port? It seems like it wouldn't like the minidisplay port either, but that one is fine.

macbook, mini, Mac OS X (10.6.3)
  • 1. Re: monitor won't work via mini-dvi to dvi adapter
    DaddyPaycheck Level 6 Level 6 (16,035 points)
    Have you tried a new cable? Is there a menu selection on the monitor itself that allows you to select which input it uses?
  • 2. Re: monitor won't work via mini-dvi to dvi adapter
    timisis Level 1 Level 1 (0 points)
    Well, I have two monitors and two computers, the mac mini server and the late 2009 4gb macbook pro, 13", and neither works with the mini-displayport to dvi, they work with the mini dvi to dvi. As the mac mini is not giving me an Apple experience at all hardware-wise, I am beginning to think quality on these adapters has become unpredictable!
  • 3. Re: monitor won't work via mini-dvi to dvi adapter
    Deebi Level 1 Level 1 (0 points)
    Hi, I'm using a Philips lcd monitor, and a mini-dvi to dvi adapter. The strange thing is, it used to work, up until a few days back, when all of a sudden it stopped working. Now when I plug in the adapter, the monitor just gives me a message - "no video input". I really don't know why, as I didn't change any configuration! It's all very strange, does anyone know why?!
  • 4. Re: monitor won't work via mini-dvi to dvi adapter
    Mel Beckman Level 1 Level 1 (35 points)
    I have the same adapter and it suddenly stopped working after I installed Apple's latest iMac display firmware update. My mac is an iMac 27" Intel Core i5. The monitor is an LG Flatron 24" Wide, and when it powers up it says "no video input" and goes into power-saving mode. No amount of replugging cables helps, but the monitor works fine on other computers.

    The Displays control panel just shows one monitor, and clicking Detect Displays does nothing.

    I suspect Apple's Display Update. Anybody have similar experience, or better yet, a fix?
  • 5. Re: monitor won't work via mini-dvi to dvi adapter
    Dah•veed Level 7 Level 7 (30,305 points)
    You must be confused, the original post is about Apple's mini-DVI to DVI adapter, as can be seen in the title. The Late '09 iMacs do not have a mini-DVI port. They only have bi-directional mini-DisplayPorts, which are not exactly the same is the uni-directional mini-DisplayPorts on the Mac minis.

    So rather than hijack this post about Mac minis, in the '09 Mac mini forum, and the Apple mini-DVI to DVI adapter, it would be better if you started you own request for help in the Intel iMac forum.
  • 6. Re: monitor won't work via mini-dvi to dvi adapter
    Mel Beckman Level 1 Level 1 (35 points)
    David.Austin.Allen wrote:
    You must be confused, the original post is about Apple's mini-DVI to DVI adapter,,, So rather than hijack this post about Mac minis, in the '09 Mac mini forum, and the Apple mini-DVI to DVI adapter, it would be better if you started you own request for help in the Intel iMac forum.


    You're right, I was confused -- I actually have the Apple mini-DisplayPort to DVI adapter. I hope you recognize that the fact that I was confused is inconsistent with the idea that I was trying to "hijack" this post. Just an honest mistake. I see that you have 8,489 posts. How did you post so much and still not develop common courtesy?
  • 7. Re: monitor won't work via mini-dvi to dvi adapter
    Dah•veed Level 7 Level 7 (30,305 points)
    I have much common courtesy. I was polite. I did not call you names or such. I explained the proper thing to do here in the Apple Discussions. Perhaps you mistake frankness for something that it is not because English is not my first language. I am sorry that I could not phrase it better for you. The number of posts does not represent much here in the Apple Discussions.

    In the Apple Discussions, when someone posts a comment that changes the subject, in this case to a different computer that cannot physically have the same issue, than that to which the forum is dedicated, that is a threadjack* according to Apple. You may check the Terms of Use if you like.

    *I use the wrong term.
  • 8. Re: monitor won't work via mini-dvi to dvi adapter
    Mel Beckman Level 1 Level 1 (35 points)
    Thanks for explaining that English is a second language for you. It's best to avoid inflammatory words like "hijack" in polite discussion. Even "threadjacking" is considered a deliberate, not accidental, act (http://tinyurl.com/threadjacking). I've read some of your other posts and you seem very knowledgeable and genuinely helpful; I believe you had no deliberate intent to insult, and I apologize for my overreaction.
  • 9. Re: monitor won't work via mini-dvi to dvi adapter
    EB2600 Level 1 Level 1 (0 points)

    • Went to Best Buy

    • Paid for a DYNEX Mini DisplayPort to HDMI Adapter ($25)

    • Came home and plugged in the adapter then the HDMI to DVI cable to the monitor. (Note: Monitor is a LG Flatron L22WTG) - DID NOT WORK

    • iMac knows monitor is plugged in and I can change the resolution on both monitors and mirror. (Note: Changed to every resolutions with/without mirror image.) - DID NOT WORK

    • Restarted computer - DID NOT WORK

    • Turned off/on LG monitor many times - DID NOT WORK

    • Unplugged/plugged back in many different ways - DID NOT WORK

    • Changed the HDMI to DVI cable with a better cable - DID NOT WORK

    • Installed BootCamp with Windows 7 - *BOTH WORK 100%*

    • Rebooted to OS X 10.6.7 (Snow Leopard) - DID NOT WORK

    • Installed Windows XP - *BOTH WORKED 100%*

    • Reinstalled OS X 10.6.4 (Snow Leopard) - *BOTH WORKED 100%*

    • Updated OS X from 10.6.4 to 10.6.7 - DID NOT WORK

     

    Seems to be a driver problem with the new update (10.6.7). I will not update again till drivers are fixed.