5 Replies Latest reply: Jul 17, 2010 4:15 AM by j.Dazz
~ flipd ~ Level 1 Level 1 (0 points)
- Hi -

- my iPhone 3GS is Stuck on this Recovery Mode Loop... - i Have Never JailBroken nor Unlocked my Device - It was Purchased Unlocked - but 2 Days ago Whilst Trying to Send an SMS the iPhone Crashed & Now Continually Enters Recovery Mode -

- When i Switch the Device on or Plug it in to a PC or my iMac via USB It Seems to Enter Recovery Mode (Connect to iTunes Icon) Somewhat Slower than Any Similarly Troubled Devices that i Have seen in Video on the Internet - it stays on the Apple Boot Logo for a Longer Time than Any of the Other Devices i Have Seen -




- i am Not Able to Restore the Device via iTunes... -

- i Attempt the Restore... - Go Through the Process of Verifying the iPhone with Apple - Download & Extract the Software - All Seems to Be Going Well... - then Repeatedly it Get's to a Stage Where it Says - Waiting for iPhone - then the iPhone Crashes - Returns to Apple Logo - & then the Recovery Mode Loop Continues -

- Following the iPhone Crash - iTunes Presents an Error Message (9) - Which i've Found to Mean There is Something Wrong with a USB Connection... - but i've Tried All the Suggestions from the Apple Support Page - http://support.apple.com/kb/TS127... -

- Switching USB Ports - Switching Cables - Even Tried it on a PC Running Windows 7 as Opposed to my iMac... -

- but No Matter Where i attempt the Restore... - Unknown Error (9) -



- i Tried Using - iRecovery - & was Able to Run that Application... - but it Did Not Fix this Problem -

- However - iRecovery - Did Give me the Following Feedback - Through the - TERMINAL - Application on my iMac... -

=======================================
::
:: iBoot for n88ap, Copyright 2009, Apple Inc.
::
:: BUILD_TAG: iBoot-636.66.33
::
:: BUILD_STYLE: RELEASE
::
:: USBSERIALNUMBER: CPID:8920 CPRV:14 CPFM:03 SCEP:03 BDID:00 ECID:000000F20A06E38D IBFL:01 SRNM:[879229FD3NR]
::
=======================================

[FTL:MSG] Apple NAND Driver (AND) RO
[NAND] Found Chip ID 0x3295DE987A on FMI0:CE0
[NAND] Found Chip ID 0x3295DE987A on FMI0:CE1
[NAND] Found Chip ID 0x3295DE987A on FMI:CE8
[NAND] Found Chip ID 0x3295DE987A on FMI1:CE9
[FTL:MSG] FIL_Init [OK]
[FTL:MSG] BUF_Init [OK]
[FTL:MSG] FPart Init [OK]
read new style signature 0x43313133 (line:375)
[FTL:MSG] VSVFL Register [OK]
[FTL:MSG] VFL Init [OK]
[FTL:MSG] VFL_Open [OK]
[FTL:MSG] YAFTL Register [OK]
yaFTL::YAFTL_Open(l:2630): CXT is not valid . Performing full NAND R/O restore ...
[FTL:MSG] FTL_Open [OK]
Boot Failure Count: 0 Panic Fail ount: 15
Entering recovery mode, starting command prompt
setenv auto-boot true
] saveenv
] /exit
Closing USB connection...


------------------------------------------------------
------------------------------------------------------

- Please Note that it says... -

CXT is not valid. Performing full NAND R/O restore

- & Also -

Boot Failure Count: 0 Panic Fail ount: 15







- i Live in the UK... - & the Nearest Apple Store is Quite a Distance Away from me - so this is a Real Nuisance - !


- Do the Errors Uncovered through - iRecovery - that i Detailed Make Any Sense to You... - What's a - Panic Fail - What's - CXT - (?)

- i'm Bamboozled - !



- It may be Related... - as Previously i Had an Issue Where my 3Gs Would Not Make Any Backups through iTunes... - It Would Sync OK - but the Backup Procedure Continually Failed... - & i Was Repeatedly Presented with an Error Message that Told me that... -


- iTunes could not backup the iphone because the iphone disconnected -

- i Was Unable to Find a Fix for this Problem... - but Eventually after a Couple of New Firmware Releases from Apple that i Installed via iTunes this Problem Seemed to Resolve Itself... - & i Was Able to Start Making Successful Backups -

- They Seem to Be Related in that the Errors both Suggest that there is a Problem in Establishing a Connection between the iPhone & iTunes -

- Any Help Would Be Appreciated... -

- Thanks -

D.

iMac, Mac OS X (10.5.8)
  • 1. Re: - Recovery Mode Loop... - iTunes Error (9) -
    Lawrence Finch Level 7 Level 7 (25,935 points)
    Either you have a bad cable, a bad dock connector, or the phone's memory is so corrupted that the restore fails. First delete the copy of tthe 3.1.3 ipsw file from your computer to force iTunes to download a new copy. Then put the phone in DFU mode, as described here: http://support.apple.com/kb/HT1808.
  • 2. Re: - Recovery Mode Loop... - iTunes Error (9) -
    ~ flipd ~ Level 1 Level 1 (0 points)
    - Hi -

    - Thanks for the Reply... -

    - How May i Go About Deleting the 3.1.3 ipsw File - (?)

    - Also... - How Could the Memory Have Been Corrupted - (?)

    D.

    Message was edited by: ~ flipd ~
  • 3. Re: - Recovery Mode Loop... - iTunes Error (9) -
    naovouporai Level 1 Level 1 (0 points)
    i have the exact same problem. While trying to restore iTunes says "waiting for iPhone" and i can see the blank progress bar on the iPhone and then the screen goes blank and goes to the apple logo again. Itunes says Error (9). I tried this many times, it's always the same thing, endless recovery mode loop.

    Why this happened? I saved a picture (20 megapixel) from mail to the camera roll, and when i tried to open it from the camera roll the iPhone froze. I had to reboot it, and then it just kept in an endless loop restarting over and over again with the apple logo.

    I tried restoring on 3 different computers, Windows 7, Xp, different iTunes accounts, different cables and usb ports.

    The problem must be on the iPhone side, as it reboot while iTunes is trying to restore it. iTunes says it's a problem with communication... yeah, if the iPhone shuts down on its own while restoring, i would say that's bad communication right there.

    No solution yet :/
  • 4. Re: - Recovery Mode Loop... - iTunes Error (9) -
    ~ flipd ~ Level 1 Level 1 (0 points)
    - i Booked an Appointment at the - Genius Bar... - Where it was Determined that my - iPhone 3Gs - In Fact had a Hard-Ware Fault -

    - the - 3Gs - was Subsequently Swapped for a New Handset With the Device Still Being Covered by It's Warranty -



    - It was assumed that All the Previous Problems i Experienced Before Entering the - Recovery Mode Loop... - i.e. - Unsuccessful Backups... - Unsuccessful Application Installations - & Frequent Crashes & Stability Issues Were Due to this Hard-Ware Issue -

    - the Hard-Ware Issue was Determined to Be a Problem With the Memory -

    - i Recommend Making an Appointment at the - Genius Bar... - though i Understand that this Can Be an Issue in itself as Certainly for me Being Resident in the UK there is a Lack of Apple Stores in Close Proximity & It Requires Something of a Day-Trip & Planning to Make an Appointment & Be Seen -

    - It Did However Seem to Resolve my Problem... - as the New Hand-Set Seems to Be Running Well so Far... - though i Have Experienced Some Problems with the Volume of the Device During Calls - though that may be a Fault Other than the - 3Gs - Itself - i.e a Bad Connection/Line -

    D.
  • 5. Re: - Recovery Mode Loop... - iTunes Error (9) -
    j.Dazz Level 1 Level 1 (0 points)
    Hey,
    I have the same problem on my 3G. Is there any other way to solve the problem without sending it to apple? because i dont have garanty anymore and i think the repair will be very expensive.