13 Replies Latest reply: Apr 23, 2012 7:30 AM by TheSadieGirl
pforkes Level 1 Level 1 (45 points)
When I try to delete an email, but pressing the trash icon, I get a dialog box saying:

"Unable to Move Message
The message could,not be moved to
the mailbox Trash."

How can I fix this?

iMac 24 inch, 2.8 GHz, Mac OS X (10.6.3), 4 Gb RAM
  • Like_a_vapor Level 1 Level 1 (0 points)
    I'm having the same problem.
  • Randy Brister Level 1 Level 1 (0 points)
    I'm having the exact same issue. Not only that, I have some messages that loaded that are from 2003!!
  • normabs Level 1 Level 1 (0 points)
    Did you ever find the answer to how to delete mail. I have the same problem. Apparently it's common. Would truly appreciate the fix if u got one. Thanks so much. Norm Stempler

    <Edited by Host>
  • pforkes Level 1 Level 1 (45 points)
    I have not found a solution.
  • Randy Brister Level 1 Level 1 (0 points)
    I actually put in a call to Apple, and although I got a very quick response, they were not able to help. They told me to contact my ISP. I have a pretty unique situation, as I have 2 accounts that are Pop accounts attached to my business website, along with a Mobile me account. I was able to delete emails from the mobile me account, but couldn't from my other accounts, so Apples response was that it wasn't the IPad, it was the way my email accounts are set up. However, instead of deleting the emails directly, I started moving them to the trash folder, and that works. Then, all of a sudden I could directly delete from one personal account, but not the other. They are both set up identically!!

    You might try disconnecting from your WiFi, then shutting down your IPad, restarting the IPad, and reconnecting to your WiFi. Then first try moving you emails manually into the trash, then try again to delete. It's got some bugs in it for certain, and I'm sure at some point there will be a fix. But, I do love the device.
  • pforkes Level 1 Level 1 (45 points)
    So you have a POP account and I have an IMAP account.

    It would suggest that it is nothing to do with it being a POP or an IMAP issue then.
  • joefor101 Level 1 Level 1 (0 points)
    OK -I figured it out with regard to an account that is not .mac. Here is the problem. This is for an IMAP account. Go to Settings, and click on Mail, Contacts, Calendars. Click on your non-mobile me account. At the bottom is an Advanced bar - click that. You will see a choice for Deleted Mailbox/Trash. Press that and you will see a Trash option at the top with a check next to it. That is the LOCAL trash folder. However, scroll down and your will find other and at the very bottom is another Trash folder. This Trash folder is part of the IMAP folders on your server. The one at the top tries to throw the deleted message in the local IPAD trash and that won't take it off the server. So, choose the Trash at the bottom (put a check mark there) and the problem is solved. The same issue exists for the Send mailbox. If you want your sent emails on all of your computers, make sure you choose the send mail box that is part of the server list.

    Joe
  • Randy Brister Level 1 Level 1 (0 points)
    Thank you, this works as well for a POP account, I apparently set one of my POP accounts this way but not the other. Hopefully someone from Apple support is reading these discussions and learning from their customers. The person I spoke to in support didn't have a clue.
  • michaelearl01 Level 1 Level 1 (0 points)
    Try this: go to the Mail settings in the settings app, choose the account, tap the "Advanced" tab, enter INBOX as the "IMAP Path Prefix"

    Worked for me
  • Otass Level 1 Level 1 (0 points)

    I don't have you no mobile me account???

  • Otass Level 1 Level 1 (0 points)

    Still my emails will not move to trash can ?

  • King_Penguin Level 10 Level 10 (113,900 points)

    Have you tried what I've suggested in your thread https://discussions.apple.com/thread/3343609?tstart=0 ?

  • TheSadieGirl Level 1 Level 1 (0 points)

    The IMAP Path Prefix - add - INBOX - suggested by "michaelear101" worked ......THANKS!!!!