6 Replies Latest reply: May 14, 2010 9:26 AM by a brody
cupidit Level 1 Level 1 (0 points)
When I try to open some files from my USB on my MacBook I get either:

'Unable to read file'
or
'The file may be read-only, or you may be trying to access a read-only location. Or, the server the document is stored on may not be responding.'

It's not read only and there is no server as it's on my USB and I've tried it on several different laptops. I read on another thread that it could be due to meta data not being transfered as I've been editing and accessing the docs on different versions of Word/Excel...

Can anyone help? I haven't backed up for months (doh!) and desperately need these files...

MacBook
  • kostby Level 4 Level 4 (2,790 points)
    Try dragging the files from your USB drive to your desktop and opening them from there.
    There may not be enough free space on the USB drive to save a copy of the original file.
    The file systems I'm familiar with need enough free space to save a complete copy of the file, then erase the original one you opened.
  • cupidit Level 1 Level 1 (0 points)
    Hello - thank you for your response.
    I've tried that... I also tried opening files from my Mac's Home drive. Neither work. I've tried in Windows and in Mac.
    Any suggestions?
  • cupidit Level 1 Level 1 (0 points)
    P.S. - From looking at other threads/discussions I have a feeling it could be to do with meta data (although I admit I'm not 100% sure of what that is), as I've been transferring and opening files between different versions of Office...
  • kostby Level 4 Level 4 (2,790 points)
    You didn't mention which version(s) of Word and Excel were used to create the documents, or which version(s) you're using/trying to use on your Mac.

    If it's (Windows) Office 2003 or earlier, Microsoft released a metadata management tool that might help you understand, and perhaps edit some of the metadata there now. The tool is available for (free in the US, at least) download here --> http://office.microsoft.com/en-us/help/HA011400341033.aspx

    It is possible that 'read-only' status was set in some version of the file (perhaps copied to a CD at some point?), and remains set to 'read-only'. One fix is to open it (in Windows) and clear the read-only status. Windows discussion here --> http://ask-leo.com/whycant_i_open_thisfile.html

    Another possibility is to try opening the documents with a different program (OpenOffice, iWorks Pages, iWorks Numbers) that can open and read many versions of Word and Excel files.

    In my experience with earlier versions of OpenOffice, I've had problems with formatting changing (e.g. text document fonts and formats) when I've opened documents with OpenOffice and then attempted to re-save them in Word (doc or docx) format. I don't recall using OpenOffice with Excel files. I'm not currently using OpenOffice, so I can't say whether the problem was fixed or not.
  • cupidit Level 1 Level 1 (0 points)
    The documents were created on a PC using Office 2000 (I think), but recently have been opened and updated using Office for Mac (2007 upwards).
    When I open one Excel document, the pop up says: The file may be read-only, or you may be trying to access a read-only location. Or, the server the document is stored on may not be responding.
    This file is stored on my USB... I've tried to open it from the desktop, my MacBook, a MacBook using an earlier version of Word, on Windows...
    Does that make sense?
  • a brody Level 9 Level 9 (64,770 points)
    If the drive you are trying to open from is read-only, that might explain the error. By default, Windows formatted NTFS hard drives are read only. FAT32 on the other hand is readable and writable by both Mac and PC. Flash drives also often have a small tab to make them read only. Make sure if reading from there it is unlocked first before plugging it in your Mac. Although you are saying you are having problems even after copying it to your Mac. When you copied it to your Mac, did you actually drag the file out onto the desktop of the Mac? Or did you create an alias to the file on your flash drive?
    When you remove the flash drive from your Mac, does the file you look at still exist on the desktop, and if you double click it, will it open?