13 Replies Latest reply: Jun 6, 2010 5:46 PM by Honey413
5480 Level 1 (65 points)
Safari freezes after some minutes working properly. Impossible to quit (spinning wheel) but force quit does work. Then it works again for some minutes before freezing again.

Listening radio in iTunes works fine so I guess the modem is not the problem.

Any advice?

Mac OS X (10.4.7), 20" iMac/2GHz Intel Core Duo/512 MB DDR2 SDRAM
  • Klaus1 Level 8 (47,770 points)
    As you say you are running 10.4.7, an ancient version of Tiger, what version of Safari are you using?
  • Carolyn Samit Level 10 (103,365 points)

    As Klaus1 mentions, your system software is outdated. Click your Apple Menu (top left in your screen) then click Software Updates. After the updates are installed you should be running v10.4.11 and Safari v4.0.5.

    Now repair disk permissions.

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and *restart your Mac.*

    Now try Safari.

  • ~Bee Level 7 (31,425 points)
    Carolyn --

    Maybe you could wait until the OP has answered Klaus' question before jumping in.
  • den.thed Level 7 (25,992 points)
    Hi 5480

    How many other Applications besides Safari are you running on 512MB of RAM and how full in your Hard Drive?

    Because to me that sounds more like you need more RAM and/or that your Hard Drive is almost full and doesn't have much room left for Virtual Memory.

    Please open your Activity Monitor and check your RAM usage and Disk Usage.

  • 5480 Level 1 (65 points)
    I am using MacBook 2GHz Intel, 2GB, OS 10.5.6. My hard drive is empty: no music, no movies, no pics, nocs, nothing, no other apps than the standard apple apps, zero.

    I replaced Safari by Firefox; now up and running without any problems.

    What might have been the problem?
  • ~Bee Level 7 (31,425 points)
    5480 --
    Thanks for clearing up which OS you're using. That helps a lot.
    It would be a good idea to update to 10.5.8 Combo, the last version of Leopard.
    Go here:

    Download and apply.
    Then repair permissions, OK?

    EDIT: You also might want to check your Font Book application for duplicate/conflicting fonts.
    Duplicates have little tiny dots to the right of the font name. Select dotted fonts and select "Resolve Duplicates."

    Message was edited by: ~Bee
  • The hatter Level 9 (60,930 points)
    Safari's web cache and others found in

    can grow beyond reason and even become corrupt, espeically the index for the cache and history.

    A nice feature would be option to empty history and cache on quit, and if you are on decent ADSL 1.5Mb or above, even disable disk caching (slower to find on your hard drive than download as needed, and Safari may try to load as much cache into RAM to improve performance and may even 'waste' previous RAM in some low memory situations).

    Firefox defaults to 50MB disk cache but you can limit that, or even empty on quit, as well as set to zero.

    Safari also copies bookmarks to that cache folder so they can be searched and indexed individually, and good idea to delete.

    Firefox with ability to sort, have tab window, control over flash and javascript per site.... I've been Mozilla user for last... decade!
  • Honey413 Level 1 (0 points)
    Wow !! How Rude! . . .
    It's my understanding that this is a public forum for EVERYONE to speak as they wish. Frankly, I appreciate Carolyn's input.
    Bee . . perhaps you should apologize to Carolyn and be thankful someone's willing to offer some help.
    Just as with Carolyn. . I'm also thankful you're taking time out to help those of us who are having problems.
    Let's all just remember why we're here . . and not attack each other.

  • Honey413 Level 1 (0 points)
    Request for help from anyone / everyone:
    I'm having a heck of a problem. Not a computer expert ( RN )
    When I open Foxfire I'm OK. When I open Safari it has the circling rainbow ball that just keeps circling. I can't use Safari at all. I can go to the Dock and
    use 'Force Quit' and Safari will close. This is also slowing everything else down.
    It appears it may be related to this line with tabs that won't go away.
    Since I can't get the ball to stop spinning or respond I can't go to Safari, close windows, etc.
    Today I did put Safari in the trash and downloaded a new version. I thought it may help. I've also screened everything for any virus/worm issues. No problem.

    I would appreciate any advice that anyone would like to give.
  • Carolyn Samit Level 10 (103,365 points)

    Your best bet here would be to start your own topic. This way it won't be at the bottom of another user's thread where few people can read it and reply.

    How to Post a Question

    Thank you for your input ...

  • ~Bee Level 7 (31,425 points)
    Honey --
    What happens if you open up Safari from your Applications folder?
    Do you still have the spinning ball?
  • Honey413 Level 1 (0 points)

    I tried opening Safari from my Applications and it was the same thing.

    HOWEVER, I think I found a fix !!

    I got an email from my cell phone company, there was a place on the email that
    said "Click here to make payment". It automatically opened up Safari and
    it was a normal Safari . . without the numerous tabs, spinning ball and frozen.

    I immediately took the opportunity to try this.
    clicked on "Safari" on the top of the screen, hit preferences.
    Then I looked at them all carefully in case there was something here.
    The second drop down box says: "New windows open with" and the box was
    filled in with Bookmarks. Now I don't recall ever setting, making any changes,etc
    I changed this box to 'Home Page"
    Then I tried opening up Safari from the Dock and it was back to normal!

    Thanks Everyone!
  • ~Bee Level 7 (31,425 points)
    Oh wow, Honey.
    Who knew???

    That sounds great.
    Glad you're sorted.