7 Replies Latest reply: Jan 20, 2012 1:10 PM by Web dude
Web dude Level 1 Level 1
expertise.iphone
iPhone
I can't access iTunes Store on G4 running OSX Leopard. It's telling me I need Safari 4.0.3 in order to have access to iTunes and I have the latest version.

G4 AGP (500Dual), PowerMac 8600, Mac OS X (10.5.7), Mac lover
Reply by Jolly Giant on May 10, 2010 8:43 AM Helpful
try if this helps:download iTunes from here http://www.apple.com/itunes/download/ and run the installer over your existing installation.you can also try to run the 10.5.8 combo updater (http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1058comboupdate .html) to see if that fixes your issue. be sure to repair permissions prior to and after installing the combo.when done, check software again for any updates offered.JGG
Reply by Limnos on May 10, 2010 8:50 AM Helpful
I don't have an iTunes store account but I know I can see the store and its various offerings with iTunes version 7.5 and no Safari running at all.

All replies