3 Replies Latest reply: May 12, 2010 11:48 AM by jf100
jf100 Level 1 Level 1 (0 points)
Hi,

I have a mac (osx 10.6.3) and a PC (Windows Vista) connected to my local home network. On the PC there are some shared folders. I can connect to the PC using the "connect to server" dialog and I can get all those PC folders mounted in my desktop (apparently in read/write mode). Dragging files from the PC to my mac works nicely but, surprisingly, there is no way to drag files from my mac to the pc.

When I drag a file from my mac to PC I'm always getting a dialog asking me to introduce my password to "allow Finder to make changes". I think it makes no sense because Finder should make no changes at all to copy a file to the PC and, on the other hand, I've read/write permissions on those files. After typing my password I get a second dialog: "One or more items can’t be copied to “Movies” because you don’t have permission to read them. Do you want to copy the items you are allowed to read?". Again, it makes no sense because I do have read/write permissions on those files. Unfortunately, any file is transferred after clicking "continue". This behavior is independent of file size, file type and permissions. No way to get any file transferred to the PC. What I'm doing wrong?

Thanks in advance for your help.

PowerBook G4 15'', Mac OS X (10.5)
  • 1. Re: Unable to copy files from mac to PC
    paullopez Level 1 Level 1 (15 points)
    Mac OS X will not write to Window NTFS filesystem (although it can read NTFS). Try a google search and you will find 3rd-party software which will allow you to write to NTFS from OS X.
  • 2. Re: Unable to copy files from mac to PC
    jf100 Level 1 Level 1 (0 points)
    Hi, paullopez.
    Thanks for your answer. Unfortunately, in my previous post, I forgot to comment that I had macFuse and ntfs-3g already installed in my mac. I wonder if the problem is related to the osx implementation of SAMBA. Or, alternatively, ntfs-3g may be not able to work with samba mounted volumes? I have very little experience in sharing files via SAMBA so any help is welcomed.
  • 3. Re: Unable to copy files from mac to PC
    jf100 Level 1 Level 1 (0 points)
    Finally I've solved the problem. It was an erroneous rule in the firewall included in my antivirus software. After reseting the rule everything worked as expected.