7 Replies Latest reply: May 10, 2010 7:50 AM by AdamTX
AdamTX Level 1 (0 points)
How do I delete an App from the Applications Tab within Itunes? I "deleted" the apps from my iphone, but they still show up in Itunes (unchecked). I want to completely remove them from Itunes, also.

I saw a post somewhere that said CNTL-RIGHT-CLICK would give you a context menu containing a delete option, but that was a Mac post and I'm running Windows (XP SP3, Itunes

I'm trying to do a little "housecleaning" before upgrading itunes to the latest release.


n/a - self built, Windows XP Pro
  • Chris CA Level 9 (78,235 points)
    CNTL-RIGHT-CLICK would give you a context menu containing a delete option

    *control click* as the same as a *right click*.
    that was a Mac post and I'm running Windows

    It works the same for Windows.
  • AdamTX Level 1 (0 points)
    Thanks for the reply, Chris, but on my PC right-click and cntl-click do NOT do the same thing. And it has been my experience within Windows, generally speaking, that those two actions do not normally produce the same results. CNTL-CLICK normally allows one to "add items" to a list of selected items; Whereas RIGHT-CLICK normally displays a context menu for the selected item(s).

    Regarding this specific situation: when I right-click on any App in the list shown within Itunes' Applications tab (regardless of whether I have one or multiple apps selected), nothing happens -- no context menu is displayed, the highlighted App(s) does not change ... nothing. If I CNTL-CLICK on apps in the list, the behavior is "standard windows" ... meaning this enables me to select multiple items (each of which is then highlighted in blue). If I CNTL-RIGHT-CLICK

    Oops ... accidentally posted prematurely! Meant to say ...
    If I CNTL-RIGHT-CLICK the behavior is the same as just RIGHT-CLICKing (without the CNTL) ... nothing happens.

    Bottom line is I still don't see any way to delete the Apps, and so any additional helpful advice would be most appreciated. FYI, in case it matters, when I look under the Main Menu EDIT option, all of the cut / copy / paste / delete / etc. items are disabled. Not sure if this is normal?


    Message was edited by: AdamTX
  • Ian Parkinson Level 6 (10,505 points)
    Select the App and press the delete key.
  • AdamTX Level 1 (0 points)
    I tried that, also (selecting the app, then pressing <del>) -- it doesn't do anything either. Just like the right-click -- the system doesn't do anything when I hit the <del> key. No response of any sort.

    Is it possible the Application "link" or "pointer" (or whatever is really behind each of these applications listed) is somehow broken, and rather than indicating that (the way Itunes does with "broken links" to a music file) it is just ignoring the keyboard input that it would normally process when that "broken" app is selected? I guess I should try deleting some of my other apps, to see if it will process the <del> request on any of the other apps (I've only tried to do this on the 2 or 3 that I really want to delete).
  • Chris CA Level 9 (78,235 points)
    My mistake.
    Right click an application should bring up the contextual menu with *Get info*, *Show in Windows Explorer* and Delete.
    Or select an application then iTunes menu Edit -> Delete.
  • AdamTX Level 1 (0 points)
    Thanks again Chris ... but I still cannot delete the app. I guess you are describing what I SHOULD see when I right click on a listed application. Unfortunately, I guess that is the root of my problem here -- I'm not seeing the options that I should when I right click on the app. Nor are those options available under Main Menu / Edit (delete, as well as the other choices, is disabled).
  • AdamTX Level 1 (0 points)
    Ahhhh. Problem solved: This entire time I have been looking at the Apps listed on the Applications Tab underneath DEvices/My iPhone -- not Library / Applications. Once I looked under Library / Applications I am able to delete the Apps as expected. (further more I can also delete one of the multiple ones listed, which solves my other current post, too).

    Thanks for your help.