7 Replies Latest reply: Aug 2, 2010 1:44 PM by talltenor
Eraser Buddy Level 1 Level 1 (0 points)
Mozilla's Plugin Check tells me to upgrade to QuickTime Plug-in 7.6.3 and links to the download page for QuickTime 7.6.6, which will not install because I already have QuickTime 10 installed. Is Plugin Check just out of date?

iMac, Mac OS X (10.6.3)
  • QuickTimeKirk Level 8 Level 8 (49,910 points)
    Snow Leopard users would find QuickTime Player in the Applications/Utilities folder. Do you have it there on your machine?
    If not, you can install QuickTime Player 7.6.3 from the Snow Leopard DVD.
    You can have both QuickTime X and QuickTime Player on Snow Leopard. Only QuickTime Player can be upgraded to Pro.
  • Charles Miles Level 1 Level 1 (0 points)
    I'm seeing this problem as well. Please note that what is being discussed is the versioin of the Quicktime plugin being reported by Firefox, not the Quicktime Player. I have Quicktime Player 7.6.6 installed, but Firefox continues to report an outdated version 7.6.3 version of the plugin.
  • the JoshMeister Level 1 Level 1 (5 points)
    It's a bug in Firefox. If you know you've installed QuickTime 7.6.6 and Firefox still thinks it's using plug-in version 7.6.3, Firefox is wrong. You can force it to display the correct version number by doing the following steps:

    1) Quit Firefox and all other open browsers.
    2) Move the QuickTime plugin from "/Library/Internet Plug-Ins/QuickTime Plugin.plugin" to someplace else temporarily (e.g. the desktop).
    3) Open Firefox. From the Tools menu, select Add-ons and click on the Plugins tab to verify that QuickTime doesn't show up in the list anymore. Then quit Firefox.
    4) Drag the QuickTime plugin back into "/Library/Internet Plug-Ins/" and then open Firefox again. Now when you verify the QuickTime plugin version in Firefox it should display the correct version number.

    I came up with this idea and tested it myself, and I can verify that it fixed the problem on my system. These steps should work on others' Macs as well.
  • Samboca Level 1 Level 1 (5 points)
    Works for me, thanks.

    Message was edited by: Samboca
  • The Stenz Level 1 Level 1 (0 points)
    Nice! That worked perfectly.
  • Jonathan Simon Level 1 Level 1 (0 points)
    Thanks, this worked for me also.
  • talltenor Level 1 Level 1 (10 points)
    I'm getting the same error message in Firefox (that I have QT 7.6.3 installed instead of 7.6.6). I have both QT 7.6.6 (1709) and QT 10.0 (114) installed.

    However, when I looked in Library | Internet Plug-Ins, there are no files located there at all.

    Hmm...

    Bill in CT