9 Replies Latest reply: May 28, 2010 5:00 AM by samoo74
samoo74 Level 1 Level 1 (0 points)
Help!.. Cannot see Apple TV in iTunes...

Have Dell PC running Windows 7 64-bit Prof. Hard-wired into d-link wireless router/modem.

Followed all Apple TV trouble shooting advice to no avail. As a final resort have even fully reinstalled PC operating system and still cannot see the device.

As a test Apple TV was found over the same wireless network by my laptop running XP - so I am sure it is not an Apple TV or network fault.

Has anyone got any adive pls?

Message was edited by: samoo74

Dell XPS 720, Windows 7, Apple TV
  • capaho Level 4 Level 4 (3,650 points)
    This seems to be a recurring issue in this forum with Windows 7 users. You might want to take a look at this:

    http://support.apple.com/kb/TS1392
  • Pete Kroner Level 1 Level 1 (10 points)
    It may ALSO be with Windows but I have not had ATV as a "Device" in iTunes for 4 months. My iPhone is seen in iTunes but ATV is missing from iTunes AND the iTunes preferences box for ATV.
    There is no reason for me to buy anything from iTunes since I don't think it will sync if I can't see it/.
    On the other hand all movies and trailers work very well on my ATV... go figure...
  • samoo74 Level 1 Level 1 (0 points)
    Thank you for the suggestion but it did not work. Any other ideas? Am I destined for this never to work?
  • Lampooner Level 1 Level 1 (20 points)
    had the same problem. The following was found in another thread on ATV disappearing from iTunes. It was posted by Cima113. I tried it. It brings ATV back in iTunes. Mine has been fine now for a month. I hope this helps someone.

    (Copied part starts here)

    It appears the best and only known solution for the AppleTV issue (windows) isn’t actually iTunes build 9.1.0.79. After the helpful postings to this thread it appears that the recent update of Bonjour is the actual culprit. Users experiencing this issue (Apple TV stopped appearing in iTunes 9.1.0.79) should try the following if your setup stopped working after iTunes 9.1.0.79.

    1) Uninstall Bonjour version 2 :
    Start> control panel>> uninstall a program>>> Select Bonjour>>>> Uninstall

    2) RESTART your computer!!!

    3) Open iTunes…
    You should get a message that Bonjour is missing… This is what you want.

    *While you have iTunes open make sure “Find AppleTV’s” is selected in iTunes, under:
    Edit> Preferences>> Apple TV tab>>> Check box bottom.
    (The above step must wait until after you install Bonjour 1.0.6, restart and open iTunes. This option is noy available while Bonjour is not installed)

    4) Close iTunes.

    5) Install Bonjour 1.0.6 (reputable download site: Cnet’s Download.com see below)
    http://download.cnet.com/Bonjour-for-Windows/3000-18507_4-93550.html

    6) RESTART your computer!!!!

    7) Open iTunes

    8) Start AppleTV and …
    Go to: Settings> Computers>> locate the “iTunes/Add library” option>>>
    Go to PC and Enter code in iTunes.

    Restarting after uninstall AND install are critical!!
  • samoo74 Level 1 Level 1 (0 points)
    Thank you for the suggestion - but again it did not work. Does anyone know if this is this a windows 7 issue?
  • Pete Kroner Level 1 Level 1 (10 points)
    My G5 Mac doesn't have bonjour... does it need it or is it only for Windows?
  • Juanito#1 Level 1 Level 1 (0 points)
    I cannot see ATV in my device list on iTunes. I have tried every imaginable means of support. The Apple Store says it's working fine and that it's my connection. However, I am successfully connected. Everything is updated. I can't get off hold when it comes to Apple Support line. Any suggestions before I bring it back for a refund?
  • Pete Kroner Level 1 Level 1 (10 points)
    Mines been like that for months... Western Digital has a similar device for under $100. without the wi-fi effect which you don;t have anyway. It should meet most of our needs.
  • samoo74 Level 1 Level 1 (0 points)
    Very bizarrely - i changed my d-link wireless router for a netgear one and apple tv is all now working perfectly even though i thoroughly checked my d-link settings..

    Message was edited by: samoo74

    Message was edited by: samoo74