6 Replies Latest reply: Jul 10, 2010 5:16 PM by 369-Open-the-Door
David Thorpe2 Level 3 Level 3 (635 points)
I am a long time Mac user and consider myself pretty competent. A friend who has been a convert for about 18 months called me for help. The 232GB hard drive on his iMac is showing, via disk utility, only 10GB free space. This is also what a 'get info' on the drive shows.

Using a couple of different sizing utilities, (Whatsize and a freeware one whose name escapes me) both report actual usage of 170GB. I ran verify disk through disk utility and sure enough it came up with a number of directory errors. Thinking this was the likely culprit I persuaded him to buy a spare HD and a copy of Disk Warrior. We cloned his drive to the new disk, booted from that and used Disk Warrior to repair the Mac HD (which it did successfully), and restarted from the newly repaired Mac HD.

Disk utility now reports no problems with the disk but we still have the exact same sizing issue. Get info and DU show 220GB used, Whatsize only 170GB. It's as if there's 50GB which the OS can't see somewhere. I checked to make sure there are no boot camp partitions set up or anything obvious like that, but now I'm stumped. I'm also embarrassed that he shelled out cash for the spare drive and Disk Warrior with no end result.

Does anyone have any ideas what could be going on here? Are there any terminal commands I could possibly get him to use to try and get to the bottom of this?

He's using 10.5 on an Intel iMac.

Many thanks

David

Mac Pro Dual 3GHz, 15GB RAM, ATI 3870, 30" ACD + 23" ACD, Mac OS X (10.6.3), MBP 17", iMac Intel 20", G4 Mini, MBA 1.8 (2nd Gen)
  • 1. Re: Missing Mac HD Space – Stumped
    Andreas  Level 4 Level 4 (1,510 points)
    As you mentioned cloning I wonder if a cloning app had been used before the unexplained growth. Let me have a wild guess. See


    My boot/source disk has GROWN ...or is FULL


    Andreas
  • 2. Re: Missing Mac HD Space – Stumped
    David Thorpe2 Level 3 Level 3 (635 points)
    Andreas, I'm not sure this is it. The space was lost before the downloading of CCC and the cloning of the drive.

    Is that the only circumstance that can cause the rogue volume or is it worth me checking that out in terminal anyway?

    Thanks.

    David
  • 3. Re: Missing Mac HD Space – Stumped
    Andreas  Level 4 Level 4 (1,510 points)
    Checking (either with Terminal or in the Finder) disturbs nothing and costs nothing but a few moments of time. Just make sure that your friend takes care to follow the instructions carefully.


    Andreas
  • 4. Re: Missing Mac HD Space – Stumped
    jsd2 Level 5 Level 5 (6,200 points)
    Sometimes permissions issues can cause such discrepancies. If you haven't already done so, try running WhatSize again after enabling "Measure as Administrator:"

    Whatsize>Tools Menu>Measure as Administrator
    enter your admin password when prompted.

    This gets around some potential permissions problems. For instance if your HD has other user accounts, their home folders will contain restricted folders (Documents, Movies, Music, .Trash, etc) which are not accessible to your user account. Some system-related folders also carry restricted privileges. These folders and their contents can't be accessed by Finder, by freeware programs such as OmniDiskSweeper, or by WhatSize when run with normal privileges, and the result will be that these folder sizes will be incorrectly reported as zero. This will make the summary disk space use incorrect as well.

    In order to reveal and correctly size all folders and files which are not accessible to your own user account, you need "root" privileges. For the freeware programs, this probably means enabling the "root" account, logging in as root, and running the program from there. WhatSize, however, has an added feature - an internal authentication tool, "Measure as Administrator", which enables you to run as root while logged into your regular admin account. The use of the word "Administrator" by WhatSize is a little confusing, because here it really refers to the root account ("System Administrator" is root's "long name"), and not to a regular user admin account.
  • 5. Re: Missing Mac HD Space – Stumped
    Dark_Angel Level 1 Level 1 (0 points)
    Two possibilities that I've personally run into, both caused exponential loss of space in my drive and only one really showed me what was going on by searching the drive with a file size program.

    First Aperture is a big one if you edit photos especially if you are creating a vault in your computer. I got around this by using a mirrored RAID drive set that servers as my storage vault so I manage files manually and load in only what I need while it also serves as a great location to store the finished photos too since it's mirrored. Also I've found that while managing about a half million photos annually does create a huge Aperture Library file which I purge out once a year just to keep everything under control I do this mainly when archiving the prior years work to storage drives.

    Second possible cause and this is a little more baffling and only recently have I run into this one...Adobe Flash. I would say what I experienced was a clear memory leak regarding Flash. I noticed it when using flash heavy websites and eventually I would start to get Flash crashing this seemed to coincide with sudden disk space warnings that seemed to crop up out of the blue. I have a program that checks available disk space and it would show I was down to around half a GB of available memory. I would usually finish what I was doing and close Safari and would in turn check my available disk space...I would also clear my cache but usually neither would render much more space; that is until I restarted then wham back to normal with a whole bunch of available drive space...hence my belief in a Adobe Flash memory leak.

    Hope this helps...

    Josh
  • 6. Re: Missing Mac HD Space – Stumped
    369-Open-the-Door Level 1 Level 1 (0 points)
    I am not familiar with Disk Warrior.
    But recently my MBP was recovered from unknown disk space issue.
    So I note my case for your reference.

    1. Cloned main HD to an empty external HD using Carbon Copy Cloner (CCC).
    http://www.versiontracker.com/dyn/moreinfo/macosx/13260
    2. Rebooted from the external HD and reformatted main HD.
    3. Cloned the external HD to blank main HD using CCC, and rebooted from main HD.
    -> All unknown space was not seen any more.

    In my case, I failed to make Bootcamp HD space and then unknown HD space appeared.
    I saw "other file space" or something on GrandPerspective.
    http://grandperspectiv.sourceforge.net/
    So I guessed that there is defected or uncompleted Bootcamp partition.

    It is worth to try because they were done by free software only.