3 Replies Latest reply: May 19, 2010 5:06 AM by Jolly Giant
SidRipper Level 1 Level 1
I got a new MacMini to replace and old Powerbook. I moved the library over, ran iTunes which updated it. It didnt require me to reeastablish the iphone/itunes link. I thought everything was good for a while.

I created a new playlist and set it to sync. It syncs the list name, but not the songs. Removed the playlist, synced, re-added with a different name, synced, same outcome.

Wiped out iTunes library on Mini, then it made me reestablish the iphone/itunes link, then synced, it removed all songs and playlists from iPhone as expected. Added all songs back to iTunes library and rebuilt newly named playlists. synced. All playlist names synced, but still i have two that wont sync the actual songs.

The playlists show songs in iTunes. Both are smart playlists which are set to sync one or two genres each. The lists that work are also smart lists.

How can I fix this?

My thoughts (please advise if it sounds right):
1) Restore iPhone to factory.
2) Wipe out iTunes library on Mini.
3) Import my songs to iTunes and recreate the playlists.
4) Setup iphone/itunes link and sync.

MacMini, Mac OS X (10.6.3), 4 GB Ram, 2.53Ghz, geForce 9400
  • Jolly Giant Level 7 Level 7
    SidRipper wrote:
    i have two that wont sync the actual songs.


    were those songs purchased from the iTMS ? if so, have you authorized iTunes on the mini to play this content ? do you use more than one iTMS account to purchase content ?

    also, check this KB article: iTunes 9: Smart Playlist not syncing as expected.

    JGG

  • SidRipper Level 1 Level 1
    Most of the songs were taken off my CD collection (2500 songs maybe), and another ~150 were bought from iTMS. A single account was used to purchase. And yes, the computer plays the songs just fine.

    I'll try the suggestions in the link when I get a chance later today.
  • Jolly Giant Level 7 Level 7
    also, check if you have read & write permissions for your iTunes music folder. in finder, right-click on it and +get info+. unlock the little padlock (you may have to enter your admin password) and change the permission settings. next, click on the little gear-shaped icon and +apply to enclosed items+ like so

    Screen shot 2010-05-12 at 6.46.11 PM

    you may also give everyone read & write access. if this doesn't help, try the same on your iTunes folder (not just the iTunes music folder).

    good luck !

    JGG