6 Replies Latest reply: Sep 9, 2010 12:35 PM by baludwiguwm
w7sg_599 Level 1 Level 1
With this turned off, I am getting new mail "sometimes". It doesn't pop up on my phone, but the Mail Icon will occasionally show new mail. Shouldn't this setting prevent new mail?

thanks

3G, iPhone OS 3.1.3
  • Allan Sampson Level 10 Level 10
    If you have Manually selected under Fetch at Settings > Mail, Contacts, Calendars > Fetch New Data, the email account (if the email account does not support Push access for received messages) should not be automatically checked for new messages in the background.

    With Manually selected, the email account or accounts should not be checked for new messages unless you launch the Mail application.
  • neuroanatomist Level 7 Level 7
    'Fetch New Data' cannot be set to OFF. Push can be set to off, but if you have Push off and still have an interval chosen for Fetch, mail will be checked. If you set Push to OFF and Fetch to Manual, that's as close to off as it gets. Mail will still be checked as soon as you tap the Mail app icon, though.
  • w7sg_599 Level 1 Level 1
    Very good, thanks.

    I now have Push to OFF & Fetch to Manually.
  • Rogerbed Level 1 Level 1
    mine still sends me mail even though I have it set to manual and not to push.
  • rebkev Level 1 Level 1
    same here - in settings, push is off, fetch is manual, but it still checks for email. I don't like that! i'm careful not to touch the mail icon.
  • baludwiguwm Level 1 Level 1
    My iPhone is doing the same thing. Push is set to "off", and Fetch is set to "manually". I even went into advanced settings and turned both of my email accounts to "manual" and I am still getting emails showing up from my Yahoo account.