14 Replies Latest reply: Jun 21, 2010 8:31 AM by SLFiore
Spectre289 Level 1 Level 1 (0 points)
I tried to update some of my apps through the app store on my iphone and now those apps are just stuck on "waiting", none of them are downloading even though they are connected to my wifi which is working fine. I then tried to update the apps through itunes on my computer instead which recognises the apps need updating but when I click the button to update them, nothing happens and itunes just stays on the same page. Any help appreciated.

Alienware m5550, Windows Vista
  • Spectre289 Level 1 Level 1 (0 points)
    It eventually timed out trying to download them but I still can't download updates for my apps neither through itunes or through the app store on my iphone. Any idea what's wrong?
  • Spectre289 Level 1 Level 1 (0 points)
    I still can't update my apps or download new ones through my iphone or through itunes, can I please get some help in resolving this?
  • Spectre289 Level 1 Level 1 (0 points)
    It's been 2 weeks now, can I please get some assistance with this? I still can't download or update any apps.
  • Spectre289 Level 1 Level 1 (0 points)
    Just run itunes diagnostics and it says the secure link to itunes store failed. I clicked help but the options it said to enable were already enabled:


    Microsoft Windows 7 x64 Business Edition (Build 7600)
    ALIENWARE m5500i-R3
    iTunes 9.1.1.12
    QuickTime 7.6.6
    FairPlay 1.7.16
    Apple Application Support 1.2.1
    iPod Updater Library 9.0d11
    CD Driver 2.2.0.1
    CD Driver DLL 2.1.1.1
    Apple Mobile Device 3.0.1.3
    Apple Mobile Device Driver 1.46.0.0
    Bonjour 2.0.1.2 (214.3)

    iTunes Serial Number 70F3CB12E5B1AAE6

    Current user is an administrator.
    The current local date and time is 2010-06-04 12:47:24.
    iTunes is not running in safe mode.

    Video Display Information

    ATI Technologies Inc., ATI MOBILITY RADEON X1400


    ** External Plug-ins Information **

    No external plug-ins installed.

    iPodService 9.1.1.12 is currently running.
    iTunesHelper 9.1.1.12 is currently running.
    Apple Mobile Device service 3.0.1.0 is currently running.

    ** Network Connectivity Tests **

    Network Adapter Information

    Adapter Name: {7B05906B-B6B9-4126-BE0A-9E01B3C8781D}
    Description: Intel(R) PRO/Wireless 3945ABG Network Connection
    IP Address: 192.168.1.2
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.1.1
    DHCP Enabled: Yes
    DHCP Server: 192.168.1.1
    Lease Obtained: Fri Jun 04 10:32:20 2010

    Lease Expires: Mon Jun 07 10:32:20 2010

    DNS Servers: 208.67.222.222
    208.67.222.222
    208.67.220.220

    Adapter Name: {51F103FB-129E-47CB-B7A0-AA44B7DBD740}
    Description: Realtek PCI GBE Family Controller
    IP Address: 0.0.0.0
    Subnet Mask: 0.0.0.0
    Default Gateway: 0.0.0.0
    DHCP Enabled: Yes
    DHCP Server:
    Lease Obtained: Thu Jan 01 00:00:00 1970

    Lease Expires: Thu Jan 01 00:00:00 1970

    DNS Servers:

    Active Connection: LAN Connection
    Connected: Yes
    Online: Yes
    Using Modem: No
    Using LAN: Yes
    Using Proxy: No
    SSL 3.0 Support: Enabled
    TLS 1.0 Support: Enabled

    Firewall Information

    Windows Firewall is off.

    Connection attempt to Apple website was successful.
    Connection attempt to iTunes Store was successful.
    Secure connection attempt to iTunes Store was unsuccessful.
    The network connection timed out.
    Secure connection attempt to iPhone activation server was successful.
    Last successful store access was 2010-06-04 12:41:02.
  • wjosten Level 10 Level 10 (93,750 points)
    Secure connection attempt to iTunes Store was unsuccessful.


    There's your answer. Something on your computer/router is blocking itunes attempts at a secure connection. The most common causes are: firewalls(router or computer), anti-virus software & anti-malware software. I see your windows built in firewall is off, any other firewalls? Any anti-virus, anti-malware? If so, try disabling all of that stuff. Firewall on your router? If so, turn it off.
  • ROGER B Level 1 Level 1 (0 points)
    im having a similar problem, thats just started today...

    Wifi is working fine, i can download apps from the app store no problem however if i try to update an app it just sits waiting, if i turn off wifi it starts to download no problem... it seems really strange this only happens when connected to wifi and im updating an app rather than downloading a new app

    i know it must be something blocking it on my router but don't know where to start

    thanks in advance for any help or suggestions
  • Spectre289 Level 1 Level 1 (0 points)
    I never used to have the problem on the router but i've just switched to a new router for other reasons and I can now download/update apps so I'm marking this as resolved, thanks for the help.
  • ROGER B Level 1 Level 1 (0 points)
    i changed the MTU on my router to 1500 and it solved my problem, app store now working fine !!
  • lgtgirl Level 1 Level 1 (0 points)
    What do I do about this. The apps I tried to update are still frozen in "waiting" mode. Yes, I was unsuccessful in logging into the apple secure line. I originally used the wrong one, but entered the correct one after two previous tries. Now what?
  • SLFiore Level 1 Level 1 (0 points)
    I'm suddenly having the same problem, whether iPhone is connected to my iMac or not. Last night I successfully downloaded 2 new apps; today it said I had 13 updates, so I clicked on Update All. Ten of them updated fine, but the other three have been stuck on Waiting for hours and hours. I have no idea what to do . . . nothing here has changed between last night and today.
  • Spectre289 Level 1 Level 1 (0 points)
    If it helps I believe my problem was that the MTU on my old router wasn't set to 1500.
  • SLFiore Level 1 Level 1 (0 points)
    Thanks for your advice. I haven't changed the settings on anything . . . why would the router suddenly begin causing problems?
  • Spectre289 Level 1 Level 1 (0 points)
    From the sounds of it, you have a different problem but do you have a spare router you can try to verify whether it is the router that's the problem?
  • SLFiore Level 1 Level 1 (0 points)
    No, afraid not. I have a youngish friend who occasionally comes over and helps me out . . . maybe he can figure this out. Thanks for your advice!