Previous 1 2 3 4 5 Next 63 Replies Latest reply: Jun 20, 2010 6:14 PM by medgirl Go to original post
  • Winston Churchill Level 10 Level 10
    Mac OS X
    I don't think there's much odd about that, that's the sort of IP an AE gives out, I assume your mac has an IP of 10.0.1.x


    Do you have an extreme or an express, do you have any other routers in use.

    Message was edited by: Winston Churchill
  • medgirl Level 1 Level 1
    @Winston Churchill It didn't seem weird to me either. All of the other devices are in the same range. The only thing I thought seemed odd is that it was the first IP address in the series, but maybe that's because it's on ethernet?
  • capaho Level 4 Level 4
    I also think it's very strange that iTunes can see the AppleTV well enough to stream to it, but not to sync to it.

    The most likely explanation is that the network connection is getting dropped intermittently, either because of a problem with the ATV, the router, or the computer. Or, as I mentioned previously, possibly because the ATV is rebooting itself randomly.

    One thing the second Apple rep said was that the IP address for my AppleTV was weird.

    Routers sold for home use most commonly use the range. Network addresses in the range are more commonly used for VPNs and NATs, but they are still valid addresses, so it shouldn't matter, as long as your computer and your ATV are on the same subnet.
  • medgirl Level 1 Level 1
    @capaho I believe that it could be related to the wireless connection dropping intermittently, although I have seen no signs of it otherwise. I do still think it's odd, though, that iTunes can find the AppleTV for streaming even after that happens, but not for syncing. Wireless connections drop all the time - it seems strange that the AppleTV does such a poor job of recovering from it, if that indeed is what's going on.

    I think the only way to really test it is going to be to connect my iMac via Ethernet as well, to remove the issue of wireless altogether. That is not trivial, however, because I don't have Ethernet running where I need it. I'm going to work on it and I'll let you all know if it worked.
  • capaho Level 4 Level 4
    I do still think it's odd, though, that iTunes can find the AppleTV for streaming even after that happens, but not for syncing.

    The processes of syncing and streaming are not entirely the same, so I suspect there is a key difference in the way iTunes handles the two that accounts for the discrepancy. There does seem to be ample evidence in this forum, however, that once the iTunes/ATV link has been interrupted due to a connectivity issue, iTunes can't recover it on its own.
  • medgirl Level 1 Level 1
    Well, here's my update. My iMac and AppleTV are now both connected to the network via Ethernet. I factory reset the router and set it up from scratch. I factory reset the AppleTV again for the gazillionth time and synced everything. Now an hour or so later iTunes again can not find the AppleTV and I can no longer sync. I have run out of ideas. I really don't think it's the network at this point, since Ethernet should rule out any wireless interference issues. Does anyone know how long it takes the AppleTV to go to sleep/standby? Maybe it can not find the network again after coming out of standby. Except that makes no sense either, since the AppleTV still connects to the internet just fine and can still have music streamed to the speakers.
  • capaho Level 4 Level 4
    This thread goes back a bit. Have you tried deleting the iTunes app and then re-installing it?

    If you have tried every possible solution, the only thing left is to take your ATV to an Apple store or call AppleCare (assuming it's still under warranty).
  • medgirl Level 1 Level 1
    @capaho - I have not tried deleting iTunes and reinstalling it. While I have done that on Windows, I'm actually not sure how to do that on a Mac, since it came with iTunes pre-installed. I'm not sure how to get rid of all the preference files, etc. Then would I reinstall it from the operating system CD?

    It is still under warranty, but not AppleCare. Unfortunately my nearest Apple Store is an hour to an hour and a half away. I have called twice about this already. They did help, but then because it's not under AppleCare they kept telling me they can't answer questions even though it's still under warranty. Which begs the question of how you can get service under the warranty if you can't call them about it. Anyway, at this point I think there is something wrong with the AppleTV itself. I think connectivity has been ruled out.
  • capaho Level 4 Level 4
    I'm actually not sure how to do that on a Mac, since it came with iTunes pre-installed.

    You only need to delete the application file. You don't need to delete the preferences, and absolutely DO NOT delete the library folder or files. You can download iTunes from Apple's web site and re-install it from that.

    It is still under warranty, but not AppleCare.

    If it's less than a year old, it's covered by the AppleCare protection plan regardless of where you bought it.
  • medgirl Level 1 Level 1

    Thanks for the information about reinstalling iTunes, although it does seem like deleting the preferences might be a good idea, since something seems to be amiss with how iTunes is handling devices? If there is some sort of corrupted file, I would need to figure out how to make sure that is out of there.

    I know it's under warranty, but since I don't have the AppleCare plan, they technically aren't supposed to take phone calls about it (although they actually have, but they keep telling me I need to buy AppleCare).

    I talked to them again on the phone about this today and they said to bring it in. I think I'm just going to bite the bullet and make the 60+ mile drive to an Apple Store. I have spent way too much time on this at this point.
  • capaho Level 4 Level 4 does seem like deleting the preferences might be a good idea....

    The user preferences aren't important with a problem like this in OS X. It would be related to the way the OS X security scheme authorizes applications for port access, if the problem is actually related to the iTunes app. It is only necessary to delete and then re-install the application file to clear it through the app authorization process cleanly.

    ...since I don't have the AppleCare plan....

    I'm still not clear on that one. All Apple products include a one-year AppleCare protection plan, with two additional years as an optional purchase.
  • medgirl Level 1 Level 1
    @capaho The basic warranty that comes with the AppleTV includes only 90 days of phone support (see Warranty section and one year of hardware support. The Catch-22 being how do you get the hardware support if you call in after the 90 days, since you must discuss it on the phone? I guess the answer would be to just bring it in to the store, but those of us who are geographically challenged can't do that easily.

    Maybe they realize that's a bit silly, because the first two reps I spoke to, while they both pointed out that they weren't supposed to be doing a support call, still did the support call. The third rep didn't mention it, but then, she just basically told me to take it to the store and did not do any troubleshooting steps.

    My update - I made the trek today to the Apple Store where they didn't even do any diagnostic testing. They just swapped it out. I am now in the process of syncing the new AppleTV. We'll see how that goes.
  • capaho Level 4 Level 4
    We'll see how that goes.

    Hopefully the replacement ATV will perform satisfactorily.
  • medgirl Level 1 Level 1
    Me too! I will report back here as to how it goes.
  • medgirl Level 1 Level 1
    I am so frustrated. The new AppleTV did not fix this. I am back to the beginning - I can not sync or stream with the AppleTV (though iTunes can play music through the speakers via the AppleTV).

    I am out of ideas and very sick of fighting with this. Here is what I have done so far:

    1. Factory restored AppleTV.
    2. Set up as a new iTunes library instead of complete restore.
    3. Rebooted AppleTV.
    4. Reset router.
    5. Set up AppleTV to connect to network via Ethernet instead of WiFi.
    6. Turned off/unplugged/removed the cordless phone that was near the iMac, thinking maybe there was some kind of wireless interference causing this.
    7. Set up iMac to connect to network via Ethernet instead of WiFi.
    8. Factory reset router and set up network all over again from scratch.
    9. Exchanged AppleTV for a new (well, refurbed) AppleTV.
    10. Uninstalled iTunes, including all preferences and everything except for content and reinstalled.

    After each step, factory restoring the AppleTV will let iTunes detect it once more for a period of time - sometimes hours, sometimes days. But eventually iTunes stops finding the AppleTV. I can't find rhyme or reason as to why this happens. As I said earlier in this thread, this happened to me a couple of months ago, but a single factory restore fixed it and it's been fine ever since until the past couple of weeks. I am out of ideas. I didn't really think it was a hardware problem with the AppleTV, but I exchanged it because I have no other way of reformatting/reinstalling an AppleTV. But of course, that didn't fix this either.