Previous 1 30 31 32 33 34 Next 1,032 Replies Latest reply: Feb 28, 2015 12:35 PM by V-l-a-d-i-m-i-r Go to original post
  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)

    Yes, this is why I have put big and fat warning! I repeat, only make a clean install of the Windows 8, please! Do NOT upgrade from Windows 7. Just put a clean Windows 8, and you will have no troubles at all.

    While I personally would recommend to pefrorm a new clean install as master solution, I have a useful information from one user (not verified by me). It gives you kind of a hope! Let me just paste it here:

     

    "This solution works and I have tried it myself though I am not a computer geek. Its really really simple!.

    Follow these steps after you have upgraded from Windows 7 to Windows 8 on a Mac book Pro. I had the same problem that tracket was not working.

     

    Step 1:Go to  Device Manager and on the two "Touchpad" entries with the bang on them, went to "Update Driver" -> "Browse My Computer" -> "Let me pick from a list..." and changed them both to USB Input Device. Reboot.

     

    Step 2: Unistall in case you install Trackpad ++ initially and it was not working. Similarly uninstall power plan assistant.

     

    Step 3: Reboot

     

    Step 4: Do a clean installation first of power plan assistant and then of trackpad ++ that you have saved as installer. So both these are installed now.

     

    Step 5:Go back to Device Manager, do an "Update Driver" again, let it search automatically, and one comes back as Apple Multitouch and the other as Apple Multitouch Mouse.

     

    Step 6:Rebooted again, trackpad working and shows up in Boot Camp control panel.

     

    TRUST ME IT WILL WORK !. I struggled y'day 10/27 after my Windows 8 upgrade and installation when trackpad was not working on my MBP. But the above suggestions helped and I am back working on Windows on my MBP."

     

    Again, the above are not my words... Please let me know if this helps... Could be useful for all the rest of the people who are not making a clean install of Windows 8 despite all of my warnings

  • rtheb Level 1 Level 1 (140 points)

    Vladimir

     

    DUH!

     

    Did not have to do any uninstall, reinstall, reboots, or anything other than go to the totally forgotten...

     

    Boot Camp control panel

     

    Went to the Trackpad Tab in the Boot Camp control panel

     

    Turned off Tap to Click and everything works!

     

    Thank You and Merry Christmas!

  • pratnala Level 1 Level 1 (5 points)

    To Vlad and the community here, I have a small piece of advice.

     

    I suggest that the "Test Mode" watermark not be removed in Windows 8. Messing with those DLLs is causing problems in Metro apps and MS-related software (for example, I couldn't activate Windows once even). I used to do a refresh every week almost because something or the other screwed up.

     

    What I did now:

     

    Since PPA automatically removes the watermark, I didn't install it (I don't need it anyways). To ensure Trackpad++ works, I ran this command in an elevated command prompt

     

    bcdedit /set TESTSIGNING ON

     

    and then installed Trackpad++. Life is good now. No problems with any Metro apps or anything whatsoever from the past 2 weeks. Also, I'm not using PPA now.

     

    I would love to hear your view on this Vlad. And, yeah all edge gestures (and other gestures) work fine for me. No problem on that end. Just one issue. Trackpad++ takes a long time to startup when the laptop is switched on. Can startup time be reduced in future versions?

     

    Happy New Year everyone!

  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)

    So, here are all the possible routes:

     

    1. Use Windows 7, any version, installing the Power Plan Assistant first:

    No even a single report regarding the Test Mode impact. No Test Mode message on the desktop. A perfect choice for those who do not need Windows 8.

     

    2. Use 32-bit Windows 8:

    No need to install the Power Plan Assistant, no Test Mode message on the desktop. Great choice for older machines with 2 GB of RAM. And still the solid option to consider for the newer machines! Zero issues, maximum compatibility. But only if you don't need much RAM.

     

    3. Use 64-bit Windows 8 NOT installing the Power Plan Assistant before the Trackpad++ (just enable TESTSIGNING):

    Test Mode message on desktop (esthetics issue!). Also, you will miss all the useful features of the Power Plan Assistant, which harnesses the keyboad lights, provides quick Wi-Fi/Bluetooth toggles, allows to turn off the display on demand, gives you the super quick shortcuts for sleep/reboot/shutdown, provides a nice, precise and informative battery tray icon alternative, and has many more features built-in, actually. In fact: the Power Plan Assistant has been re-worked for Windows 8 specifically and is definitely worth trying alone (even if you do not want to try the Trackpad++ itself). But other than the above, this is an option to consider, either.

     

    4. Use 64-bit Windows 8 installing the Power Plan Assistant before the Trackpad++:

    No Test Mode message on the desktop! All the features of the Power Plan Assistant and Trackpad++ are available together, improving your Boot Camp experince dramatically. And the setup is super-simple and fully automatic, even a complete newbie will be able to install both tools. Issues? If Windows 8 is already activated (like in my case) there are no issues I can notice. Also, no other users are reporting the problem on this topic. By the way: thank you very much prantala! Highly appreciate your feedback! I will definitely monitor the situation further. Summary: anyone shall try, test and make their own choice. It's good to have the choice, isn't it? Just let me put a small disclaimer (like in EULA): I really, sincerely, hope that both of the tools will serve You perfectly, however I neither provide any warranty/guarantee that they will work, nor I am responsible for any issues or damage caused to your OS, computer, car, house, planet Earth, etc.

     

    Cheers & Happy Near Everybody!!!

  • pratnala Level 1 Level 1 (5 points)

    I actually like PPA Vlad. But, as I described, removing Test Mode watermark is actually causing issues for me. I really love the WiFi/bluetooth toggle.

     

    P.S. Love that last sentence of yours

  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)

    @All:  Among the most popular new user questions comes the following one: "what is the difference between the Trackpad++ for Windows 7 and Windows 8". So I think I will provide the answer right here (again).

     

     

    Windows 8-only features:

     

    1.)   Horizontal 2-finger swipe to the left from outside the right edge (action: show/hide Charms Bar, the gesture shall be performed like this: http://powerplan7.com/OutsideSwipe.gif)

     

    2.)   Horizontal 2-finger swipe to the right from outside the left edge (action: show/hide Metro Switcher if at least 1 Metro app is running)

     

    3.)   Horizontal 4-finger swipe (action: show/hide Charms Bar)

     

    4.)   4-finger tap (action: show/hide Start screen)

     

    5.)   Option to "respect focus" for scrolling in an underlying window regardless of the focus state (it's always on in Windows 7, but made user-configurable in Windows 8, because of the incompatibility with certain Metro apps)

     

     

    Windows 7-only features:

     

    1.)   Vertical 4-finger swipe down (action: show all windows using the Windows Flip 3D feature)

     

    2.)   Horizontal 4-finger swipe (action: Alt-Tab alternative)

     

    Note: both features cannot be involved programmically in Windows 8 (one was thrown away by Microsoft, and the second, unlike in Windows 7 requires the signed code to be called from!)

     

     

    Common features (available both in Windows 7 and Windows 8):

     

    1.)   Horizontal 3-finger swipe (action: back / forward)

     

    2.)   Vertical 3-finger swipe (action: zoom in / zoom out)

     

    3.)   3-finger tap (action: middle mouse button)

     

    4.)   Vertical 4-finger swiping (action: minimize/restore open windows, although the method is different per OS, see above)

     

    5.)   Accelerated/natural scrolling model implemented

     

    6.)   Better pointer ballistics (i.e. how a pointer speed depends on a finger speed; six optimal presets built-in)

     

    7.)   Bug-free dragging with two fingers (both fingers allowed to move freely, unlike with Boot Camp-native driver), plus a unique option to increase the pointer speed while dragging

     

    8.)   User-customizable option to ignore accidental trackpad input when typing, option to eliminate accidental drag'n'drop actions (for tap-style dragging)

  • Marcelo NS Level 1 Level 1 (40 points)

    Hi Vladimir,

     

    I have installed the power plan assistant. However the test message does not dissapear. It still remained if I restarted, uninstalled the program, etc.

    It was still there after all reboots, uninstalls, reinstalls etc.

    I wiped my hard drive re-formatted and reinstalled windows. Installed the power plan again and the mark reapeared and i cannot get rid of it.

    MBA MID2011

    Windows 8 Pro

  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)

    @Marcelo NS: I believe this is because of the format / locale setting of your system. For the test, could you please try to set both to EN-US (English (United States)). This is very important preliminary step!!! (If you can't set to EN-US, at least please make sure that 'Locale' in Control Panel -> Region -> Administrative strictly matches 'Format').

     

    Then do not reinstall the Power Plan Assistant, please try the standalone fix first.

     

    To restate, normally the Power Plan Assistant shall handle this thing, but it seems like in rare cases you might need to apply the fix manually.

     

    Therefore, I have cooked a small standalone fix for the community.

     

    http://powerplan7.com/Windows_8_x64_Test_Mode_Remover.zip

    <This Link is a direct download>

     

    USAGE: unzip, run *as administrator*, wait until says done, reboot. By the way it's safe to apply the fix multiple times. For example, if the message persists after reboot, apply the fix again.

     

    USE IT ONLY *IF* AFTER INSTALLING BOTH THE POWER PLAN ASSISTANT AND TRACKPAD++ THE "TEST MODE" MESSAGE *IS* SHOWN. *DO NOT* USE IT OTHERWISE!

     

    <Edited By Host>

  • Marcelo NS Level 1 Level 1 (40 points)

    Hi Vladimir,

     

    I was able to set any setting I found to EN-US.

    restarted

    I've applied the patch as administratoe-rebooted 5 times.

    the Test Mode thing still there.

    Im gonna reinstall the app now.

  • Marcelo NS Level 1 Level 1 (40 points)

    Reinstalled and didnt helped. Any way to remove the PPA and this annoying TestMode msg without having to Format my bootcamp partition again ?

     

    I have also grabbed this from error log there is aproblem related to PPA:

     

    See the end of this message for details on invoking

    just-in-time (JIT) debugging instead of this dialog box.

     

     

    ************** Exception Text **************

    System.IO.IOException: The process cannot access the file 'C:\Program Files\Boot Camp\Bootcamp.exe' because it is being used by another process.

       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

       at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)

       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)

       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)

       at   .  (String  , String  )

       at   . (Object  , FormClosingEventArgs  )

       at System.Windows.Forms.Form.WmClose(Message& m)

       at System.Windows.Forms.Form.WndProc(Message& m)

       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

     

     

     

     

    ************** Loaded Assemblies **************

    mscorlib

        Assembly Version: 4.0.0.0

        Win32 Version: 4.0.30319.17929 built by: FX45RTMREL

        CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

    ----------------------------------------

    PowerPlanAssistant

        Assembly Version: 3.0.2.0

        Win32 Version: 3.0.2.0

        CodeBase: file:///C:/Program%20Files/PowerPlanAssistant/PowerPlanAssistant.exe

    ----------------------------------------

    System.Windows.Forms

        Assembly Version: 4.0.0.0

        Win32 Version: 4.0.30319.17929 built by: FX45RTMREL

        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4. 0.0.0__b77a5c561934e089/System.Windows.Forms.dll

    ----------------------------------------

    System.Drawing

        Assembly Version: 4.0.0.0

        Win32 Version: 4.0.30319.17929 built by: FX45RTMREL

        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0_ _b03f5f7f11d50a3a/System.Drawing.dll

    ----------------------------------------

    System

        Assembly Version: 4.0.0.0

        Win32 Version: 4.0.30319.17929 built by: FX45RTMREL

        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c5 61934e089/System.dll

    ----------------------------------------

    ModifyRegistry

        Assembly Version: 1.0.3516.24642

        Win32 Version: 1.0.3516.24642

        CodeBase: file:///C:/Program%20Files/PowerPlanAssistant/ModifyRegistry.DLL

    ----------------------------------------

    ComponentFactory.Krypton.Toolkit

        Assembly Version: 4.1.1.0

        Win32 Version: 4.1.1.0

        CodeBase: file:///C:/Program%20Files/PowerPlanAssistant/ComponentFactory.Krypton.Toolkit. DLL

    ----------------------------------------

    HardwareHelperLib

        Assembly Version: 1.0.0.0

        Win32 Version: 1.0.0.0

        CodeBase: file:///C:/Program%20Files/PowerPlanAssistant/HardwareHelperLib.DLL

    ----------------------------------------

    state

        Assembly Version: 1.0.3543.17274

        Win32 Version: 1.0.3543.17274

        CodeBase: file:///C:/Program%20Files/PowerPlanAssistant/state.DLL

    ----------------------------------------

     

     

    ************** JIT Debugging **************

    To enable just-in-time (JIT) debugging, the .config file for this

    application or computer (machine.config) must have the

    jitDebugging value set in the system.windows.forms section.

    The application must also be compiled with debugging

    enabled.

     

     

    For example:

     

     

    <configuration>

        <system.windows.forms jitDebugging="true" />

    </configuration>

     

     

    When JIT debugging is enabled, any unhandled exception

    will be sent to the JIT debugger registered on the computer

    rather than be handled by this dialog box.

  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)

    @Marcelo NS: Please open terminal (cmd.exe) as administrator

    and execute the following command:

     

    bcdedit -set TESTSIGNING OFF

     

    Then reboot, and there will be no test mode thing anymore. (But, sadly, no ability to use the Trackpad++! Please refer my post above on this page for all the possible "routes" to Trackpad++).

     

    Another idea might be to run the fix directly from the elevated cmd.exe, to see its output. It shall write why it cannot be applied.

     

    I can ensure you, for many thousands of people the fix works fine (or, actually, it is not even required, because PPA's internal fix - which is the same code - handles this thing). So, this is truly a mistery. This is not your day   Sorry...

  • Marcelo NS Level 1 Level 1 (40 points)

    Thank you for your replay. Can this issue be related with my Win8 license? I have purchased the license in the Netherlands and it is an upgrade licesne (i have however made clean install).

    Can you provide me the fix? I am certainly able to run the code in the terminal console.

  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)

    @Marcelo NS: Not really sure... The fix is the one I posted above: http://powerplan7.com/Windows_8_x64_Test_Mode_Remover.zip

    <This Link is a direct download>

     

    Just run it from terminal as admininstrator. Please let me know what is the output in terminal.

     

    <Edited By Host>

  • Marcelo NS Level 1 Level 1 (40 points)

    I have downloaded the program. There is no output the program seems to work, te terminal shows up just a fraction of second.

    O wait... sorry i missunderstood. I ran the program with double click on the icon as administrator. How do i run it from the console?

  • Marcelo NS Level 1 Level 1 (40 points)

    Hi Vladimir,

     

    thank you for your patience. I will certainly buy you a beer . Running the exe file from the cmd prompt as administrator finnaly did the trick.

    The output was somehtink like Ok, Ok, done, Ok. please reboot...

    I am enjoying PPA and trackpad ++ drivers now.

Previous 1 30 31 32 33 34 Next