Previous 1 31 32 33 34 35 Next 1,030 Replies Latest reply: Feb 28, 2015 12:35 PM by V-l-a-d-i-m-i-r Go to original post
  • rtheb Level 1 Level 1



    The Nag Test Mode Remover worked like a charm so that issue is resolved.


    The Control Module finally ran and appeared in the task bar.


    Unfortunately after closing it the Trackpad++ Control Panel does not appear on the taskbar anymore after rebooting.


    All the figure gestures are working as well so I can live with the Trackpad++ Control Panel not displaying except I have the inverted two finger scroll and I would like to disable that feature.


    Any help with this issue will be appreciated.


    Which Trackpad++ Control Module should I be using as I have the following programs in the Trackpad++ directory:


    Trackpad++ Control Module.exe  date 10/8/2012 File Version 1.00




    Trackpad++ Control Module for Windows 8.exe date 10/25/2012 File Version 2.3.4


    or should they all be in the directory and running?


    Also should the Apple Boot Camp Manager be running or not?


    I upgraded from Windows 7 and I am sure that I probably have left over programs in the Trackpad++ directory as I did not uninstall Trackpad++ before upgrading.


    When I installed the newest Trackpad++ upgrades they were installed in the same directory by default.


    Thanks again for all your help and we almost have Trackpad++ functioning perfectly.

  • rtheb Level 1 Level 1



    I solved the issue by closing PowerPlanAssistant and Trackpad++ in the task manager.


    I then renamed the existing Directories to:








    Next I reinstalled PowerPlanAssistant using Power_Plan_Assistant_30b_Setup_12202012.exe




    reinstalled Trackpad++ using Trackpad_Plus_Plus_Driver_Control_Module_23d_Setup_12202012.exe




    Now everything is working perfectly


    I did NOT do an uninstall!


    BTW The Nag Test Mode Remover still functions and I did not have to reinstall it.


    Thanks again for your efforts they are much appreciated!


    All the above confirms that the Windows 7 x64 to Windows 8 x64 upgrade route does leave conflicting remnants behind,


    Have a very Happy New Year!

  • floriko Level 1 Level 1

    Just got Trackpad++ and first results look really promising it's much better than the bootcamp driver for sure. The setup routine is a little bit weird, first I did not like installing another program to get the feature I really wanted but I ended up liking the powerplan tool too

  • der-kai Level 1 Level 1

    With Trackpad++ it is really possible to enjoy Windows 8 on a MacBook..

    I am really happy to have a OS for working and another one to feel home ( you can guess which on is which )

    I hope some people donate too, so the development wont stop.

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @All: Thanks for the feedback!


    Important information for Windows 8 users: some Windows updates could occasionally restore the Test Mode message on the desktop. Which had in fact NEVER happened to Windows 7! How I know it? Well, this has just happened to me! But stay calm To remove the Test Mode string, use the super-simple fix posted above in this topic. It's perfectly safe to apply the fix multiple times (for example, in certain cases you might need to apply it again after the reboot). Note: make sure your locale setting and format setting (both from the Windows regional settings) are identical before running the fix. Even better, set both to "English (United States)", and the fix will work, guaranteed. And, of course, you shall know that the whole fix thing is just the esthetics thing, so it's not mandatory to remove that Test Mode message from bottom right corner of the desktop. The choice is up to You.


    Happy New Year!

  • y.orim Level 1 Level 1

    Super! Fix just worked for me! THX!!! I love T++!!!! 

  • Marcelo NS Level 1 Level 1

    Hi Vladimir,


    I am using trackpad++ in windows 8 and i am loving it. Are you taking any user suggestions/request into account?. If so I would like to ask you:


    1.- Can we expect a pinch to zoom gesture?

    2.- If the anser is affirmative, 3 finger drag is also doable?





  • V-l-a-d-i-m-i-r Level 1 Level 1

    @Marcelo NS: at this moment, it is very difficult to implement the pinch-to-zoom gesture. Basically, when this exact gesture is simulated, the trackpad hardware is not sending the correct finger data for the second finger. Only Apple knows why is it and how to workaround, but they will never tell (of course).


    3-finger drag is possible (although not available yet). But you have to know, this will disable 3-finger zoom, 3-finger back/forward, and 3-finger tap (middle mouse button).

  • Scorpido Level 1 Level 1

    Thank you for your hard work on this driver. It works like a charm except for one issue on my Win8 x64 Bootcamp. OK, I installed Win8 x64 with Bootcamp 4.0 -can't really remember the version details but I'm pretty sure it is the latest Bootcamp that Apple provided.- And I installed the Bootcamp drivers also, when I turn my Win8 on, it was like no issue except multitouch gestures on trackpad. So after a little search on web, I found this and I did install it following the steps. I am pretty sure I did everything well but it didn't work at first step. So I kept looking and thought it may be an issue from .NET Framework so I installed 3.5 version.-4 and 4.5 versions are included in Win8 already.- This time I could open and use the default gestures, but all the time I start up the Windows, it came up with a Microsoft .NET Framework error that says "System.NullReferenceException: Object reference not set to an instance of an object" and detailed as


       at  . (Object  , EventArgs  )

       at System.Windows.Forms.Form.OnLoad(EventArgs e)

       at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

       at System.Windows.Forms.Control.CreateControl()

       at System.Windows.Forms.Control.WmShowWindow(Message& m)

       at System.Windows.Forms.Control.WndProc(Message& m)

       at  .WndProc(Message&  )

       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    And when I click "continue", I can use gestures with no problem except I can NOT open the Adjust Settings or Control Module from either the file or the right click on the icon at bottom right. I don't know what can I do for this and I searched a lot but couldn't find any fix.



    Also, can we expect a Magic Mouse gesture driver too?


    Thanks again.

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @Scorpido: Really strange! I don't know what could be causing this. I recommend to exit the Trackpad++ icon from system tray (if you cannot do this, kill it from Task Manager) and simply re-install the Trackpad++, or, better, both the Power Plan Assistant and Trackpad++. By the way, it's really important to exit the application from tray before re-installing it. The new installation will not be correct otherwise!


    Magic mouse - sorry, but there are no plans to support it yet.

  • Morealth Level 1 Level 1

    Hi Vlad


    I've just installed trackpad++ on a fresh install of windows 8 64bit pro on a 15" retina, the steps were:

    run usual boot camp setup

    install boot camp software in win 8

    update win 8

    install powerplan

    install trackpad++


    It works great apart from one thing, the three finger horizontal gesture doesn't seem to work, i've tried in chrome and IE so far....


    All other gestures (scroll, zoom, metro interface etc) work fine, any ideas?

  • Marcelo NS Level 1 Level 1



    Thank you for your replay. I would love to have the option of trying the 3 fingers drag, in fact i never use the 3 finger zoom (i use ctrl-two finger) or other 3 finger gestures.

  • Scorpido Level 1 Level 1

    This is really strange. I uninstalled both of them after exiting both. Then I downloaded the setup files again to have a clean setup. But after I installed PowerPlan, it came up with an error saying:

    "Internal error has occured. Please notify about this issue!


    System.ArgumentException: Parameter 'null' is not valid for 'stream'.

    at System.Drawing.Icon..ctor(stream stream, int32 width, int32 height)

    at . ( , IntPtr L)

    Parameter 'null' is not valid for 'stream'."


    I don't know what should I do now but I think I'll try to install TrackPad++ once more.


    OK, when I press "OK" for that error up above, another issue has came up.

    "Internal error has occured. Please notift about this issue!


    System.NullReferenceException: Object reference not set to an instance of an object.

    at .*(Object , EventArgs L)


    Object reference not set to an instance of an object."

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @Morealth: some of the vendor-specific mouse software is known to cause this. Please try to remove it and simply use generic Windows driver for your mouse. The back/forward gesture shall become available again.


    @Scorpido: super-strange indeed! If you are familiar with regedit.exe, please try to remove with regedit.exe the "hkey_local_machine/software/powerplanassisstant" from registry. Then reinstall the Power Plan Assistant. Also, make sure to really kill the process before reinstalling! Please check with the Task Manager.

  • FrederiQ Level 1 Level 1

    I'm following this project since 2010 and I've to say, it's getting better and better! Recently I've installed Windows 8 and I'm just loving all of the new gestures! Everything works perfectly. Yet I'd put one minor thing in the queue: could three-finger zoom be made continuous? So that releasing fingers won't be required to change the zoom again. Thank you Vladimir for listening! All the best to you and your  drivers in 2013!! 




Previous 1 31 32 33 34 35 Next