Previous 1 41 42 43 44 45 Next 1,030 Replies Latest reply: Feb 28, 2015 12:35 PM by V-l-a-d-i-m-i-r Go to original post
  • hbeardave Level 1 Level 1

    I'm able to two-finger scroll in Firefox and IE,

    ...but in Chrome, scrolling doesn't work UNLESS the mouse pointer over the scroll bar area.

    Any thoughts?

    MacBook Air (Fall 2011)

    Windows 8

    Trackpad++ 2.4a-x64

    Boot Camp 5.0

    Chrome 26.0.1410.64 m

    Also, are there certain settings in Boot Camp that should be enabled/disabled for the trackpad?

    (it's not clear how that and Trackpad++ interact/override.)

    Thanks for all your hard work on this (donations already sent!)

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @hbeardave: Thanks for reporting.

    Trackpad++ is the real, advanced, multitouch device driver, not just the user mode enhancement! That means, architecturally the Trackpad++ just sends the scrolling commands from the kernel space to operating system (user space). The driver cannot even know to what user mode application is the input being sent. So, logically, if the scrolling works in other apps, you have a problem with Chrome. Maybe you have some unwanted Chrome extension activated. For example, some of the mouse drivers (e.g. from Logitech and Microsoft) are silently installing their own smooth scrolling plugins in Chrome and other browsers.


    Another idea: maybe you can try to turn on (or off) the 'Respect Focus' flag in the Trackpad++ Control Module? In general this shall affect only the Metro apps, but still, I suggest to try.


    Regarding your second question. With Trackpad++, you can simply forget about the Boot Camp Control Panel - it's poor and when the Trackpad++ is loaded its settings are ignored anyways. Just use the Trackpad++ Control Module, where all the possible multitouch and trackpad-as-mouse settings (including the scrolling speed, acceleration and direction) are put together, in a single place.


    Finally: are the Trackpad++ multi-touch gestures working? I mean, for 3 and 4 fingers. If they do, then the Trackpad++ was definitely installed correctly.




  • hbeardave Level 1 Level 1

    You nailed it, Vladimir.

    I had a Chrome extension: Chromium Wheel Smooth Scroller that messed up the functionality.

    It scrolls now (but in a bit more jerky way than smooth continuous scroll in Firefox).


    Chrome acts more like it's receiving scrolling info as line-up / line-down commands...perhaps that's a limitation of Chrome.


    Yes, the multitouch works fine (Love the 3-finger drag for pulling a tab off the browser into an independent window). And Ctrl-Scroll for zooming works is fine as a substitute for pinch.


    Thanks for your continued work on this project.

  • hbeardave Level 1 Level 1

    Oh, wow, just found another setting in Chrome.

    If you go to chrome://flags/ there is a setting to Enable Smooth Scrolling.

    Now we're in business!



  • distant0 Level 1 Level 1

    I'm on Mid 2009 Macbook Pro, with Bootcamp 4.0 and Windows 7 64bit. I


    've followed all the instructions, installed {owerplan and then trackpad++. However, I couldn't get the trackpad++ module to load as it keeps saying the trackpad driver couldnot be load. I've tried to re-install Trackpad++ several times and it still doesn't fix this problem. Need HELP!!!

  • Myndranius Level 1 Level 1

    Hi Vladimir,


    Been using your trackpad for awhile now. I've come across a small issue however.


    Been running Windows 8 and bootcamp 4 on a MPB (early 2012) for several months, and no issues.


    Today, I upgraded to bootcamp 5, and then reinstalled both the powerplan assistant and trackpad++. Since then, I've found that trackpad++ is using a consistent 25% CPU, and it causes the fan to spin up. I really can't figure out why trackpad++ is using so much CPU, but I can only assume it has to do with bootcamp 5.


    Any advice?

  • ExoMaker Level 1 Level 1

    I don't think it is related to Trackpad ++. I upgraded to bootcamp 5 and my fan went crazy. It would not stop running. My battery life was horrible, all before I put trackpad on. And you cannot roll back to version 4. I ended up reinstalling windows and going back to bootcamp 4

  • Myndranius Level 1 Level 1

    While I appreciate your reply, and the fact that boot camp 5 is likely involved in the issue, I feel the need to point out that it is trackpad++, not boot camp, which is running at a constant 25% CPU utilization, which - with a quad core processor - represents maximum utilization of the core it is running on. Moreover, ending the trackpad++ process results in normal computer behaviour, no abnormal CPU utilization, no excessive fan speeds and no system overheating.


    This is a trackpad++ issue.


    If there's more information I can provide to help resolve the issue, I'd be more than happy to oblige.

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @distant0: Trackpad++ is compatible with Mid-2009 (and all of the later, including Retina) Boot Camped Macbook Pro models. And in fact, in had literally been developed on the Mid-2009 model - so I cannot be more sure about the compatibility. Is the Power Plan Assistant capable of disabling the keyboard backlight? If no, you do not have my tools installed correctly, so please re-run the installer of the Power Plan Assistant first (and reboot), then re-run installer of the Trackpad++. Please always exit the application from tray icon before re-installing, or it would not be the correct re-installation!


    @Myndranius: The latest Trackpad++ is fully compatible with Boot Camp 5.0 and Windows 8. The Trackpad++ shall never use more then literally 0% of CPU (as displayed by Windows Task Manager). Please try the following: exit the Trackpad++ Control Module application from the tray icon ('++' icon) and re-run the installer using the very latest build.

  • Myndranius Level 1 Level 1

    It seems the trick is ensuring that you close trackpad before attempting to install a newer version. In retrospect, this makes sense, though I initially treated trackpad as more of a driver and less of a program. Drivers (like graphics drivers) typically don't require anything to be closed first, so the thought of closing trackpad's control module first hadn't crossed my mind.


    Perhaps making this clear might help others out in the future?


    I'll take the opportunity now to thank you for the work you've done. A truly excellent tool!


    Much appreciated!

  • jls4592 Level 1 Level 1

    I'm having a problem with the program being out of date, i've downloaded 2.4a trackpad and the latest power plan; but still can't make it work?


    What should i do?

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @jls4592: The name of the current driver installer file shall be Trackpad_Plus_Plus_Driver_Control_Module_24a_Setup_05092013.exe, this file is not out of date. Please verify the name. The Power Plan Assistant is also OK, if you use the file from 05092013. Please try to re-download both again normally or directly from FileCluster in case of the date mismatch.

  • jls4592 Level 1 Level 1

    Thank You very much! I was going to the wrong site to get the downloads... defintly working now!

    Great job on the software!

  • V-l-a-d-i-m-i-r Level 1 Level 1

    @jls4592: Thank you for the feedback. Good to know everything is running OK now. Enjoy the Trackpad++!

  • timelover Level 1 Level 1

    Hello Vladimir.


    Im trying to run trackpad on a macbook air 2011 with Tiny 7 installed.


    I keep getting this communication with driver error. Is it due to the Tiny 7 OS or it might be something else?

Previous 1 41 42 43 44 45 Next