4 Replies Latest reply: Jun 15, 2010 2:50 PM by AuburnTigersFan
AnonyMouse Level 2 (260 points)
I'm unable to open any file or folder by double clicking on its icon whether the icon is on my desktop or in a folder.
For example, I can't open my hard disk or any DMG file on desktop by double clicking on its desktop icon, but I can open it or any file or folder by control-clicking on the icon and then clicking on 'open'.
In my Finder, If I double click on an item in 'list' I can open it and in' columns' if I double click on an icon in 'preview' it will open/ launch and in 'cover flow' if I select an icon and double click on it there the file will open/launch.
I've repaired permissions, 'verified disk' in Disk Utility (no problems found),
run Disk Warrior as well as Applejack but the problem persists.... I just can't open by double clicking.
Anyone have any ideas?

MacBook pro Penryn 17" 2.5 GHz, Mac OS X (10.5.8)
  • louie Level 4 (2,945 points)
    Pretty weird...but I think I've heard of it before. I have no direct answer, but when weird stuff like this happens, I think of trying things like:
    -boot from OSX DVD and check operation
    -Time Machine backup
    -Safe Boot - might correct something
    -log out of user account and/or log into another user account, and see if doubleclick returns
    -and the usual SMC/PRAM reset

    I'm assuming you've diddled with the mouse/trackpad settings. Did you try a mouse?
  • Richie Beno Level 1 (45 points)
    Probably not going to solve your issue, but have you taken a look at mouse settings, or trackpad settings in system pref's.

    Dont see an option for double click in mouse options other than speed, but in trackpad I think you can disable double click by unticking the "clicking" option. So if its not set then enable it.

    Other than that I cant help!
  • AnonyMouse Level 2 (260 points)
    Hey there guys, thanks for pointing me in the right direction;
    as a matter of fact I HAD been diddling with mouse settings, I totally forgot.
    I had double-click speed set at maximum fast.....I just moved the slider back to half way and, voila, problem solved. Whoohoo!
    What a dumb *** I am.
  • AuburnTigersFan Level 1 (0 points)
    And I want to thank you! I have a brand new laptop and suddenly this afternoon (after 3 hours in a project session at Apple this morning), I couldn't open a document by clicking. I slowed down the double-click thing and it works now! I love these forums