10 Replies Latest reply: Nov 3, 2010 10:06 AM by KasiaJoon
FIDO14 Level 1 Level 1 (0 points)
please all i need help
from December 2009 till now i am trying to connect to any WI-FI network and this message appear to me "UNABLE TO JOIN NETWORK" and i restored my iphone 3G many times to try to solve it and nothing new happend please i want help
my software is 3.1.3

iphone 3G, iPhone OS 3.1.3
  • waytogomate Level 1 Level 1 (0 points)
    I too have the same trouble as i have discovered today. I have an active wireless network (Linksys router) my Iphone can see the wireless network name (SSID) i enter the password and.. (unable to join network). I have turned the security off on the router,and i have (unable to connect) changed the mode to mixed protocol b and G. (Still nothing) The wireless channel is 2.442GHZ. I have no trouble connecting my macbook to the network. Is this a fault with s/w 3.1.3.--

    I have had success!! When entered the password touch the flashing icon and (select all) will appear touch it and then Join. hopefully Job Done!!
  • FIDO14 Level 1 Level 1 (0 points)
    which flashing icon ???
    i got tired from trying to connect
  • FIDO14 Level 1 Level 1 (0 points)
    which flashing icon??
    i got tired from trying to connect
  • waytogomate Level 1 Level 1 (0 points)
    At the password line enter your password, after you have entered it as the cursor (sorry) is blinking tap the cursor and hopefully (select all) will appear.
    Select this and then press Join.
  • FIDO14 Level 1 Level 1 (0 points)
    nothing happened !!!
  • waytogomate Level 1 Level 1 (0 points)
    Ok Then

    I have had a problem yesterday with again not wanting to go network and discovered after (tweeking) by changing the channels on the router from 6 to 11 and has helped me again.
    To change the channels go into the router settings mine is a linksys look in wireless and then basic wireless settings. Reason for this is i sat my phone next to the antenna of the router and there must have been a frequency interference from something else. And also to notice that the iphone did not auto fill in the, ip address, submask, router id, DNS and so on, when it was at the default channel (6) i did not know which channel to try and the first one i picked at the far end of the channels it auto filled in the settings of the router, and rejoined again. Fingers Crossed this time, i have had the same trouble as you however i have only been going at it for 2 weeks. Do you or someone have a laptop to hook up via the wireless router. If you do you all ready know the router is working. Oh also.. the frequency of the router is a digital signal @ 2.4GHz and can be subject to interference like any other frequency. ‹›
  • Mike Donscheski Level 1 Level 1 (0 points)
    I had this very problem last night. I've been running my iPhone 3 and iPhone 4 on my home network since I got them with no problems. After doing the basics, rebooting the iPhone, "forgetting the network", airplane mode on/off, I focused on the router. Although it appeared to be working (existing connected devices could still access the internet via ethernet or wireless), I found I couldn't access the router itself. So, I rebooted the router and was able to then connect with my iPhone with no problems. Hope that works for you!
  • CessNeo Level 1 Level 1 (0 points)
    I had this issue and was able to resolve this by changing the Channel Width (frequency) on which wireless is broadcast from the router. For the record, I am using Linksys Cisco WRT160N. Using the 20MHz only setting, I was able to connect to the wireless network using my iPhone 4, however, if I changed this option to be Auto (20MHz or 40MHz) I could no longer connect to the wireless network using my iPhone. Changing the setting back to 20MHz resolved the issue.
  • lemmywinks007 Level 1 Level 1 (0 points)
    This works for me as well. I'm using a WRT160N v3 Linksys router. When "Channel Width:" is set to 'Auto (20MHz or 40MHz)', my iPhone4 and iPad does not connect ('Unable to connect to network'). When "Channel Width:" is set to '20MHz only', both connect to the WiFi without any problem.

    1. Goto '' in your browser. Username is 'admin' and pw is 'admin' by default.
    2. Click on the 'Wireless' tab.
    3. 'Basic Wireless Settings' subtab, selected by default: Change 'Configuration View' to 'manual'.
    4. Default values are fine, but change the field labeled 'Channel Width' to '20MHz only'.
    5. Save Changes - Reconnect with your Apple hardware
  • KasiaJoon Level 1 Level 1 (0 points)
    Not sure if this will help you, but I had the same problem with my iPad, it would only connect to unsecured WiFi networks.

    After reading several threads and trying a multitude of solutions, I was finally able to connect and identified the following:
    - security couldn't be higher than WPA (WPA2 would not work)
    - SSID broadcast must be enabled
    - SSID must be all lower case and less than 5 characters
    - pre-shared key cannot be larger than 8 characters

    It is incredibly disappointing that my WiFi only iPad does not support better security than that. Had I known that I would never have bought it.