7 Replies Latest reply: Jul 23, 2010 11:08 PM by macsurferuk
davidemm Level 1 Level 1 (0 points)
My iPhone has stopped recognizing one of my contact's numbers. In the calls and visual voicemail lists it just displays the number rather than the name (for either of the contact's numbers--home or mobile). However, it does display the name when calling or receiving a call, and when I enter the number in on the keypad. This never used to be a problem. One day a few months ago, without having modified the contact, this problem appeared and has remained ever since.

I have removed and re-added the contact several times. I have separated the home and mobile number in different contacts. This is not a number format issue--while I normally store all of my numbers as +1 (xxx) xxx-xxxx (which works for every other contact, and used to work for this one), I have also tried saving this contact's numbers as (xxx) xxx-xxxx, 1 (xxx) xxx-xxxx, etc.

Apple Support also suggested that I delete my entire text message thread with this contact, which I did. An upgrade to OS 3.1.2 also did not help.

Not a terribly important problem, but it bothers me a lot as this is someone I contact very frequently. I wasn't able to find much documentation on this problem--any suggestions?

iPhone 3GS 16GB, iPhone OS 3.1.2
  • modular747 Level 6 Level 6 (18,090 points)
    An upgrade to OS 3.1.2 also did not help.
    Not a terribly important problem

    I guess not all that important to you either since 3.1.2 was replaced months ago and is no longer available from Apple... Are using hacked - jailbroken/unlocked firmware? Are you using the correct Region Format for your area?

    Message was edited by: modular747
  • davidemm Level 1 Level 1 (0 points)
    modular747 wrote:
    I guess not all that important to you either since 3.1.2 was replaced months ago and is no longer available from Apple... Are using hacked - jailbroken/unlocked firmware? Are you using the correct Region Format for your area?

    Message was edited by: modular747


    Ok...since you seem to care, I left for overseas in January and just returned to the U.S. Now that I am using my iPhone again, I would like to try and fix this problem. Though it's not that serious, it bothers me. I tried to fix it before I left, but Tech Support didn't know much about this problem so I thought I'd try here.

    Yes, using standard U.S. formatting. As I said, this is not a formatting issue--all of my other contacts work. My iPhone is not jailbroken and is locked to AT&T.

    Is anyone else having this problem or have solutions??
  • modular747 Level 6 Level 6 (18,090 points)
    The only explanation is corrupted data on your phone. You should do the basic troubleshooting steps described in the user guide, as needed.

    1. Reset phone - press both home and sleep wake buttons until the Apple logo appears.
    2. Restore in iTunes using a backup.
    3. Restore as a new iPhone if needed - the backup may contain the corrupted data.
  • Amack1985 Level 1 Level 1 (0 points)
    I am having this same problem too, though my just recently started to happen. I have already restored from backup with no luck and was wondering if restoring to new fixed the problem?
  • Tristan Dehlinger Level 1 Level 1 (0 points)
    I am having this same problem as well. I did a complete restore of my iPhone 36 and set it up as a new phone hoping it would help speed it up. It has been god awful slow since the iOS 4 upgrade. So now when I get a text message it pops up with the preview showing the persons name. When you go into the messaging app it only shows the phone number and even has the button at the top "add to contacts".

    Never had this problem before doing the restore and setup today.
  • mbellissimo Level 1 Level 1 (0 points)
    I have begun to have this same problem since migrating from my iPhone 3G to the iPhone4. I did the OS upgrade prior to getting the new phone. I get texts from know individuals in my contacts list and the header data is missing (no contact name or number). But the connection is there since when I click on "Call" it does call the right person. When I click on "Contact" it does not make the connection. After checking the online support postings I am conforming with all of the standards re contact info (and, nothing changed from before when it was working, other than the new phone upgrade).
  • macsurferuk Level 1 Level 1 (0 points)
    Im having the same issue with about half of mt contacts now just appearing numerically. Im on a 3gs with ios4.