7 Replies Latest reply: May 24, 2010 6:58 PM by BDAqua
loweman01 Level 1 Level 1
I'm running Mac OSX 10.4.11 on a Dual 2GHZ PowerPC (Power Mac) G5 and would like to TRY and upgrade the processor so that I can install later version of OSX (like 10.5 an 10.6 etc) Is this possible or am I just out of luck??? Any help would be appreciated.

Mac tower G5, Mac OS X (10.4.11)
Solved by BDAqua on May 24, 2010 5:14 PM Solved
Don't most of the software that runs a min of 10.5.7 or higher require an Intel based processor to work??


Nope, 10.5 is at 10.5.8 at the moment & works fine on PPC Macs, only 10.6 & up require an IntelMac.
  • Niel Level 10 Level 10
    No, but you don't need to have an Intel Mac to use Mac OS X 10.5, except for Boot Camp. Boot Camp and Mac OS X 10.6 require an Intel Mac.

    (51892)
  • loweman01 Level 1 Level 1
    Thanks! See, I was doin my research and thats what I figured that I didn't need it to run 10.5 on a powerPC but some TARD at the APPLE Store ( whom I'm sure was a newbie cuz he was askin for help on the question) told me I couldn't. Don't most of the software that runs a min of 10.5.7 or higher require an Intel based prosessor to work?? They are already on 10.6 and I feel like Im fallin behind and sooner rather than later, I will have a useless machine.
  • BDAqua Level 10 Level 10
    Don't most of the software that runs a min of 10.5.7 or higher require an Intel based processor to work??


    Nope, 10.5 is at 10.5.8 at the moment & works fine on PPC Macs, only 10.6 & up require an IntelMac.
  • loweman01 Level 1 Level 1
    Gotcha, thanks for the help
  • BDAqua Level 10 Level 10
    Great news, thanks!

    Apple doesn't list it for sale or have it in their Stores anymore, you have to call Apple & ask for it, and you may have to ask for a product specialist if you're told they don't have it.

    Don't wait too long to get it though.
  • loweman01 Level 1 Level 1
    ohh your talking bout 10.5 right??? Yea, i went looking in the apple store for it but no luck, it's all good. I know some folks that have it. I can borrow it.
  • BDAqua Level 10 Level 10
    ohh your talking bout 10.5 right?


    Yep, plain old Leopard/10.5.x.